Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will not work with Google, GMail, or Google Search

  • 28 replies
  • 110 have this problem
  • 1 view
  • Last reply by AliceWyman

more options

I have a client that uses Google for e-mail and calendar. I am constantly on this site. I noticed last Friday that Google, GMail and Google search will not work on Firefox. When I go to the website for my client it spins says connecting and then just stops. When I try to put a search in the Google search box nothing happens. It's like I did absolutely nothing.

I need this access. I use Firefox because I develop websites and like the developer add-ons. There has to be a fix for this. Please let me know when this is fixed.

All Replies (20)

more options

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r (Mac: Command+Shift+r) to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

(WIN) orange Firefox button (or Tools menu) > Options > Advanced
(MAC)Firefox menu > Preferences > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, remove your Google cookies individually.

Then try reloading the page. Does that help?

more options

That was the very first thing I tried. I have cleared the cache and the cookies via the Tools menu and also went in to Preferences, Advanced, Network. Still will not work.

more options

Do you have any privacy-related extensions that might impact Google services? I think people have reported some issues with Disconnect and Ghostery, for example.

more options

I have contacted my security provider, which is Intego. My daughter is also on Intego and she does not have this problem.

I have downloaded, several times, a new Firefox thinking the one I had was corrupted and I still have the same problem.

more options

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

more options

I have no idea what the problem was or if clearing the cache several times, etc. but I got Firefox and Google to start working. There are a few glitches but everything is able to run. Thanks for all of your suggestions

more options

I spoke too soon. My Firefox is not working with Google again. I tried to find the cookies.sqlite file on my computer and it did not show up anywhere. Therefore, I have to assume I don't have that file. Is there somewhere I need to look specifically for it? I am on a Mac. Are there any other possibilities that I can try to get Firefox and Google to work together again?

more options

Have you tried Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Does Google work any better?


I think MacOS X hides your Firefox settings folder (AKA your profile folder). To open it directly, try:

Help > Troubleshooting Information > "Show in Finder" button

You should quit out of Firefox before changing files in that folder because many will be updating during Firefox's shutdown process.

more options

I opened Firefox in Safe Mode and there was no difference. I also found the file cookies.sqlite and renamed it cookies.sqlite.old. I deleted the 2 other cookies files. Still no difference. I am still unable to get a google search or log into a google account.

more options

Had this problem this morning and it is now fixed.

1. Open Firefox Browser

2. Type about:config in location bar and press ENTER

A message will come up "This might void your warranty" Select, I'll be careful, I promise.

3. Search for configuration key, keyword.URL and highlight it

4. Right Click on the configuration key, keyword.URL and choose RESET from the shortcut menu.

Firefox automatically resets the value to:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

5. If the RESET option is greyed out in the shortcut options, select NEW and type in the google search location

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

and press OK.

If you are not comfortable with having changed the default URL, you can now go back to the shortcut option and select RESET, which will do exactly the same thing.

A further problem I found that causes the Firefox Google Search function not to work

Go to the Firefox dropdown menu. Select Options (Underneath Add-Ons), and sub-menu Options.

A page should display showing the following information:

Warn me when sites try to install Add-Ons Block reported attack sites Block reported web forgeries.

I have these all ticked.

Go to the EXCEPTIONS Tab and Delete the default options Mozilla Firefox has loaded, as if there are any sites in the Exceptions, the browser will not work for some reason.

Your Firefox Google Search function will now work again, and you are back in business searching using Firefox Google.

If you run into problems again, go to Options, Options, Exceptions and make sure there are no sites in the Exceptions list.

.... Enjoy.

Cheryl

more options

See next post

Modified by jscher2000

more options

Hi FirefoxGoogleFix, when you open this dialog --

orange Firefox button > Options > Options or
Tools menu > Options

-- there are Exceptions buttons on several different tabs (e.g., popup windows, cookies, software installation). Which exact type of exceptions need to be cleared or Google will be blocked?

more options

Orange Firefox Button Options (Underneath Add-Ons Button) Options Security Exemptions

I had 3 x default Add-On files loaded by Firefox, which I cleared, and the Search Function now works, but I couldn't tell you if it was only one of the 3 x default files affecting it working as I have deleted them, sorry.

more options

Hi FirefoxGoogleFix, Firefox normally doesn't include any extensions or load any behind your back. You might want to run some supplemental malware scans. These three tools are highly regarded (and free):

more options

Please NOTE: You need to go to the Security TAB, as per the notes below. ..... Wasn't clear initially. This is in addition to the Keyword.URL fix provided initially.

Go to the Firefox dropdown menu. Select Options (Underneath Add-Ons), and sub-menu Options. SECURITY TAB

A page should display showing the following information:

Warn me when sites try to install Add-Ons Block reported attack sites Block reported web forgeries.

I have these all ticked.

Go to the EXCEPTIONS Tab, (In the Security TAB options) and Delete the default options Mozilla Firefox has loaded, as if there are any sites in the Exceptions, the browser will not work for some reason.

Your Firefox Google Search function will now work again, and you are back in business searching using Firefox Google.

If you run into problems again, go to Options, Options, Security TAB, Exceptions and make sure there are no sites in the Exceptions list.

The sites in my list were all Mozilla Firefox Add-Ons which were causing me problems.

more options

Hi FirefoxGoogleFix, you wrote:

Go to the EXCEPTIONS Tab, (In the Security TAB options) and Delete the default options Mozilla Firefox has loaded, as if there are any sites in the Exceptions, the browser will not work for some reason.

The list of sites allowed to install add-on shouldn't affect whether you can use Google. I suspect there is some other problem with your Firefox.

more options

There is no problem with my Firefox Google search.

It is working fine, after I made the changes I have advised.

Just trying to assist others with the same problem.

Funny thing is, Firefox Google Search wasn't working for 2 days.

Searched the web and the Mozilla Forum has offered no solution over many months.

Fixed it myself, and try to let others know on the forum, and get all my posts marked as not useful, and told I must have a problem on my computer when it is working fine.

All Good. No need to post anymore, as what worked for me obviously wont work for others.

I am happy I tried to help for those who may find what I posted useful.

Have a Nice Day

Cheryl

more options

For those who want to know,

Also go to Firefox Drop Down Menu, Add-ONs, and DISABLE any Add-Ons in the Extensions and Plug-Ins Tabs, as these also appear to affect the Firefox Google Search function if they are enabled.

Thanks

more options

I woke up this morning to the same problem, but my solution was much easier...I went into Ghostery settings and, quite easily actually, found out what was causing the problem for me. Through just a couple of minutes of trial and error, I identified what the cause of my blank google search page was. Make sure to uncheck the 'Google AJAX Search API box in the Widget section of Ghostery. All of the other options can be checked EXCEPT that one :)

Enjoy! It worked for me - let me know how it turns out for you.

more options

I ended up going to Chrome and still have some trouble with Google Calendar loading. I have to refresh several times.

  1. 1
  2. 2