X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does Firefox garble my on screen text. when I use my Windows zoom to larger text it stops.Other browsers don't do this.

Posted

The text becomes garbled (blurred) at smaller font sizing. When I increase the font size using Windows zoom feature the garbled blurreness goes away. I am running Windows 7 Home Premium with a PLANAR PXL 2430 MW monitor with an ATI Radeon HD 2600 XT graphics card.

This issue does not happen in Internet Explorer or Google Chrome.

Please advise

Chosen solution

Some font rendering issues are caused by graphics driver incompatibilities. Could you try disabling Firefox's use of hardware graphics acceleration?

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the display improved?

Read this answer in context 8

Additional System Details

Installed Plug-ins

  • Motive Plug-in for Mozilla Browsers
  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.4"
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Google Update
  • 5.1.20125.0
  • Amazon MP3 Downloader Plugin 1.0.17
  • SiteAdvisor
  • McAfee Virtual Technician plugin
  • McAfee MSC FF plugin DLL
  • Motive Management Plug-in for Mozilla Browsers

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF})
  • McAfee SiteAdvisor 3.6.0 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Yahoo! Toolbar 2.5.9.20130409112616 ({635abd67-4fe9-1b23-4f01-e679fa7484c1})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 2600 XT
  • adapterDescription2:
  • adapterDeviceID: 0x9588
  • adapterDeviceID2:
  • adapterDrivers: aticfx32 aticfx32 atiumdag atidxx32 atiumdva
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 4-19-2011
  • driverDate2:
  • driverVersion: 8.850.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 2600 XT)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 215040
  • browser.display.use_document_fonts: 0
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://my.yahoo.com/
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • dom.w3c_touch_events.expose: True
  • extensions.lastAppVersion: 20.0.1
  • font.default.x-western: sans-serif
  • font.minimum-size.x-western: 12
  • font.name.monospace.x-western: Bookman Old Style
  • font.name.serif.x-western: Arial
  • font.size.fixed.x-western: 14
  • gfx.direct3d.checkDX10: False
  • keyword.URL: http://search.yahoo.com/search?fr=mcafee&p=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1366215859
  • places.history.expiration.transient_current_max_pages: 10457
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: Yes
jscher2000
  • Top 10 Contributor
2344 solutions 20791 answers

Chosen Solution

Some font rendering issues are caused by graphics driver incompatibilities. Could you try disabling Firefox's use of hardware graphics acceleration?

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the display improved?

Helpful Reply

Your response was right on. Thank you for the resolution.