X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 19.0.2 can't browse the file system.

Posted

As the subject line reads I am using Firefox 19.0.2 Extra info: OS: Kubuntu 12.04 Mem: 4GB Please ask if you need more information.

When I try to open a local file system page such as: file:///home/username/documents/webnotes/

Where in that directory are a bunch of html files that I should be able to open in firefox, and lets say for the sake of the question I have file01.html, file02.html, and file03.html in the above directory. Then if I hover my mouse over file01.html, then the little text link display box in the lower left corner of the window shows this: file:///home/username/documents/webnotes/# when it should show this: file:///home/username/documents/webnotes/file01.html and if I click on the file01.html file nothing happens and I'm stuck in the same directory listed above.

Whats even more strange is that if I type in the complete URL into the address bar such as: file:///home/username/documents/webnotes/file01.html Then the file opens as it should, but this is an impossible pain if I'm trying to navigate from one directory to the next because the same thing happens if I am pointing the browser at: file:///home/username/documents/ From there I can't click on or navigate to the webnotes directory unless I type it by hand into the address bar.

Note: This was working fine in previous versions of firefox.

Questions: 1.) How can the problem described above be fixed or probed further for troubleshooting?

Thanks

Additional System Details

Installed Plug-ins

  • Java plug-in for NPAPI-based browsers.
  • Shockwave Flash 11.2 r202
  • Mime Type x-skype for Skype Buttons
  • LibreOffice Plug-in handles all its documents
  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • Version 2.0.3 Twoflower, copyright 1996-2011 VideoLAN and Authorshttp://www.videolan.org/vlc/
  • Gecko Media Player 1.0.4Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/Linux/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.7 (adblockpopups@jessehakanen.net)
  • AIO Search Toolbar 1.5 (ASToolbar@aiosearch.com)
  • Block Site 1.0.3 ({dd3d7613-0246-469d-bc65-2a3cc1668adc})
  • Boo.ly Shopping 3.001 (getbooly@boo.ly)
  • CLEO 5.0.1 (CLEO@guid.customsoftwareconsult.com)
  • Customizations for Adblock Plus 1.0.3 (customization@adblockplus.org)
  • DownloadHelper 4.9.14 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • DownThemAll! 2.0.15 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • DownThemAll! AntiContainer 1.2.3 (anticontainer@downthemall.net)
  • Element Hiding Helper for Adblock Plus 1.2.3 (elemhidehelper@adblockplus.org)
  • FEBE 7.1.0 ({4BBDD651-70CF-4821-84F8-2B918CF89CA3})
  • Flash and Video Download 1.30 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a})
  • Flash Video Downloader - Youtube Downloader 3.8.7 (artur.dubovoy@gmail.com)
  • Global Menu Bar integration 3.7.2 (globalmenu@ubuntu.com)
  • Grab and Drag 3.1.2 ({477c4c36-24eb-11da-94d4-00e08161165f})
  • Image Zoom 0.4.6 ({1A2D0EC4-75F5-4c91-89C4-3656F6E44B68})
  • Noia 4 Theme Manager 1.8.0 (Noia4Options@ArisT2)
  • OPIE 4.0 (OPIE@guid.customsoftwareconsult.com)
  • PrefBar 6.2.0 ({8A6C82A1-F6C9-481a-AAE7-C96444C9A754})
  • Restart Firefox 0.5 (restart@restart.org)
  • Search Image Everywhere 1.1 (images@snark.co.il)
  • Session Manager 0.7.9.6 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Session Manager Export Tool 0.2 (sessionmanagerexporttool@tijtij.com)
  • TableTools2 1.17 (tabletools2@mingyi.org)
  • Thumbnail Zoom Plus 2.4 (thumbnailZoom@dadler.github.com)
  • TinEye Reverse Image Search 1.1 (tineye@ideeinc.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Ubuntu Firefox Modifications 2.6 (ubufox@ubuntu.com)
  • Updated Ad Blocker for Firefox 11+ 0.7.7 ({4DC70064-89E2-4a55-8FC6-E8CDEAE3618C})
  • Xmarks 4.1.3 (foxmarks@kei.com)
  • Cite This! 0.20 (citethis@angelforge.org) (Inactive)
  • Novell Moonlight 3.99.0.3 (moonlight@novell.com) (Inactive)
  • Zotero 3.0.11 (zotero@chnm.gmu.edu) (Inactive)
  • Zotero LibreOffice Integration 3.5.6 (zoteroOpenOfficeIntegration@zotero.org) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Corporation -- GeForce 8800 GT/PCIe/SSE2
  • adapterDeviceID: GeForce 8800 GT/PCIe/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: NVIDIA Corporation
  • driverDate:
  • driverVersion: 3.3.0 NVIDIA 304.84
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- GeForce 8800 GT/PCIe/SSE2
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.browsewithcaret: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #333333
  • browser.display.foreground_color: #FFFFFF
  • browser.display.use_document_colors: False
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: about:blank
  • browser.startup.homepage_override.buildID: 20130307122903
  • browser.startup.homepage_override.mstone: 19.0.2
  • browser.tabs.onTop: False
  • browser.urlbar.autocomplete.enabled: False
  • browser.urlbar.trimURLs: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • font.name.serif.x-western: DejaVu Sans Mono
  • font.size.fixed.x-western: 16
  • font.size.variable.x-western: 18
  • network.cookie.prefsMigrated: True
  • network.http.sendRefererHeader: 0
  • places.database.lastMaintenance: 1363792104
  • places.history.expiration.transient_current_max_pages: 103649
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.soname.list: libXext.so
  • privacy.clearOnShutdown.extensions-dta: True
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.cpd.extensions-dta: True
  • privacy.cpd.extensions-sessionmanager: False
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.enable_java: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
iamjayakumars
  • Top 10 Contributor
418 solutions 4938 answers

Helpful Reply

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Question owner

Yes, this seemed to fix the problem, but may I please have some follow up information?

Note: I have reinstalled all of the plugins and reconfigured firefox to the state it was in before the fix was applied, and the problem with navigating the local file system is still solved, so this seems like it was not an issue with one of the plugins.

Was the procedure you had me follow refered to as starting firefox in "safe mode", and what are some of the reasons this might have fixed the problem and what made you think to suggest this as a solution to the problem?

Last question: Will marking this thread as solved keep you from being able to respond to my last question (like it would in other forums) or is it ok to mark a thread as solved and ask follow up questions afterwords?

Thanks for the help.

Modified by firefoxuser1138

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97064 answers

If it happens again then you can first try some basic steps like these:

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.