X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox always crashes after the update of the newest flash version (11.6.602.171). I've to disable flash to use my browser. What can I do?

Posted

The title above sums my problems up. My Firefox version is 19.0 and I'm running Windows 8.

Chosen solution

I've found the mms.cfg file.

In Windows8 it's stored under: windows\SysWOW64\Macromed\Flash !

I changed the file, like mentioned in the link above ( http://techdows.com/2012/06/disable-flash-players-protected-mode-for-firefox.html ), and it works!!!!

Great, thank you again feer56.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.15.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • PDF-XChange Viewer Netscape Gecko Plugin
  • 5.1.10411.0
  • Office Live Update v1.5

Application

  • Firefox 19.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0/WINNT/de/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • BetterPrivacy 1.68 ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3})
  • Exif Viewer 2.00 (exif_viewer@mozilla.doslash.org)
  • ProxTube - Gesperrte YouTube Videos entsperren 1.4.6 (ich@maltegoetz.de)
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Xmarks 4.1.3 (foxmarks@kei.com)
  • avast! WebRep 7.0.1474 (wrc@avast.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 630
  • adapterDescription2:
  • adapterDeviceID: 0x0f00
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2047
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16433
  • driverDate: 2-9-2013
  • driverDate2:
  • driverVersion: 9.18.13.1407
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 630)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.spiegel.de/
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1361636818
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.clearOnShutdown.extensions-betterprivacy: True
  • privacy.clearOnShutdown.formdata: False
  • privacy.cpd.extensions-betterprivacy: True
  • privacy.cpd.formdata: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3018 answers

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox and any leftover program files and then reinstall Firefox. Please follow these steps one by one:

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu) and confirm all upcoming messages.
  3. Now, uninstall Firefox by following the steps mentioned in the Uninstall Firefox article.

IMPORTANT: On Windows, the uninstaller has the option to remove your personal data and settings. Make sure that you do not check this option; otherwise all of your bookmarks, passwords, extensions, user customizations and other Firefox user profile data will be removed from your computer.

After uninstalling Firefox on Windows, delete the "Mozilla Firefox" program folder, located by default in one of these locations:

  • (On 32-bit Windows) C:\Program Files\Mozilla Firefox
  • (On 64-bit Windows) C:\Program Files (x86)\Mozilla Firefox
  1. Go to the Windows Start menu and click on "Computer".
  2. In the Explorer window that opens, double click Local Disk (C:) to open the C:\ drive.
  3. Find the "Program Files (x86)" folder or "Program Files" folder.
    • On 32-bit Windows, double-click the Program Files folder to open it.
    • On 64-bit Windows, you will see a "Program Files (x86)" folder AND a "Program Files" folder. Open the Program Files (x86) folder.
  4. Look for a Mozilla Firefox folder. If you find one, right-click it and select Delete and confirm that you want to move the folder to the Recycle Bin.

Now, go ahead and reinstall Firefox:

  1. Double-click the downloaded installation file and go through the steps of the installation wizard.
  2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!

Question owner

feer56, thank you for your answer.

Well, my Firefox installation is just only 3 weeks old – but it seems your suggestion could be the only solution.

What a poor performance either by Adobe and/or Firefox.

Question owner

I just did a reinstall and was gone through all the proposed steps

– but after installing flash

– Firefox freezes again!

Help!

Question owner

BTW

If it matters:

the Firefox version I've used for the new installation is the German version of 19.0.1

Question owner

It could be a Windows 8, 64bit related problem:

https://bugzilla.mozilla.org/show_bug.cgi?id=814963

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3018 answers

Helpful Reply

Try viewing this: http://techdows.com/2012/06/disable-flash-players-protected-mode-for-firefox.html

DISCLAIMER: The above-mentioned URL would take you to a non-Mozilla Web site. Mozilla does not control it and is not responsible for information outside of Mozilla web sites.

Question owner

Thank you feer56 – but there is no "mms.cfg" file under WINDOWS\System32\Macromed\Flash on my computer.

Chosen Solution

I've found the mms.cfg file.

In Windows8 it's stored under: windows\SysWOW64\Macromed\Flash !

I changed the file, like mentioned in the link above ( http://techdows.com/2012/06/disable-flash-players-protected-mode-for-firefox.html ), and it works!!!!

Great, thank you again feer56.

Modified by rodelaax