X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Cannot disable plugin-container in Firefox 18. Did all in "about-config" and it is still there. Help or I am quiting Firefox

Posted

Cannot disable plugin-container in Firefox 18. Did this: dom.ipc.plugins.enabled;false dom.ipc.plugins.flash.subprocess.crashreporter.enabled;false dom.ipc.plugins.java.enabled;true ….and it is still showing in my CPU.
Please, Help or I am quitting Firefox

Modified by Noah_SUMO

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • VLC media player Web Plugin 2.0.2

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello, waht do you want to achieve by disabling the plugin-conatiner? (it's there for increased stability & performance)

in case you want to disable the plugin-container for java you'll have to keep dom.ipc.plugins.java.enabled set to false.

gonehazel 0 solutions 13 answers

Helpful Reply

Having dom.ipc.plugins.java.enabled set to false doesn't do a thing - flash still automatically starts plugincontainer.exe. AND, for the record, the plugin container definitely DOES slow down your processor considerably. Firefox has really gone down the tubes. Unfortunately there's no browser that gives users what they really want: speed without hassles. Maybe someday...

Modified by gonehazel

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96858 answers

The Flash plugin is forced to run in a plugin-container process because Adobe doesn't do any testing in normal mode anymore on current Windows versions (Vista+).

  • bug 769721 - Force-enable OOPP for Flash users on Windows Vista+

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

silkphoenix 92 solutions 1250 answers

Helpful Reply

Most of the time, if not all, the plug-in container for Flash is the culprit which slows down the PC/browser. It seems like it's getting worse as newer versions of FF comes out. After update to FF 19, I have to disable the plug-in container continuously (every few hours or so) in order for FF and my PC to be back to normal.

If Mozilla will or able to, somehow find a solution to solve this problem, that'll improve FF performance tremendously.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

maybe it's an issue with the protected mode in the flash plugin - you could try if downgrading to flash 10.3 (which is still supported) or disabling protected mode makes a difference.

silkphoenix 92 solutions 1250 answers

madperson -- Will it be a good idea to downgrade the Flash? I think there might be a security risk.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

as stated before, the 10.3 branch of the plugin is still supported by adobe and receives security fixes: https://www.adobe.com/products/flashplayer/distribution3.html