Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Btsearch, avg.name homepage removal


I downloaded the youtube.downloader file under the demonoid bit torrent disguise. Firefox was is my default browser. Even after uninstalling the downloader, the btsearch, avg.name kept coming up as my homepage. Antivirus and Malware will not detect this. I started up in safe mode, uninstalled firefox, and used IE as to download firefox again. Problem still existed. I uninstalled again, then did a file search of "Mozilla" on my hard drive. I came across a Mozilla Firefoxoverride config file. I deleted this file reloaded firefox and works fine. All the other support sites take you through the registries, downloading software, etc... blah blah blah. I just wanted to put this out there to help anyone else coming across this annoying problem. This may not fix your issue, but it is a possibility to try.

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • Adobe Shockwave for Director Netscape plug-in, version
  • Google Update
  • iTunes Detector Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Adobe Shockwave for Director Netscape plug-in, version
  • 5.1.10411.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers


  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

  • Top 10 Contributor
  • Moderator
10761 solutions 96854 answers

What home page do you use?

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

Try to reset some preferences to the default with the SearchReset extension:

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

Question owner

This really was not a question, but a solution and had nothing to do with the search engine.

I posted it here, because no other site had the solution to the problem. I use yahoo as my homepage. I could reset it in the options section, but when you close firefox, it would automatically revert back to avg.name. When you opened the options, it would be listed as avg.name as your homepage. I tried solutions on other sites, but nothing worked. I un-installed firefox, then did a a search of Mozilla to see what files were still remaining that could keep redirecting my homepage automatically back to the avg.name. That was when I came across the override config file as stated above. If you do a search of this problem, you will see that no one has a clear solution and it has not been addressed here. I just wanted to give a solution. Attached is a screen shot of the file in my recycle bin.

splashmywtrfall 0 solutions 2 answers

so I have this problem but I use internet explorer AND am operating in windows 8 right now. ive pretty much figured the system out, but it does have its qwerks. I would try everything you said @rpmjack, but clearly override firefox isn't my option. I suppose I can look for internetexplorer but we shall see.

splashmywtrfall 0 solutions 2 answers

okay, so I went into computer and just searched the term override and found the avg.override file. when I attempted to delete that file it kept interrupting saying an unexpected error was keeping me from deleting the file.. I went into task manager made sure all programs under youtube download was ended and after trying again several times, I had to just skip. ultimately, it worked!! I restarted my computer just to make sure, and all it well.

Note: there is one tine snippet of a file left in my computer associated with the avg. file, but it doesn't appear to affect anything. im not exactly a professional to remove it.

munner2020 0 solutions 4 answers

Thank you very much! I will try this and get back to you. THIS is why I continue to love Firefox!!


kondoril 0 solutions 15 answers

I wonder why after so many months... (I saw that people wrote about btsearch more that 6 months ago)... there is no proper solution to this issue...

all the "solutions" found on the web do not help

munner2020 0 solutions 4 answers

Helpful Reply

I am having exactly the same problem!! Nothing works, and for that reason I have switched to Chrome until someone at Mozilla takes this seriously!!!


munner2020 0 solutions 4 answers

Tried this. Didn't help!


kondoril 0 solutions 15 answers

I agree... no more Firefox till they solve it

KMcD 0 solutions 2 answers

I Had This Problem - But It was in Chrome'

Everytime I started Chrome I would see avg.name in the address bar. But the one difference was it would show a link to "Lucidchart Diagramming Tab Plus"which was an extension that I had installed - and it was enabled. BUT I had not "Activated" the extension since You had to sigh in to Google to be allowed to activate the extension.

  • The extension thought it was active because I enabled it
  • The website wouldn't accept any communication because Google hadn't activated.permission to use it

When I disabled the extension Lucidchart the everything reverted to normal and avg.name didn't show up anymore.

It strikes me that the browser had a conflict every time it opened. It couldn't ensure that all the active extensions were linked to their appropriate websites if necessary.

When I did a whois on avg.name it indicated that the name was specific to an Internet Registry that hellps (?) assign IP's/ensure that identification on the internet was clear.,

It's possible IMO the appearance of avg.name in the address bar may indicate a conflict within the browser. The fact that this issue has been reported in IE, Firefox, and Chrome within this forum suggests that the problem is not due to the browser specifically but is indicative of a common issue - a conflict in identifying an appropriate link.

I try to document the entire process if anyone's interested - but this is a Mozilla forum and all I wanted to do was log my solution and the fac that this was a generalized problem and not specific to Firefox.

P.S. I use chrome for a specific purpose but Firefox is my main browser,

kondoril 0 solutions 15 answers

I had the same "virus" or malware inside chrome.. but I did not have this extension On the other hand... it was very simple to kick it off the chrome... I entered the list of the search engines and deleted it.. it never returned.. But When I did the same thing on Firefox.. it desappears but it keeps retuning every new session... So.. I'm sure that this is some virus or malware that needs to be solved

KMcD 0 solutions 2 answers

Thank you for your comment. I never even thought of looking for avg.name as a search engine. It wasn't really acting as a search engine in my case, it was just sitting in the address bar box, like I had typed it in.

I wasn't suggesting that the specific extension caused the state of the browser. I was noting that a minor conflict in how I had configured the browser, that I had ignored, seemed to have triggered avg.name to appear.

I don't think this is malware. The same type of problem has started manifesting in 3 separate, and very different browsers at around the same time. .

So what's different in that time?

  • what could be affecting all three browsers?
  • This is (I think) all within the last month
  • It affect how the browsers function at opening
  • a normal method of dealing with the opening of the browser is conflict ed

Has anyone else just installed PeerBlock recently? That program controls what IP's are allowed to interact with your computer?

kondoril 0 solutions 15 answers

The problem still exists. The AVG antivirus and malware detecting software did not find anything. I deleted a "custom search.xml" file which had the "http://btsearch.name" inside it.. I reseted the homepage and every resettable url startup but this btsearch keeps coming each time I start firefox. this is annoying and I wonder why mozilla does nothing to solve it

This is the file I mentioned:

<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/" xmlns:os="http://a9.com/-/spec/opensearch/1.1/"> <os:ShortName>Custom search</os:ShortName> <os:Description>Custom search search</os:Description> <os:InputEncoding>UTF-8</os:InputEncoding> <os:Image width="16" height="16">data:image/x-icon;base64,AAABAAEAEBAAAAEAIABoBAAAFgAAACgAAAAQAAAAIAAAAAEAIAAAAAAAQAQAAAAAAAAAAAAAAAAAAAAAAAD///5EufL/1kve/+0P1P/tB9L/7THZ/+2i7/3tr9Sl7Q+EDu0AfgDtAYAB7QGAAe0BgAHtAYAB7QOBA90BgAFZpO7/0gHQ//8Az///ANL//wDS//8A0P//AM///6/3//+z1ab/AnwC/wB/AP8AgAD/AIAA/wCAAP8AgAD/AIAA5Tfb/+sAz///ANL//wDS//8A0v//ANL//wDP//9T4v/////7/yKRIf8AfAD/AIAA/wCAAP8AgAD/AIAA/wCAAO9a4v/oAM7//wDS//8A0v//ANL//wDR//8Az///qPD//////f8plCn/AHwA/wCAAP8AgAD/AIAA/wCAAP8AgADt4P//6Dnk//8A0///ANH//wDQ//8Az///euf////////a7Nn/CYMJ/wB+AP8AgAD/AIAA/wCAAP8AgAD/AIAA7f9paOz5zM3/quf2/2ji/v9Z3fz/ou7/////////////U6lT/wB6AP8AgAD/AIAA/wCAAP8AgAD/AIAA/wCAAO3/AADt/wIC//8lIv//S0n//+/t///////4+/f/Yq9i/wB6AP8AgAD/AIAA/wCAAP8AgAD/AIAA/wCAAP8AgADt/wAA7f8AAP//AAD//zc3///////1+vX/S6VL/wB3AP8AgAD/AIAA/wCAAP8AgAD/AIAA/wCAAP8AgAD/AIAA7f8AAO3/AAD//yUl//9paf//////4v3v/wCAAP8AfAD/AIAA/wCAAP8AgAD/AIAA/wCAAP8AgAD/AIAA/wCAAO3/QkLt/8XF///m5v//Zmb//0BA//+pq/+i2av/B4AI/wB/AP8AgAD/AIAA/wCAAP8AgAD/AIEA/wCEAP8AhQDt//r66f//////WVn//wAA//8AAP//AwP//+Ps/6rbsf8EeQ3/AIQA/wCIAP8AiAD/AIcA/wGCAP8CbC//AzKf7f///+j/ycn//wAA//8AAP//AAD//wAA//+lpP//////VGPf/wAnrv8COpH/ATuN/wIxo/8CG83/AQP6/wAA/+3////o/4OD//8AAP//AAD//wAA//8AAP//paX//////4B8//8AAP//AAD//wAA//8AAP//AAD//wAA//8AAP/t////6/9ubv//AAD//wAA//8AAP//AAD//9XU//////9eXv//AAD//wAA//8AAP//AAD//wAA//8AAP//AAD/8P7//8f/pKT//wAA//8AAP//AAD//1dX/////v/m5///FRX//wAA//8AAP//AAD//wAA//8AAP//AAD//wAA/938/f0x//r6w/9+fur/Njbq/3Bw6v/09Or19v/rUFD/7AIC/+0EBP/tAwP/7QIC/+0BAf/tAQH/7QIC/9ABAf5FAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA==</os:Image> <UpdateInterval>7</UpdateInterval> <UpdateUrl></UpdateUrl> <IconUpdateUrl></IconUpdateUrl> <SearchForm></SearchForm> <os:Url type="text/html" method="GET" template="http://btsearch.name/results.php?q={searchTerms}"/> <os:Url type="application/x-suggestions+json" template="http://suggestqueries.google.com/complete/search?output=firefox&client=firefox&hl=en&q={searchTerms}"/> </SearchPlugin>

munner2020 0 solutions 4 answers

I tried this and the same damn thing came back. It srarts with an Avg file, andbthen btsearch appears! ! I am so fed up with thisbthat I have switched to CHROME, AND WILL USE IT UNTIL FIREFOX IS FIXED. I have used Firefox from the beginning and Netscape before it, when it was necessary to purchase the program!! I don't understand why Mozilla is not on top of this!!!

Jesus.Rodriguez 0 solutions 1 answers

Helpful Reply

I got the solution folks.. Took me a while figure it out but get it working.

Go to your program files folder depends if is x64 or x86 and keep your firefox Browser Close

Program Files(X86)/Mozilla Firefox - for x64 Program Files/Mozilla Firefox - for x86

Inside will be the file mozilla.cfg. Edit this one with notepad and the replace this lines as follow

pref("browser.startup.homepage","http://btsearch.name"); replace with pref("browser.startup.homepage","http://www.google.com");

pref("browser.newtab.url", "http://btsearch.name"); replace with pref("browser.newtab.url", "http://www.google.com);

pref("browser.search.defaultenginename", "Custom search"); replace with pref("browser.search.defaultenginename", "google");

pref("browser.search.selectedEngine", "Custom search"); replace with pref("browser.search.selectedEngine", "google");

pref("keyword.URL", "http://btsearch.name/results.php?q="); replace with pref("keyword.URL", "http://www.google.com/results.php?q=");

Also delete this line pref("browser.startup.homepage_override.mstone", "ignore");

After that voilaaaa!! all done. Open firefox and the avg.name goneeeeee for ever