X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Working set memory problem with Catalyst 12.8?

Posted

I run a Win7 Ultimate x64 system with twin ATI HD5870s inside. After updating to Catalyst 12.8 today, I noticed a problem with how much working set memory was used by Firefox 14.0.1.

== REPRO STEPS 1) Launch Firefox 2) Open Taskman, sort by Working Set 3) http://www.kotaku.com 4) Use the mousewheel to scroll the right side pane downwards - load up additional articles for review.

If you scroll a bit, you should see Firefox eat a couple GB of working set memory in short order. The page begins responding improperly at that point and Firefox becomes unstable.

Note: This problem only repros when Crossfire is enabled. When Crossfire is turned off, there's no issue at all.

I don't know if this is a Firefox v Crossfire thing, or a new trick delivered by Catalyst 12.8... but either way, keep your eyes open. I don't have a way to fix this yet aside from shutting down Crossfire, which negates the reason I went with a dual-card solution in the first place.

Chosen solution

Disabling Firefox > Options > Advanced > General > Browsing > Use hardware acceleration when available solves the problem untill Mozilla and AMD fix this issue

Read this answer in context 23

Additional System Details

Sites Affected

http://www.kotaku.com

Installed Plug-ins

  • Pando Web Plugin
  • 0.3
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • Shockwave Flash 11.3 r300
  • Microsoft Lync 2010 Meeting Join Plug-in
  • 5.1.10411.0
  • NPWLPG
  • AmazonMP3DownloaderPlugin 1.0.15
  • Winamp Application Detector
  • PopCap Games Plugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.8.612
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

(see repro notes in the details section)

mohsen57 0 solutions 3 answers

yes , i have same problem, please someone help AMD or Firefox should solve this problem with crossfire enabled issue

jbjelacic 1 solutions 1 answers

Chosen Solution

Disabling Firefox > Options > Advanced > General > Browsing > Use hardware acceleration when available solves the problem untill Mozilla and AMD fix this issue

Helpful Reply

Tested, and I agree; that resolves the issue. I filed a bug with AMD's support team last week as well, though I've had no feedback from that side of the house.

Nice workaround solution.

Lazycrockett 0 solutions 3 answers

This doesn't solve the problem with people who are using the dual graphics motherboard/video card combo. That hardware acceleration is already checked.

mohsen57 0 solutions 3 answers

This problem only occur when using crossfirex enabled using 2 graphic card, when disable crossfirex or only have onr there wont be any problem!

cannibs420 0 solutions 1 answers

i had this problem as well, but as my graphics card drivers being up to date was more important, first i tried to update to the latest beta firefox.. i fixed firefox crashing like mad by simply disabling the update option on it, then downloading firefox 13.0.1 and now ill just manually check for update, hoping that the one past 14.0.1 fixes my problem by the time its not beta. honestly this is the first problem ive ever had with firefox

edit: i spoke too soon, i crashed right afterwards. it has to do with the ati driver, and since im not downgrading that ill be stuck disabling hardware accel in firefox. o well, wait for amd then

Modified by cannibs420

Question owner

This is definitely an AMD issue; older Catalyst drivers worked fine on 14.0.1. The Catalyst update was the only change I made.

At least there's /some/ kind of workaround to let us keep running at full power. =)

Lazycrockett 0 solutions 3 answers

This issue also occurs when using a dual graphic set up. Its not just crossfire.

csabbymtc 0 solutions 2 answers

I'm also using dual garphics, and I also had the same problem after I had updated my Catalyst software... But I've rolled my drivers back in the device manager, and since then, my problem have gone away!

Lazycrockett 0 solutions 3 answers

Does anyone know if firefox 15 addresses the dual graphic issue?

csabbymtc 0 solutions 2 answers

I don't know yet, and unfortunately, I'm not able to try it 'till weekend... But I hope the new version solves the problem.

mohsen57 0 solutions 3 answers

I updated to Firefox 15 and problem still there, and not solved, this problem is not from Firefox, this is from AMD driver

Question owner

Confirmed; problem reproduces in Firefox 15.0. But as is noted, it's a Catalyst problem, not a Firefox problem.