Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How do I establish which of my Extensions or Add-ons will be disabled before I actually allow a Firefox upgrade to proceed (e.g. Tab Utilities Lite still not working after FF 10 upgrade)?

  • 2 replies
  • 3 have this problem
  • Last reply by hengels

more options

Although I usually appreciate the frequency of Mozilla's update program for FireFox, I find it frustrating to lose the functionality of the numerous extensions or add-ins that I have come to rely on. Unfortunately, there is no easy downgrade option. Is there some way that the upgrade process could identify and report on what the post-upgrade status of my extensions, etc. would be BEFORE I commit to the upgrade?

Chosen solution

Hi hengels,

You should take a look at the release notes for Firefox 10:

http://www.mozilla.org/en-US/firefox/10.0/releasenotes/

You'll see that one of the new features is to assume that add-ons are compatible rather than the other way around. This should cut down on the issue you describe a great deal.

You can find a much more detailed explanation of how the new system works here.

Hopefully this helps!

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Hi hengels,

You should take a look at the release notes for Firefox 10:

http://www.mozilla.org/en-US/firefox/10.0/releasenotes/

You'll see that one of the new features is to assume that add-ons are compatible rather than the other way around. This should cut down on the issue you describe a great deal.

You can find a much more detailed explanation of how the new system works here.

Hopefully this helps!

more options

Thank you for your assistance. I found the link to the detailed explanation (https://wiki.mozilla.org/Features/Add-ons/Add-ons_Default_to_Compatible] most helpful. I think the FF10 update did advise me that there would be an extension compatibility issue ( in general). However, my preference would be to have the update process advise me specifically of all extensions that are incompatible with the update so that I can make a decision on whether to accept or reject the update. Again, thanks for the info, much appreciated.