X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox browser hijacker sets the home page to www.iknowsearch.net

Posted

Recently, I installed a free application which installed a browser hijacker setting my home page to www.iknowsearch.net and I can't get rid of it. Please, help!

Additional System Details

This happened

Every time Firefox opened

This started when...

December 2011

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.1 r102
  • Version 2.5.8.4958
  • Google Talk Plugin Video Accelerator version:0.1.44.14
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • Windows Activation Technologies Plugin for Mozilla
  • Plug-in for detecting Nero Kwik Media.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Zeon PDF Plugin For Mozilla
  • Version 1.1.11, copyright 1996-2011 The VideoLAN Teamhttp://www.videolan.org/
  • Picasa plugin
  • IE Tab Plug-in for Mozilla/Firefox
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Adobe Shockwave for Director Netscape plug-in, version 11.5

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20100101 Firefox/9.0

More Information

vincleo 2 solutions 12 answers

Helpful Reply

Change it here.

Question owner

setting manually the home page back to the previous one does not help. When I restart Firefox, the hijacker sets my home page back to www.iknowsearch.net again.

Pablito1 0 solutions 1 answers

This happened to my wife on a PowerMac laptop - the home page is set on all of our computers for google.ca but for unexplained reasons, every time my wife opened Firefox [or Safari for that matter], even if google.ca was entered in the address bar, it automatically re-routed to search-results.com. I get infuriated by this kind of thing and I searched the web for a solution. Most of the information was for PC's and involved a lot of directory stuff, but I did see something about Proxy settings. I went to the computer's proxy settings, and there was a web address in a box that began with an asterisk (*). I deleted that, closed the options and opened a new window - problem solved! Hope this is helpful for others!