Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

adobe flash plugin has crashed 3.6.8

more options

I've updated to 3.6.8 but many times a day I receive the error that adobe flash plugin has crashed. I've checked for flash updates and have the current available. This occurs when I open firefox, browsing the net, using google, viewing facebook, viewing hotmail, viewing firefox website - basically at any time firefox is opened. Doesn't seem to matter what I am viewing.

Note: while writing this I received the error twice. And any attemtp to report the issue causes this error and complete lock up of firefox.

OS: win 7 32 bit

This happened

Every time Firefox opened

== 3.6.4

All Replies (3)

more options

i use windows xp sp 3. when i open pages with flash i often got a bluescreen with the message "driver irql not. less or equal".

more options
Firefox version 3.6.8 

Windows XP SP3


I have the same problem

more options

Same problem for Vista Home. This symptom made the performance turned very bad!! Need a new release to fix it ASAP!!!