Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Send Page to Device" and "Send Tab to Device" missing in recent versions!

  • No replies
  • 0 have this problem
  • 1 view
more options

After I reported this problem earlier (https://support.mozilla.org/en-US/questions/1374122), my installation of Firefox on Windows 10 has been auto-updated to Ver. 103.0.2, but the missing "Send Page to Device" and "Send Tab to Device" commands have not been restored yet.

I tested to see whether pages/tabs can be sent back and forth between my Android tablet and PC, as well as whether the Android device is visible on the PC at all, and compared the results between before and after auto-update (88.0.1 and 103.0.2, respectively) . Here is the sum-up:



On PC (88.0.1):

(1) Android device is visible in the "Connected Services" page. (2) It is also listed as destination in the "Send Page to Device" and "Send Tab to Device" commands. (3) Pages/tabs are successfully sent to Android using these commands.


On PC (103.0.2):

(1) Android device is visible in the "Connected Services" page. (2) But the "Send Page to Device" and "Send Tab to Device" commands are not available (see the screen shots below). (3) Therefore, pages/tabs cannot be sent to Android.


On Android, when trying to send a page to PC (88.0.1):

(1) PC is listed as destination in the "Send to other devices" command. (2) Pages are successfully sent to PC using the command.


On Android, when trying to send a page to PC (103.0.2):

(1) PC is listed as destination in the "Send to other devices" command. (2) The command apparently finishes successfully, but the page does not show up on PC.



Though both desktop versions can perfectly sync bookmarks, history, cookies, etc., with Android, it seems something is wrong with Ver. 10x (and 9x as I have reported earlier) in communicating with Android.




[Screen shots]

(Green = 88.0.1, Blue = 103.0.2, Red = Android)

  1. 1: 88.0.1 Version info
  2. 2: 88.0.1 "Connected Services"
  3. 3: 88.0.1 Right click on page
  4. 4: 88.0.1 Right click on tab
  5. 5: Android (connected to 88.0.1) "Send to other devices"
  6. 6: 103.0.2 Version info
  7. 7: 103.0.2 "Connected Services"
  8. 8: 103.0.2 Right click on page
  9. 9: 103.0.2 Right click on tab
  10. 10: Android (connected to 103.0.2) "Send to other devices"
After I reported this problem earlier (https://support.mozilla.org/en-US/questions/1374122), my installation of Firefox on Windows 10 has been auto-updated to Ver. 103.0.2, but the missing "Send Page to Device" and "Send Tab to Device" commands have not been restored yet. I tested to see whether pages/tabs can be sent back and forth between my Android tablet and PC, as well as whether the Android device is visible on the PC at all, and compared the results between before and after auto-update (88.0.1 and 103.0.2, respectively) . Here is the sum-up: ---------------------------------------- On PC (88.0.1): (1) Android device is visible in the "Connected Services" page. (2) It is also listed as destination in the "Send Page to Device" and "Send Tab to Device" commands. (3) Pages/tabs are successfully sent to Android using these commands. On PC (103.0.2): (1) Android device is visible in the "Connected Services" page. (2) But the "Send Page to Device" and "Send Tab to Device" commands are not available (see the screen shots below). (3) Therefore, pages/tabs cannot be sent to Android. On Android, when trying to send a page to PC (88.0.1): (1) PC is listed as destination in the "Send to other devices" command. (2) Pages are successfully sent to PC using the command. On Android, when trying to send a page to PC (103.0.2): (1) PC is listed as destination in the "Send to other devices" command. (2) The command apparently finishes successfully, but the page does not show up on PC. ---------------------------------------- Though both desktop versions can perfectly sync bookmarks, history, cookies, etc., with Android, it seems something is wrong with Ver. 10x (and 9x as I have reported earlier) in communicating with Android. ---------------------------------------- [Screen shots] (Green = 88.0.1, Blue = 103.0.2, Red = Android) #1: 88.0.1 Version info #2: 88.0.1 "Connected Services" #3: 88.0.1 Right click on page #4: 88.0.1 Right click on tab #5: Android (connected to 88.0.1) "Send to other devices" #6: 103.0.2 Version info #7: 103.0.2 "Connected Services" #8: 103.0.2 Right click on page #9: 103.0.2 Right click on tab #10: Android (connected to 103.0.2) "Send to other devices"
Attached screenshots

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.