Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox starting in windowed mode instead of Maximized!!!

  • 12 replies
  • 1 has this problem
  • 26 views
  • Last reply by empleat

more options

How to fix Firefox starting in Windowed mode instead of Maximized??? I tried some solutions from past and none worked for me... So annoying... Thanks!

How to fix Firefox starting in Windowed mode instead of Maximized??? I tried some solutions from past and none worked for me... So annoying... Thanks!

All Replies (12)

more options

What have you tried?


https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data \Mozilla\Firefox\Profiles\

Search for the above file. Then rename or delete it. Restart Firefox.

more options

I don't remember I tried it many times, or what people posted me, nothing ever worked. I can say I already tried this, I will probably try again this thing, if you have any other ideas I would appreciate it...

more options
more options

Deleting xustore didn't do anything as usual... Wait I don't want to create new profile! I will have to set up everything again, I have a lot of stuff. Besides I have feeling this starts happening again after awhile. More permanent solution would be better!

more options

Did you check the Firefox shortcut to see how it is opened ?

more options

Yeah! Same bug was in Chrome, but there fix worked google found...

Modified by empleat

more options

empleat said

Wait I don't want to create new profile! I will have to set up everything again

Do the new profile. If it works, we know where the problem is. You can always go back to the original profile.

more options

No... It would be crazy amount of things that need to be set again, there is gotta be a better solution... Maybe later, if no better solution is found...

more options

I don't want you to do anything in the new profile. All I want to know is if the problem is still there.

more options

Ah sorry I have headache... I actually have second instance of Firefox not created long time ago and I made sure it was maximized and it is happening there too!

more options

What did you do to fix this in Google Chrome as that might give a clue about its cause ?

more options

It will be unrelated, there was some command. But in firefox nothing worked I tried so far...