Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Trouble with certain websites

  • 7 replies
  • 1 has this problem
  • 20 views
  • Last reply by cor-el

more options

I have used Firefox as my main browser for years now and I really like it. However, for the past 5 or 6 months I haven't been able to sign into my online banking at all with Firefox. I have to use Chrome. It allows me to put in my username and password but then it just takes me to another sign in view.

Recently I was on another site, trying to purchase a few items and it would not allow me to use the "add to cart" button, only the buy now. But then when I went back to the products, if I added something else to the cart, it wiped out the first thing I had added.

In both of these cases, I have gone to Chrome and used the functions and signed in with no issues. I don't want to have to use different browsers for different things. Is there anything you can advise?

The sites are: https://www.simplii.com/en/home.html and https://amaranthstoneware.ca/

My Firefox is up to date (just today and I tested the bank sign in again, with my fingers crossed).

Thank you.

All Replies (7)

more options

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

Thank you! I was able to get into my bank account in safe mode and then followed some instructions you sent.

I really appreciate your help.

Mary

Helpful?

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Helpful?

more options

Hi Fred,

Sorry, I had marked this (on my email) as solved, but it may not have. My only issue is, with the:

Use recommended performance settings & Use hardware acceleration when available

unticked, I can sign into the bank, but it doesn't recognize me as in a recognized computer, EVERY TIME, so I have to get a code sent to my phone in Firefox to sign in. Not much of an improvement.

I use Last Pass and Duck Duck Go and NordVPN (but it's only on when I need it) as Extensions and the only plugins I have are recommended, I think. OpenH264 Video Codec and Widvine Content Decryption Module provided by Google Inc. Can I turn either of those off, and I've used LastPass and Duck Duck Go for a couple of years without issue. Funny thing is, another bank I log into is fine.

I'll try again after restarting.

Thank you.

Helpful?

more options

marys477 said

Sorry, I had marked this (on my email) as solved

A post was flagged as Solved Problem. If the problem is not solved, please remove that flag. If you don’t, others that can help may not read this post.

Go to that message, and use the Undo link to its right.

Helpful?

more options

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.


Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Helpful?

more options

Make sure that you do not clear the Site Preferences.


Detail like websites remembering you and log you in automatically is stored in a cookie.

You can use these steps to make a website recognize and remember you.

  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you

You can check that you aren't clearing important cookies.

  • using "Delete cookies and site data when Firefox is closed" keeps cookies with an allow exception
  • using "Clear history when Firefox closes" to clear cookies clears all cookies including cookies with an allow exception you may want to keep
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security -> Cookies and Site Data: "Manage Exceptions"

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.