Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF profile choice problem on Linux Mint with Claws email

more options

I have three FF profiles on my Linux Mint 19.3 system (work, not-work and one for e-tail). Somehow the problem only appeared after I added that last one. All profiles have the same syntax; I checked the files. Neither one is set to be the dominant one. Typically, I don't use more than one at a time.

I also use Claws mail. Whenever I get any mail with a link I want to check out, I just used to click on that link and it opened in a new tab in the FF browser profile that was currently open. Similarly, whenever I wanted to see the HTML version of a mail, I right-clicked on the html-icon and chose open. Again, it picked the open browser.

Now, though, whenever I pick either one of those options above, I get the "Choose User Profile" box. If I pick the profile that is currently open, I get an error telling me that it's already running.

Since I mostly read email when I use the no-work FF profile, I tried to add "firefox -P NotWork -no-remote --class NotWorkProfile" but that also resulted in the choose user profile box to open.

My current work-around is to copy the link and open it in a new tab, or pull the whole mail into the tab to see the HTML version. Quite annoying.

Is there any way to get it to ignore all other profiles but the currently open one? Thank you for anyone who has an idea. Let me know if there's anything else I may add to explain the situation.

[My apologies if this isn't the right forum; I'm also attempting to ask this question in the Linux Mint and Claws forums, if those exist.]

Chosen solution

A profile can be locked to a specific Firefox version (installation path), so it is possible that the BuyingStuff profile is locked. Lock information is stored in profiles.ini with installs.ini being a backup that is used when this lock data in profiles.ini is lost.


Read this answer in context 👍 1

All Replies (9)

more options

Note that you shouldn't start Firefox with the -no-remote command line switch as that causes this problem. Only if you omit -no-remote then you will be able to open external link in a running Firefox instance.

What profile (if any) is set as the default profile in profiles.ini ?

Helpful?

more options

Thank you, cor-el, for your quick response! I tried "open with" without the "-no-remote" -- i.e. firefox -P NotWork --class NotWorkProfile %s

But that also calls the choice box.

Thank you for mentioning the profiles.ini. I hadn't dealt with that file, only with linking the direct profiles on my desktop. (Sorry, I had confused this with some ini files.) I've only been using Linux for 2 years, and I wanted to create shortcuts, which I managed by way of following an online tutorial.

My profiles.ini looks like this: [Profile3] Name=BuyingStuff IsRelative=1 Path=fmvsb544.BuyingStuff

[Install4F96D1932A9F858E] Default=wh6b87xk.Work Locked=1

[Profile1] Name=default IsRelative=1 Path=ujoxo5rz.default Default=1

[Profile0] Name=Work IsRelative=1 Path=v3avmb1t.default-release

[General] StartWithLastProfile=1 Version=2

[Profile2] Name=NotWork IsRelative=1 Path=wh6b87xk.Work

I have no idea why there are cryptic number-letter combos in front of each profile name; I didn't do that. I'd be grateful if you could tell me what might be wrong. Thanks already!

Helpful?

more options

You also shouldn't specify the profile via the -P parameter, just use "firefox url" to open the URL in the currently open Firefox instance or specify a profile that isn't in use.

Firefox uses an eight character random string for the file name part. You see the file extension in the profile manager. This profile, marked as Default=1, is currently set as the default profile.

[Profile1]
Name=default
IsRelative=1
Path=ujoxo5rz.default
Default=1

Helpful?

more options

Thanks for your continued help. I just tried with only "open with" "firefox" -- but that opened the link in a tab in the profile BuyingStuff, even though NotWork was already open.

Why did you ask what my default profile is, anyway? Sorry, I forgot to ask that earlier.

Helpful?

more options

Update: after rebooting several times (for other reasons), I still have Claws open all URLs in the BuyingStuff profile. Also, if I just open Firefox by way of the regular menu (i.e. not any of my profiles' shortcuts), it also opens the BuyingStuff profile. In the latter case, it always used to ask (before I added the 3rd profile) which one I wanted, by way of the choice box.

If the Default profile is the default profile -- shouldn't it NOT be the BuyingStuff one that gets called? Is there a rule/bug that things get messed up as soon as there are 3 different profiles?

Please, anyone?

Helpful?

more options

Chosen Solution

A profile can be locked to a specific Firefox version (installation path), so it is possible that the BuyingStuff profile is locked. Lock information is stored in profiles.ini with installs.ini being a backup that is used when this lock data in profiles.ini is lost.


Helpful?

more options

Thank you! I read my way though the linked pages and then just went to about:profiles -- and picked NotWork as my default profile.

Now all's well. Thanks again.

Helpful?

more options

Aaaand... a PC reboot brought it all back to the way it was before. I'm at my wits' end. The good news: The profile that I want (NotWork) is now set and persistently recognized as the default profile.

And the choice box doesn't appear anymore, but whenever I try to open a link or the html version of an email, I get the same error as before: "Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile."

I read around a bit again, and now I wonder if that actually points to what's really wrong. But every discussion and info about this error message is 9 years old.

Or is the problem related to my default profile (NotWork) referencing a particular install?

profiles.ini: [Install4F96D1932A9F858E] Default=wh6b87xk.Work Locked=1

I never wanted that; I only have one version of Firefox, always the most recently updated one, not including Betas. How do I change it? I tried deleting those lines, but on restarting FF, the entry re-appeared, except for the "locked=1" part.

Or is the problem in this last line, about which I can't find any documentation: [General] StartWithLastProfile=1 Version=2

What does "version=2" refer to? I changed it to 0 or 1, but it doesn't seem to change anything. (I did close and restart FF.)

Please, if someone has another idea, I can post my complete inis again, if that'd help.

Helpful?

more options

Since there doesn't seem to be any more help available -- here my workaround in case someone with the same problem finds this.

There seems to be (so far) no problem if I start FF for the first time after booting by launching it via a clicked link from within Claws. Triple checked it. If I close Claws and restart it without closing FF too, I get the dreaded error that FF is already running.

Case closed.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.