Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

History not appearing in chronological order

  • 1 reply
  • 1 has this problem
  • 5 views
  • Last reply by cor-el

more options

My history sidebar doesn't show my most recently visited websites even when sorted by "Last Visited".

If I start to type the name of the website, they do appear there (so they are being recorded in history). But it doesn't matter what sites I visit, the last visited links don't change.

Does anyone know what might be causing this?

Attached screenshots

All Replies (1)

more options

Make sure that you remember history and also not use Private Browsing mode.

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.