Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to save .mkv downloads without being asked, with 'open' as default, no checkbox

  • 2 replies
  • 1 has this problem
  • 28 views
  • Last reply by roberthaus

more options

On multiple machines (Windows 7-10), if I click on an MP4 or other media file, I have the option of checking the box to save the file without asking in the future. With .mkv files, the checkbox isn't there, so every time I have to go through the process of changing the default (play) action to save the file. I've checked preferences and there's no way to add mkv files to the default actions. I deleted the handlers... file to reset and start over, but same behavior...it wants to play the file, with no option to quit asking and just save it.

On these same machines, I can do the same download process with any other browser such as Opera, and it just saves the file as I've instructed it to do in preferences. So why the different (and long-term consistent) and annoying behavior with firefox? MP4, AVI, fine, but MKV?? No option, and it's not as if it's a new file type or new behavior.

I suppose one could say "what's the big deal, just change it when it asks?", but it seems like nonsensical and pointless behavior, which has continued for a long time, with other browsers able to deal with it properly. At the very least, how about a way to add file extensions manually to the list of actions in the options?

Please don't blame the web server for "not sending the proper information", as I've seen in some non-solution posts; the .mkv extension should tell enough, and it's over many servers. I looked in the registry to see if perchance I could patch it in there, but couldn't find entries, so I assume it's all in the handlers file.

All Replies (2)

more options

roberthaus said

Please don't blame the web server for "not sending the proper information", as I've seen in some non-solution posts; the .mkv extension should tell enough, and it's over many servers.

Well, if the shoe fits... Firefox generally doesn't care what the file extension is if the server says it's a generic binary file. If that's the problem, my add-on can help you:

https://www.reddit.com/r/firefox/comments/hsnuac/how_to_automatically_save_file_when_download_file/

Or wait for other replies to see whether there is a "native" way to fix it.

Helpful?

more options

Thanks for the quick reply and link. I got your add-on and will give it a try, sounds like it should work to fix the issue.

I'm not sure why other browsers seem able to handle it on the same server and file type, and since FF recognizes that it can be opened with the media player I use and chooses that, or why it gives me a checkbox for MP4 etc. from that same server, but not for MKV, but other than that, it's perfectly clear...I think...8^)

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.