Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Doesn't work any sites except support.mozilla.org

  • 2 replies
  • 1 has this problem
  • 26 views
  • Last reply by Neo

more options

All sites except support.mozilla.org and accounts.firefox.com do not work in my main profile. When entering an address or calling from a favorite, the tab remains blank and the loading indicator always works. No site elements (even a title) appear. Even the web panel of my router (LAN) does not load. Others profiles work fine. History is important for me. So I don't want to clean it.

Attached screenshots

Chosen solution

Try running in Firefox Safe Mode. It's possible that one of your extensions are blocking pages from loading. This would explain why Firefox is working fine for Mozilla-related domains, since extensions have very limited permissions to interact with those websites.

Hope this helps.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Try running in Firefox Safe Mode. It's possible that one of your extensions are blocking pages from loading. This would explain why Firefox is working fine for Mozilla-related domains, since extensions have very limited permissions to interact with those websites.

Hope this helps.

Helpful?

more options

It was uMatrix. Reinstalling it helped me. Thanks a lot.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.