Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps hanging, black screen then white for 10secs then recovers. very annoying

  • 3 replies
  • 1 has this problem
  • 11 views
  • Last reply by FredMcD

more options

I do not have this issue In safe mode. It has been going on for some time and I've had to revert to Chrome, which I hate. I have used Firefox for years and up till now never had any issues until now.

Chosen solution

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Helpful?

more options

Hi Fred, Thanks for your very detailed solutions to my Firefox issue. You correctly identified the issue as being the 'Hardware Acceleration' setting. I un-ticked the box, opened 20+ tabs and very quickly clicked between them. All was very stable and no sign (thus far) of the problem I was having. I want to give a you a heartfelt thanks for your help here. I had been stumbling around fruitlessly trying to solve this thing for quite a while. I can now revert back to a browser I have great affection for and trust in. Many, many thanks once again Colin

Helpful?

more options

Glad to help. Safe Surfing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.