Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Extreme slowness: I tried everything on the troubleshoot page and even reinstalled Firefox, but after two days it slowed down again. How can i find the problem?

  • 7 replies
  • 1 has this problem
  • 72 views
  • Last reply by FredMcD

more options

Firefox suddenly slowed to a crawl last week. Every page I open or reload takes more than a minute to load. After a few days and following all the suggestions on the troubleshoot pages, I reinstalled the program. It worked great for two days, and now it's back to crawl. Again I've gone through all the suggestions on the troubleshoot pages, but nothing helps. The rest of my computer works fine.

Chosen solution

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Read this answer in context 👍 1

All Replies (7)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop

Helpful?

more options

Safe mode was the first thing I did - per the Firefox trouble shooting instructions. But it changed nothing.

Helpful?

more options

Chosen Solution

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

more options

That seems to have fixed it - THANKS! But what exactly changed by starting the computer in safe mode and then restarting it again normally?

Helpful?

more options

When a computer is started in Safe Mode, only system programs are running.

There could be many reasons that this fixed the issue. The computer's log might tell you what happen. Ask about it here: https://support.microsoft.com

http://answers.microsoft.com/en-US/windows/forum/windows_10

Helpful?

more options

OK, great. Thanks again! Even if I don't find out exactly what did it, it'll be easy enough to do the same thing next time it happens (definitely easier than reinstalling Firefox!).

Helpful?

more options

Glad to help. Safe Surfing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.