Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't send emails

  • 25 replies
  • 2 have this problem
  • 40 views
  • Last reply by sfhowes

more options

I have gone through all the steps and still get this. Been like it for a few years. What I do is save in drafts and then send through webmail. Husband who doesn't email much can't understand why I haven't found a solution so trying again.

Attached screenshots

All Replies (5)

more options

ddhaff said

Here is the error message I get.

For the outgoing server, do you have smtp.comcast.net on port 465, SSL/TLS security?

https://www.xfinity.com/support/articles/setting-up-thunderbird

Plus, disable scanning of outgoing mail and secure connections by ESET, or whatever AV you have.

more options

For outgoing server I have smtp.frontier.com. If I use port 465, sending message times out. When I use port 587 (default), I get the message that I attached previously. In security, I don't see SSL/TLS, and I don't see a place for it to be entered. I only see "Digital Signing" and "Encryption".

more options

If you have a Frontier account and a Comcast account, open Tools/Account Settings, select the Frontier account in the left pane, check Outgoing Server (SMTP) in the lower right pane and set it to the Frontier smtp. Same for the Comcast account - set it to send on the Comcast smtp.

At the bottom of the left pane of Account Settings, select Outgoing Server (SMTP) to edit the smtp settings.

more options

I don't have a Comcast account. And I assume you meant smtp.Frontier.com, because trying Frontier smtp, as you suggested, gave me a message "Frontier smtp is not a valid server". When I change that to Frontier.smtp, and try to send, the error message that I get is Frontier.smtp is unknown. So, I'm back to square one. smtp.Frontier.com is what I've entered, and that is what gives me the error message that I attached in my earlier communication.

more options

The error in your picture refers to a comcast.net server, so it's natural to assume you have a Comcast account. The Frontier outgoing server is smtp.frontier.com on port 465, SSL/TLS security, authentication = normal password, User Name = email address.

A better approach might be to switch from Frontier servers to Yahoo servers:

https://support.mozilla.org/en-US/questions/1280043

  1. 1
  2. 2