X
Tap here to go to the mobile version of the site.

Support Forum

why isn't my firefox updating?

Posted

I can't use Hulu or Netflix because the version of Firefox I have isn't supported. I tried following the instructions I saw, but nothing.

I can't use Hulu or Netflix because the version of Firefox I have isn't supported. I tried following the instructions I saw, but nothing.
Quote

Additional System Details

Installed Plug-ins

  • This plugin provides integration with GNOME Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org

Application

  • Firefox 52.7.3
  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
  • Support URL: https://support.mozilla.org/1/firefox/52.7.3/Linux/en-US/

Extensions

  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Magnif) 0.1.1 ({65dc18e1-109f-4039-929b-f8a7a29be090})
  • Multi-process staged rollout 1.10 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Ivybridge Mobile
  • adapterDeviceID: Mesa DRI Intel(R) Ivybridge Mobile
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • crashGuards: []
  • currentAudioBackend: pulse
  • driverDate:
  • driverVersion: 3.0 Mesa 17.3.7
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}]}
  • info: {u'ApzWheelInput': 1, u'ApzTouchInput': 1, u'CairoUseXRender': 0, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 2
  • supportsHardwareH264: No
  • webgl2Renderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Ivybridge Mobile
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Ivybridge Mobile
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Wesley Branton
  • Top 10 Contributor
573 solutions 4884 answers

My assumption, based on the fact that your system details says you are running Firefox 52.7.3, is that you are running the Extended Support Release (ESR) version of Firefox.

If you can't get Firefox to update, you can try manually downloading and installing the latest version from Mozilla, rather than using the package manager for your Linux distribution.

If you are using Firefox ESR, download the latest version here. If you are using the regular Firefox release, download the latest version here.

Hope this helps.

My assumption, based on the fact that your system details says you are running Firefox 52.7.3, is that you are running the Extended Support Release (ESR) version of Firefox. If you can't get Firefox to update, you can try manually downloading and installing the latest version from Mozilla, rather than using the package manager for your Linux distribution. If you are using Firefox ESR, [https://www.mozilla.org/en-US/firefox/organizations/all/ download the latest version here]. If you are using the regular Firefox release, [https://www.mozilla.org/en-US/firefox/all/ download the latest version here]. Hope this helps.
Was this helpful to you?
Quote
nshattuck20 0 solutions 3 answers

Hi, Please provide any instructions you followed so we can further help you.

Hi, Please provide any instructions you followed so we can further help you.
Was this helpful to you?
Quote
James
  • Moderator
1593 solutions 11224 answers

onose01 said

why isn't my firefox updating?

With Linux there are two main reasons.

You are using a third-party package build from your Linux distro as updates from them and not Mozilla.

You have Firefox for Linux from mozilla.org however the user does not have read/write permissions for the Firefox folder for to get updates from Mozilla.

A easy way around this if you are the only user is to have Firefox folder in Home.

https://support.mozilla.org/en-US/kb/install-firefox-linux

''onose01 [[#question-1259365|said]]'' <blockquote>why isn't my firefox updating?</blockquote> With Linux there are two main reasons. You are using a third-party package build from your Linux distro as updates from them and not Mozilla. You have Firefox for Linux from mozilla.org however the user does not have read/write permissions for the Firefox folder for to get updates from Mozilla. A easy way around this if you are the only user is to have Firefox folder in Home. https://support.mozilla.org/en-US/kb/install-firefox-linux
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.