X
Tap here to go to the mobile version of the site.

Support Forum

any firefox newer than 57.8 in RHEL 7.5 or 7.6 doesn't highlight text when trying to cut and paste

Posted

For example, if I click on a url it changes the text color from light black to dark black, but it doesn't highlight it.

I can't highlight text to be able to cut and paste. If I act like it is working by clicking and dragging across the text, then ^C it and go somewhere and ^V it, it works. but it is hard to deal with the text not having been highlighted to see exactly what you were going to get.

RHEL 7.5 or RHEL 7.6

I believe the last FF that worked was 57...

The version I have installed is 60.6.1 and I also have tried 66.0.5.

I am running:

kwin --version Qt: 4.8.7 KDE Development Platform: 4.14.8 KWin: 4.11.19

Thanks for any advice. tom

For example, if I click on a url it changes the text color from light black to dark black, but it doesn't highlight it. I can't highlight text to be able to cut and paste. If I act like it is working by clicking and dragging across the text, then ^C it and go somewhere and ^V it, it works. but it is hard to deal with the text not having been highlighted to see exactly what you were going to get. RHEL 7.5 or RHEL 7.6 I believe the last FF that worked was 57... The version I have installed is 60.6.1 and I also have tried 66.0.5. I am running: kwin --version Qt: 4.8.7 KDE Development Platform: 4.14.8 KWin: 4.11.19 Thanks for any advice. tom

Chosen solution

Could be due to the GTK3 theme you have in use.

Firefox ever since 46.0 to current has required GTK 3.4 (three.four) at minimum to run and as a result requires a GTK3 theme to be used or Firefox looks weirdly unthemed like missing scroll bars and such.

Some Linux distros may have delayed the change from GTK 2.8 to 3.4 minimum requirement in their own package builds of Firefox.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

James
  • Top 25 Contributor
  • Moderator
1593 solutions 11222 answers

Chosen Solution

Could be due to the GTK3 theme you have in use.

Firefox ever since 46.0 to current has required GTK 3.4 (three.four) at minimum to run and as a result requires a GTK3 theme to be used or Firefox looks weirdly unthemed like missing scroll bars and such.

Some Linux distros may have delayed the change from GTK 2.8 to 3.4 minimum requirement in their own package builds of Firefox.

Could be due to the GTK3 theme you have in use. Firefox ever since 46.0 to current has required GTK 3.4 (three.four) at minimum to run and as a result requires a GTK3 theme to be used or Firefox looks weirdly unthemed like missing scroll bars and such. Some Linux distros may have delayed the change from GTK 2.8 to 3.4 minimum requirement in their own package builds of Firefox.
Was this helpful to you? 1
Quote

Question owner

I had it set to system-settings>application appearance>GTK+ Appearance>Widget style = Raleigh

I changed it to oxygen-gtk and everything works now.

Thanks! tom

I had it set to system-settings>application appearance>GTK+ Appearance>Widget style = Raleigh I changed it to oxygen-gtk and everything works now. Thanks! tom
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.