X
Tap here to go to the mobile version of the site.

Support Forum

How can I remove the text from my Home button?

Posted

As shown in the attachment, my Home button in the navigation toolbar has the text "Home" next to it. It's been like that for at least four or five years, maybe a lot longer. Any ideas on how I can remove it to reclaim a little toolbar real estate? Fyi, changing theme to one of the three defaults, or a different custom one, makes no difference. And there is no alternate, text-less Home button for me to choose in Customize. Thanks.

As shown in the attachment, my Home button in the navigation toolbar has the text "Home" next to it. It's been like that for at least four or five years, maybe a lot longer. Any ideas on how I can remove it to reclaim a little toolbar real estate? Fyi, changing theme to one of the three defaults, or a different custom one, makes no difference. And there is no alternate, text-less Home button for me to choose in Customize. Thanks.
Attached screenshots
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

Question owner

Not even a guess?

Not even a guess?
Was this helpful to you?
Quote
TyDraniu
  • Top 25 Contributor
255 solutions 1420 answers

Helpful Reply

Hardly. Can't reproduce this label. Go to ≡ -> Help -> Restart with Add-ons Disabled… to see if it's addon-related.

Hardly. Can't reproduce this label. Go to ≡ -> ''Help ''-> ''Restart with Add-ons Disabled…'' to see if it's addon-related.
Was this helpful to you? 1
Quote

Question owner

Thanks for the suggestion. On a related note, one thing I should have mentioned earlier is that I wondered if the issue might be related to a legacy (no longer usable) add-on (maybe a toolbar buttons add-on?) that might have offered both with-text and without-text versions of the Home button (although I'm not sure why I would have selected with-text...).

OK, with that in mind, I find that using Safe Mode *does* remove the text next to the home icon. BUT, if I instead manually disable each add-on (restarting after each disable), the text does *not* go away. So doesn’t that confirm that it’s *not* a *current* add-on that’s causing the issue? Again, maybe instead it’s the residual effect of a no-longer used (or usable) add-on?

Which leads to the question: Is there a way to solve it without resetting or re-installing Firefox (which wouldn’t be worth the possible disruptions just to solve this issue).

One thing I tried today: Got into Safe Mode so the text next to Home goes away. Then go into Customize and drag the button off the toolbar. Then get out of Safe Mode and drag it back. Unfortunately, once dragged back, it still shows the text. I had a feeling this wouldn’t work, because of the odd way my Home looks in (regular mode) Available Buttons before dragging it back to the toolbar (see screenshot). Fyi, I also tried dragging back while still in Safe Mode, which only solves the issue until I return to regular mode.

I was hoping perhaps someone could suggest a profile file that I could try editing or deleting to fix this...perhaps something related to a now-inactive legacy add-on? Thanks.

Thanks for the suggestion. On a related note, one thing I should have mentioned earlier is that I wondered if the issue might be related to a legacy (no longer usable) add-on (maybe a toolbar buttons add-on?) that might have offered both with-text and without-text versions of the Home button (although I'm not sure why I would have selected with-text...). OK, with that in mind, I find that using Safe Mode *does* remove the text next to the home icon. BUT, if I instead manually disable each add-on (restarting after each disable), the text does *not* go away. So doesn’t that confirm that it’s *not* a *current* add-on that’s causing the issue? Again, maybe instead it’s the residual effect of a no-longer used (or usable) add-on? Which leads to the question: Is there a way to solve it without resetting or re-installing Firefox (which wouldn’t be worth the possible disruptions just to solve this issue). One thing I tried today: Got into Safe Mode so the text next to Home goes away. Then go into Customize and drag the button off the toolbar. Then get out of Safe Mode and drag it back. Unfortunately, once dragged back, it still shows the text. I had a feeling this wouldn’t work, because of the odd way my Home looks in (regular mode) Available Buttons before dragging it back to the toolbar (see screenshot). Fyi, I also tried dragging back while still in Safe Mode, which only solves the issue until I return to regular mode. I was hoping perhaps someone could suggest a profile file that I could try editing or deleting to fix this...perhaps something related to a now-inactive legacy add-on? Thanks.

Modified by Rick216

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17006 solutions 153568 answers

Are you using code in userChrome.css in the chrome folder in the profile folder that could be adding this Home text?

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Are you using code in userChrome.css in the chrome folder in the profile folder that could be adding this Home text? *https://www.userchrome.org/what-is-userchrome-css.html You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
Was this helpful to you?
Quote

Question owner

I only recently, for the first time, added a userChrome.css file. I added it after I updated from 52esr (52.9??) to Quantum (60.3.0esr) in order to restore some classic UI aspects that were lost since I could no longer use Classic Theme Restorer or Places' Full Titles (namely moving tabs below all menus, rounded tabs, yellow default tab, and unlimited width for the Bookmarks Toolbar overflow). It has nothing related to the Home button, or any other buttons. In fact, as I mentioned I've had this issue for years but only added userChrome.css in the past week.

I only recently, for the first time, added a userChrome.css file. I added it after I updated from 52esr (52.9??) to Quantum (60.3.0esr) in order to restore some classic UI aspects that were lost since I could no longer use Classic Theme Restorer or Places' Full Titles (namely moving tabs below all menus, rounded tabs, yellow default tab, and unlimited width for the Bookmarks Toolbar overflow). It has nothing related to the Home button, or any other buttons. In fact, as I mentioned I've had this issue for years but only added userChrome.css in the past week.

Modified by Rick216

Was this helpful to you?
Quote
WestEnd
  • Top 10 Contributor
59 solutions 5051 answers

That sounds odd. I've used firefox for long time and never had that "homepage" showing up next to the icon. And those firefox version never had userChrome.css file installed until FF57+. So I doubt that is a firefox caused.

That sounds odd. I've used firefox for long time and never had that "homepage" showing up next to the icon. And those firefox version never had userChrome.css file installed until FF57+. So I doubt that is a firefox caused.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17006 solutions 153568 answers

Does this text still appear if you start Firefox in Safe Mode?

Does this text still appear if you start Firefox in Safe Mode? *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Was this helpful to you?
Quote

Question owner

cor-el said

Does this text still appear if you start Firefox in Safe Mode?

As I said above, the text goes away in Safe Mode, but still appears in Regular mode *even with ALL of my add-ons manually disabled.*

''cor-el [[#answer-1176996|said]]'' <blockquote> Does this text still appear if you start Firefox in Safe Mode? *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode </blockquote> As I said above, the text goes away in Safe Mode, but still appears in Regular mode *even with ALL of my add-ons manually disabled.*
Was this helpful to you?
Quote

Question owner

WestEnd said

That sounds odd. I've used firefox for long time and never had that "homepage" showing up next to the icon. And those firefox version never had userChrome.css file installed until FF57+. So I doubt that is a firefox caused.

Yes, strange isn't it. I just found a screenshot of my Firefox 3.05 as configured almost exactly ten (!) years ago, and my home button had the adjoining text there, too (see screenshot). So obviously this is something I can live with if no solution is found. :)

''WestEnd [[#answer-1176990|said]]'' <blockquote> That sounds odd. I've used firefox for long time and never had that "homepage" showing up next to the icon. And those firefox version never had userChrome.css file installed until FF57+. So I doubt that is a firefox caused. </blockquote> Yes, strange isn't it. I just found a screenshot of my Firefox 3.05 as configured almost exactly ten (!) years ago, and my home button had the adjoining text there, too (see screenshot). So obviously this is something I can live with if no solution is found. :)
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17006 solutions 153568 answers

Did you try to remove the userChrome.css file?

In Firefox Safe mode these changes are effective:

  • hardware acceleration is disabled (Options/Preferences -> General -> Performance)
  • all extensions are disabled (about:addons)
  • default theme is used (no lightweight theme)
  • default toolbar layout is used
  • xulstore.json is ignored
  • userChrome.css and userContent.css are ignored (chrome folder in profile folder)
  • JavaScript JIT compilers are disabled
  • plugins are not affected
  • preferences are not affected
Did you try to remove the userChrome.css file? In Firefox Safe mode these changes are effective: *hardware acceleration is disabled (Options/Preferences -> General -> Performance) *all extensions are disabled (about:addons) *default theme is used (no lightweight theme) *default toolbar layout is used *xulstore.json is ignored *userChrome.css and userContent.css are ignored (chrome folder in profile folder) *JavaScript JIT compilers are disabled *plugins are not affected *preferences are not affected
Was this helpful to you?
Quote

Question owner

The Home text was there even before I created a userChrome.css file. But just in case I have tried removing it, and the Home text remains.

I started implementing all the Safe Mode components you list as a test, but it's not worth it to me to undo the toolbar layout, and I don't know how to force xulstore.json to be ignored or how to disable JavaScript JIT compilers.

So I'll just continue to live with this minor issue (unless someone has another idea), but thanks to everyone for all the suggestions.

The Home text was there even before I created a userChrome.css file. But just in case I have tried removing it, and the Home text remains. I started implementing all the Safe Mode components you list as a test, but it's not worth it to me to undo the toolbar layout, and I don't know how to force xulstore.json to be ignored or how to disable JavaScript JIT compilers. So I'll just continue to live with this minor issue (unless someone has another idea), but thanks to everyone for all the suggestions.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17006 solutions 153568 answers

You can create a new profile to test if your current profile is causing the problem. If a new profile still has this text then it is likely something in the Firefox program folder and in that case try a clean reinstall (you can rename the current program folder to check for changes).

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

You can create a new profile to test if your current profile is causing the problem. If a new profile still has this text then it is likely something in the Firefox program folder and in that case try a clean reinstall (you can rename the current program folder to check for changes). See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17006 solutions 153568 answers

So, the text is part of the icon and not real text that Firefox would normally display below the icon and not next to it.

So, the text is part of the icon and not real text that Firefox would normally display below the icon and not next to it.
Was this helpful to you?
Quote

Question owner

The new, test, profile's Home button did NOT have text next to it, so the text I see is probably part of the icon.

But I am definitely done doing anything on this minor issue because after I went back to my main profile, all my internet history was gone! (And download history as well. I didn't check to see if bookmarks were still there.) History is *hugely* important to me. In fact, Firefox's deft and intelligent handling of history is perhaps the #1 reason I prefer it over Chrome.

Thank goodness I had just created a Windows 7 restore point last night, so I was able to switch to a "previous version" of the profile from that, and thus get all my history back, aside from the past 24 hours.

FWIW, the url box had also become narrower for some reason, but that also resolved after going back to last night's copy of the profile.

(EDIT: BTW, during the period that I lost all my history I noticed that my places.sqlite file, which had been about 66MB, was now only about 6MB, and there was another file called places.sqlite.corrupt that was about 66MB. I assume there might have been a way to use that to restore my history, but I decided to go straight to the previous-file-version route since I was pretty sure that would work.)

The new, test, profile's Home button did NOT have text next to it, so the text I see is probably part of the icon. But I am definitely done doing anything on this minor issue because after I went back to my main profile, all my internet history was gone! (And download history as well. I didn't check to see if bookmarks were still there.) History is *hugely* important to me. In fact, Firefox's deft and intelligent handling of history is perhaps the #1 reason I prefer it over Chrome. Thank goodness I had just created a Windows 7 restore point last night, so I was able to switch to a "previous version" of the profile from that, and thus get all my history back, aside from the past 24 hours. FWIW, the url box had also become narrower for some reason, but that also resolved after going back to last night's copy of the profile. (EDIT: BTW, during the period that I lost all my history I noticed that my places.sqlite file, which had been about 66MB, was now only about 6MB, and there was another file called places.sqlite.corrupt that was about 66MB. I assume there might have been a way to use that to restore my history, but I decided to go straight to the previous-file-version route since I was pretty sure that would work.)

Modified by Rick216

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17006 solutions 153568 answers

The places.sqlite database would normally only get corrupted if you would use the profile with a newer Firefox version and then revert the profile to an older Firefox version. I don't know if you did such a thing. Creating a new profile and using that profile shouldn't have any effect on other profiles, so I don't know what went wrong (could have been an issue with security software or cleanup software).

The places.sqlite database would normally only get corrupted if you would use the profile with a newer Firefox version and then revert the profile to an older Firefox version. I don't know if you did such a thing. Creating a new profile and using that profile shouldn't have any effect on other profiles, so I don't know what went wrong (could have been an issue with security software or cleanup software).
Was this helpful to you?
Quote

Question owner

I didn't use a different version. I do have CCleaner, but it is carefully set to delete ONLY cookies (other than those marked Keep) and browser cache; and to run only on demand, which I did not do.

And I wouldn't think a corrupt places.sqlite could have affected the UI (namely the url box getting narrower -- something I've never seen before). That was strange.

I do have a copy of 64-bit 52esr on the computer (my regular installation of Firefox -- now 60.3esr -- is 32-bit), but the 64-bit 52esr "never update" is there strictly for use by another user account I created for when I want to use Scrapbook, which is not supported by Quantum. As a precaution I purposely made 64-bit 52esr hard to get to (in addition to a separate user, there are no shortcuts).

Anyway, I have used the alternate profile dialog before with no problems, to stay on the safe side I think I'll now steer clear of it.

I didn't use a different version. I do have CCleaner, but it is carefully set to delete ONLY cookies (other than those marked Keep) and browser cache; and to run only on demand, which I did not do. And I wouldn't think a corrupt places.sqlite could have affected the UI (namely the url box getting narrower -- something I've never seen before). That was strange. I do have a copy of 64-bit 52esr on the computer (my regular installation of Firefox -- now 60.3esr -- is 32-bit), but the 64-bit 52esr "never update" is there strictly for use by another user account I created for when I want to use Scrapbook, which is not supported by Quantum. As a precaution I purposely made 64-bit 52esr hard to get to (in addition to a separate user, there are no shortcuts). Anyway, I have used the alternate profile dialog before with no problems, to stay on the safe side I think I'll now steer clear of it.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8212 solutions 67177 answers

These are kind of fascinating:

Your Firefox seems to have its own distinct Home button that none of the rest of us have.

Lately, I think that would only be possible via custom style rules in a userChrome.css file, possibly with the addition of a .png or .svg file in the same folder or a subfolder with the alternate artwork. Do you see any image files in your chrome folder with the userChrome.css file?

If not...

If you want to poke at it and learn its source, I think you would need to learn a bit about the Browser Toolbox, an interactive inspector for browser parts (similar to the Page Inspector for poking around in web pages).

https://developer.mozilla.org/docs/Tools/Browser_Toolbox

By inspecting that toolbar button, you should find how its artwork is specified, and the source of it.

These are kind of fascinating: <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2018-11-25-22-34-28-8cf04a.png"> <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2018-11-29-12-11-43-c33492.png" width="500"> Your Firefox seems to have its own distinct Home button that none of the rest of us have. Lately, I think that would only be possible via custom style rules in a userChrome.css file, possibly with the addition of a .png or .svg file in the same folder or a subfolder with the alternate artwork. Do you see any image files in your chrome folder with the userChrome.css file? If not... If you want to poke at it and learn its source, I think you would need to learn a bit about the Browser Toolbox, an interactive inspector for browser parts (similar to the Page Inspector for poking around in web pages). https://developer.mozilla.org/docs/Tools/Browser_Toolbox By inspecting that toolbar button, you should find how its artwork is specified, and the source of it.
Was this helpful to you?
Quote

Question owner

Again, I didn't even have a userChrome.css file until I created one within the last week after I updated to 60.3esr and wished to reinstate some of my old layout elements that I lost as a result (since I could no longer use Classic Theme Restorer). But the Home button text has been there since at least 2008. Strange.

The Browser Toolbox idea looks interesting, maybe when I have some time I'll look into it.

Again, I didn't even have a userChrome.css file until I created one within the last week after I updated to 60.3esr and wished to reinstate some of my old layout elements that I lost as a result (since I could no longer use Classic Theme Restorer). But the Home button text has been there since at least 2008. Strange. The Browser Toolbox idea looks interesting, maybe when I have some time I'll look into it.

Modified by Rick216

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17006 solutions 153568 answers

Can you post the content of your userChrome.css file just to be sure?

It must be something in your profile folder if a new profile doesn't have it.

EDIT: Can you also list your extensions (see about:support)?

Can you post the content of your userChrome.css file just to be sure? It must be something in your profile folder if a new profile doesn't have it. EDIT: Can you also list your extensions (see about:support)? *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox

Modified by cor-el

Was this helpful to you?
Quote

Question owner

First here are my 7 enabled add-ons. (Let me know if you would also like me to list my 8 disabled webextension add-ons or my 19 disabled legacy add-ons.)

Adblock Plus 3.4.1 Close All Tabs Button 1.3 Flagfox 6.1.8 Google search link fix 1.6.7 Print As Plain Text 1.8.0 Print/Print Preview 1.3 Send Link from context menu 1.3.2

Below is my full userChrome.css file. ( I don't claim to understand much about css. I just pieced this together from four different css style sheets and code that made UI changes that I wanted. I don't understand why/how the forum splits up what I pasted in, or why it does things like change # to numerals.)

    /* ACTIVE TAB BACKGROUND COLOR */

    .tab-content[selected="true"] {
      background: rgba(255, 255, 128, 0.5) !important;
    }

/* Add Shape to Background Tabs (Firefox 57) */
.tabbrowser-tab:not([selected="true"]), 
.tabbrowser-tab:not([selected="true"]) .tab-background {
  border-radius: 20px 20px 0px 0px / 60% 60% 0px 0px !important;
}
/* Set background color for dark themes */
#main-window[lwthemetextcolor="bright"] .tabbrowser-tab:not([selected="true"]) {
  background: linear-gradient(to top, rgba(255,255,255,0), rgba(255,255,255,0.1) 60%, rgba(255,255,255,0.2) 80%, rgba(255,255,255,0.3));
}
/* Draw border for light themes */
#main-window:not([lwthemetextcolor="bright"]) .tabbrowser-tab:not([selected="true"]) {
  border-left: 1px solid var(--tabs-border-color) !important;
  border-top: 2px solid var(--tabs-border-color) !important;
  border-right: 1px solid var(--tabs-border-color) !important;
}
/* Remove the animated tab line from hovered bg tabs */
.tabbrowser-tab:hover .tab-line:not([selected="true"]) {
  display: none !important;
}
/* Remove the short vertical lines between bg tabs */
.tabbrowser-tab::before, .tabbrowser-tab::after {
  border: none !important;
}

/* Tab bar below Navigation & Bookmarks Toolbars */
#nav-bar { /* main toolbar */
  -moz-box-ordinal-group: 2 !important;
  box-shadow: none !important;
}
#PersonalToolbar { /* bookmarks toolbar */
  -moz-box-ordinal-group: 1 !important;
}
#TabsToolbar { /* tab bar */
  -moz-box-ordinal-group: 3 !important;
  padding-top: 0 !important;
}
/* Clean up spacing */
.titlebar-placeholder {
  display: none !important;
}
toolbarbutton.bookmark-item {
  padding-top: 2px !important;
  padding-bottom: 2px !important;
}

/* Vertical space for min/max/close buttons above the main toolbar */
/* On Mac, if not showing title bar, allow 20 pixels */
#main-window[tabsintitlebar="true"]:not([inFullscreen="true"]) #toolbar-menubar:not([accesskey]) ~  #nav-bar {
  margin-top: 20px !important;
}
/* On Windows, if not showing title bar or menu bar, allow 20 pixels */
#main-window[tabsintitlebar="true"] #toolbar-menubar[autohide="true"][inactive="true"] ~ #nav-bar {
  margin-top: 20px !important; /* More px may be better on Win10 */
}
/* Sorry, Linux users, I don't know the best approach for you! */

/* Background for Light and Dark themes */
#main-window[lwthemetextcolor="bright"] #TabsToolbar, 
#main-window[lwthemetextcolor="dark"] #TabsToolbar {
  background-color: var(--chrome-secondary-background-color) !important;
  background-image: none !important;
}
#main-window[lwthemetextcolor="dark"] .scrollbutton-up,
#main-window[lwthemetextcolor="dark"] .scrollbutton-down,
#main-window[lwthemetextcolor="dark"] .tabs-newtab-button,
#main-window[lwthemetextcolor="dark"] #new-tab-button,
#main-window[lwthemetextcolor="dark"] #alltabs-button {
  fill: var(--lwt-text-color) !important;
}
/* Left and right borders on Win 7 & 8, but not on 10 and later: */
@media (-moz-os-version: windows-win7), (-moz-os-version: windows-win8) {
  /* Vertical toolbar border */
  #main-window[sizemode=normal] #navigator-toolbox > toolbar#TabsToolbar {
    border-left: 1px solid hsla(240,5%,5%,0.3) !important;;
    border-right: 1px solid hsla(240,5%,5%,0.3) !important;;
    background-clip: padding-box;
  }
}

/* Override vertical shifts when moving a tab (9 Jan 2018) */
#TabsToolbar[movingtab] {
  padding-bottom: 0 !important;
}
#TabsToolbar[movingtab] > .tabbrowser-tabs {
  padding-bottom: 0 !important;
  margin-bottom: 0 !important;
}
#TabsToolbar[movingtab] + #nav-bar {
  margin-top: 0 !important;
}

/* Snip I found to make bookmark-width unlim, thus replicate Places... */
/* Full Titles. This is solution at... */
/* https://support.mozilla.org/en-US/questions/803166 */
#personal-bookmarks .bookmark-item,
#bookmarksMenuPopup .bookmark-item { max-width: none !important; }
First here are my 7 enabled add-ons. (Let me know if you would also like me to list my 8 disabled webextension add-ons or my 19 disabled legacy add-ons.) Adblock Plus 3.4.1 Close All Tabs Button 1.3 Flagfox 6.1.8 Google search link fix 1.6.7 Print As Plain Text 1.8.0 Print/Print Preview 1.3 Send Link from context menu 1.3.2 Below is my full userChrome.css file. ( I don't claim to understand much about css. I just pieced this together from four different css style sheets and code that made UI changes that I wanted. I don't understand why/how the forum splits up what I pasted in, or why it does things like change # to numerals.) <pre><nowiki> /* ACTIVE TAB BACKGROUND COLOR */ .tab-content[selected="true"] { background: rgba(255, 255, 128, 0.5) !important; } /* Add Shape to Background Tabs (Firefox 57) */ .tabbrowser-tab:not([selected="true"]), .tabbrowser-tab:not([selected="true"]) .tab-background { border-radius: 20px 20px 0px 0px / 60% 60% 0px 0px !important; } /* Set background color for dark themes */ #main-window[lwthemetextcolor="bright"] .tabbrowser-tab:not([selected="true"]) { background: linear-gradient(to top, rgba(255,255,255,0), rgba(255,255,255,0.1) 60%, rgba(255,255,255,0.2) 80%, rgba(255,255,255,0.3)); } /* Draw border for light themes */ #main-window:not([lwthemetextcolor="bright"]) .tabbrowser-tab:not([selected="true"]) { border-left: 1px solid var(--tabs-border-color) !important; border-top: 2px solid var(--tabs-border-color) !important; border-right: 1px solid var(--tabs-border-color) !important; } /* Remove the animated tab line from hovered bg tabs */ .tabbrowser-tab:hover .tab-line:not([selected="true"]) { display: none !important; } /* Remove the short vertical lines between bg tabs */ .tabbrowser-tab::before, .tabbrowser-tab::after { border: none !important; } /* Tab bar below Navigation & Bookmarks Toolbars */ #nav-bar { /* main toolbar */ -moz-box-ordinal-group: 2 !important; box-shadow: none !important; } #PersonalToolbar { /* bookmarks toolbar */ -moz-box-ordinal-group: 1 !important; } #TabsToolbar { /* tab bar */ -moz-box-ordinal-group: 3 !important; padding-top: 0 !important; } /* Clean up spacing */ .titlebar-placeholder { display: none !important; } toolbarbutton.bookmark-item { padding-top: 2px !important; padding-bottom: 2px !important; } /* Vertical space for min/max/close buttons above the main toolbar */ /* On Mac, if not showing title bar, allow 20 pixels */ #main-window[tabsintitlebar="true"]:not([inFullscreen="true"]) #toolbar-menubar:not([accesskey]) ~ #nav-bar { margin-top: 20px !important; } /* On Windows, if not showing title bar or menu bar, allow 20 pixels */ #main-window[tabsintitlebar="true"] #toolbar-menubar[autohide="true"][inactive="true"] ~ #nav-bar { margin-top: 20px !important; /* More px may be better on Win10 */ } /* Sorry, Linux users, I don't know the best approach for you! */ /* Background for Light and Dark themes */ #main-window[lwthemetextcolor="bright"] #TabsToolbar, #main-window[lwthemetextcolor="dark"] #TabsToolbar { background-color: var(--chrome-secondary-background-color) !important; background-image: none !important; } #main-window[lwthemetextcolor="dark"] .scrollbutton-up, #main-window[lwthemetextcolor="dark"] .scrollbutton-down, #main-window[lwthemetextcolor="dark"] .tabs-newtab-button, #main-window[lwthemetextcolor="dark"] #new-tab-button, #main-window[lwthemetextcolor="dark"] #alltabs-button { fill: var(--lwt-text-color) !important; } /* Left and right borders on Win 7 & 8, but not on 10 and later: */ @media (-moz-os-version: windows-win7), (-moz-os-version: windows-win8) { /* Vertical toolbar border */ #main-window[sizemode=normal] #navigator-toolbox > toolbar#TabsToolbar { border-left: 1px solid hsla(240,5%,5%,0.3) !important;; border-right: 1px solid hsla(240,5%,5%,0.3) !important;; background-clip: padding-box; } } /* Override vertical shifts when moving a tab (9 Jan 2018) */ #TabsToolbar[movingtab] { padding-bottom: 0 !important; } #TabsToolbar[movingtab] > .tabbrowser-tabs { padding-bottom: 0 !important; margin-bottom: 0 !important; } #TabsToolbar[movingtab] + #nav-bar { margin-top: 0 !important; } /* Snip I found to make bookmark-width unlim, thus replicate Places... */ /* Full Titles. This is solution at... */ /* https://support.mozilla.org/en-US/questions/803166 */ #personal-bookmarks .bookmark-item, #bookmarksMenuPopup .bookmark-item { max-width: none !important; }</nowiki></pre>

Modified by cor-el

Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.