Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do I suddenly get this message and how do I fixed it on my Mac? An error occurred during a connection to discussions.apple.com. Peer received a valid certif

  • 3 replies
  • 1 has this problem
  • 3 views
  • Last reply by jscher2000

more options

I suddenly get this message everytime I try to google something, my gmail also is not loading properly What's wrong??!!!

All Replies (3)

more options
more options

Thanks for your reply.

That makes sense, ive just signed up with ESET.

Exact error message says:

An error occurred during a connection to discussions.apple.com. Peer received a valid certificate, but it’s access was denied. Error code: SSL_ERROR_ACCESS_DENIED_ALERT

How do I fix it though??


Thank you

more options

The code SSL_ERROR_ACCESS_DENIED_ALERT doesn't come up here very often.

Was the error message referring to Apple's discussion forum coming up in an expected context, such as a link to those forums? I certainly wouldn't expect you to see that one when you want to access Gmail...

Do you access the internet through a business network (either from inside the office or via VPN)?

Please scan through these threads for discussion of things that worked or didn't work. I wouldn't say there are any definitive solutions here yet, but various things that seem to have helped in some cases:

  • SSL mistake - Firefox 61, Safe Mode marked as solution, but that's a workaround, really, not a solution

For reference:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?