Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox hides icons and buttons on webpages

  • 32 replies
  • 1 has this problem
  • 173 views
  • Last reply by haribadhri

more options

unable to get the gmail icon only that too in my home system but not anywhere else.

i have attached the file

Attached screenshots

All Replies (20)

more options

Hi, is that hindering the performance of Gmail ?

Please : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 61.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

Hi, i have done the above method and i have posted result

one more thing i have cleaned registry too also.

more options

Make sure you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure you allow pages to choose their own colors.

  • Options/Preferences -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

more options

cor-el said

Make sure you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings. Make sure you allow pages to choose their own colors.
  • Options/Preferences -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"
Try "Never" if the default "Only with High Contrast themes" isn't working.

yes that was done by me

please note: i have been using firefox since 2002 strongly and i mostly recommend it to use because open source and security concerns issue.

for all the suggestion made by me to my friends find it useful and easy to browse.

it is all started from may 2018 icons disappear from webpage since i know where it will be and with help of tool tip i was able to continue to use.. but know these things why icon do not disappear i want to know that it is and nothing.

i use opera to know what mails i have to delete but to know mail i use firefox only.

Modified by haribadhri

more options

Instead of using the High Contrast theme, maybe you'd like to give this extension a try :

https://addons.mozilla.org/en-US/firefox/addon/nosquint-plus/

more options

McCoy said

Instead of using the High Contrast theme, maybe you'd like to give this extension a try : https://addons.mozilla.org/en-US/firefox/addon/nosquint-plus/

i did that and result is down below. i am just pain in neck i think so.

more options

now the problem goes to another step like whereever i login the account the problem persists.

now it has become universal. i think so.

because the similiar login for other in same computer with same browser that like win 7 with firefox 61.x.x is giving good results as compared to my login.

let me wait i know will get my solution definitely but not immediately ....

my hope will be answered by some one i think so will try to give a screen shot in two or three days.

more options

haribadhri said

i did that and result is down below.
Your screenshot shows that you have the Text zoom level set to 100% (default) - what if you increase it to e.g. 120%  ?

i am just pain in neck i think so.

You are definately not a pain in the neck (or anywhere else)  !

more options

When I look at the second screenshot you posted, I don't see the Google apps icon, and (even more important) I don't see the Settings icon (cog wheel). Are those still missing  ?

more options

yes that is why continuously posting information

any technical level details how to fetch let me know i will do it post it here.

thanks for understanding me and travelling with me.

more options

Just saw a similar thread here :

https://productforums.google.com/forum/#!topic/gmail/zUGHSNhVvzA

No solution .....


Let's try Firefox in Safe Mode, to see if maybe one of your extensions (if you have any) could be causing this :

If Firefox is not running : Hold down the Shift key when starting Firefox.

If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode


If Safe Mode doesn't make a difference, then you could try the Refresh feauture  :

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.
more options

in the preview post made on the aug 22 itself was addons disabled mode. only i did not tried the safemode.

after seeing your post i have done and that was not given result i have taken a screen shot and posted.

next i refreshed the firefox with the links given in that page. it done it part it is same result.

on the 22 aug installation i went head open the registry and clean each firefox key and tag items and then mozilla this has restored the opening loading of the gmail view and other things but it did not helped me that is posted on the 22 aug itself without dragging across.

any how thanks for help and immediate mccoy i appreciate your effect and handling situation.

thanks and regard with hearts

more options

Ahhh, still no luck - I am so sorry ......

I'm going to call for help - please, hang in there.

more options

A complete stab in the dark and maybe far-fetched, but would you try this please :

When you're on your Gmail page, click on the 'i' in a circle, next to the padlock at the left side of the address bar. That will take you to 'Page Info'. Then click on the little black arrow on the dropdown and then on 'More Information'. Click on the 'Media' tab - is 'Block Images' unchecked  ?

more options

Sometimes the permission problem is with a server used by the site, rather than the main site itself (mail.google.com). To investigate that, could you check the Media tab of the Page Info dialog?

While you are on the site, you can call that up using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

At the top, click "Media". Firefox should show a list of all the images requested in the page.

If you click in the list, Firefox should show the image details plus the block status (a box you can uncheck). You can use the down arrow to skim through the list. For example:

more options

'Couldn't let it go just yet and was thinking that, if on Page Info => Media tab 'Block Images' is unchecked, then that's not it either.

This may sound like it doesn't make any sense, but do you by any chance use a custom Windows 10 theme  ?

If so, would you change it back to Windows 10 default theme and see if the icons will show up again  ?

Windows Settings => Personalization => Themes

more options

unable to find the media tab and did the following thing.

Chosen solution Try to toggle this pref to false on the about:config page.

media.block-autoplay-until-in-foreground = false You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

http://kb.mozillazine.org/about:config Read this answer in context 4

now the problem the gear wheel itself is not working by clicking the gear wheel the a popup will display now that is too not showing now. that is popup is persist even before the problem has started or little parallelly they are existing i think so.

thanks man's both of you for helping me out.

if your any code or report to taken please let me know it will do it.

more options

haribadhri said

unable to find the media tab

It is in the Page Info dialog when you call up Page Info for the current page. While you are on the site, you can call that up using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Media is one of the categories along the top.

Try to toggle this pref to false on the about:config page.

media.block-autoplay-until-in-foreground = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

This setting is for audio and video files, not for images or buttons.


Maybe this is not a Firefox setting. Could you try:

New Profile Test

This takes about 3 minutes, plus the time to test Gmail.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like August2018, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Does Gmail work any better in the new profile?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

more options

yeah i did that and result is sorry to say that no impact on my machine.

if you want a report needs to taken from my computer just give me hint and step of it so that i will share the report here.

attached file is result

more options

What happens when you try to load these background images directly?

Gmail Logo for dark theme (different sizes):

"+" Icon on Compose button:

Mail item checkbox background image:


A couple tools that might be useful in your testing:

Web Console

You can open the Web Console in the lower part of the tab using either:

  • "3-bar" menu button > Web Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console
  • (Windows) Ctrl+Shift+k

Then reload the image in the upper part of the tab and watch for error or security messages. (The lines with blue triangles generally are not significant unless you suspect a style rule problem.) Anything that sounds like it could be relevant?

Network Monitor

To open the Network Monitor it the lower part of the tab, you can use either:

  • "3-bar" menu button > Web Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • (Windows) Ctrl+Shift+e

If you have the Web Console open, just click the "Network" heading on the bar along the top of the Developer Tools pane.

When you reload the page/image in the top part of the tab, Firefox should start listing all the files it is requesting, along with information about whether the request was successful. Any unusual codes here (200 = success, 304 = not changed from the cached version)?

  1. 1
  2. 2