Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google safe search won't turn off since version 60

  • 12 replies
  • 1 has this problem
  • 39 views
  • Last reply by Shadow110

more options

I have four browsers, some of them are Firefox based: Firefox 61 (64-bit latest version). Comodo Ice Dragon 60.0.2.10 (64-bit) (Portable Edition), Pale Moon (the old FF version, 27.9.3), Opera and IE. I also have a few search engines, including Yahoo, Bing, Google, Duck Duck Go, and others for some specific sites search that I added or compiled, like Firefox Support (this very site).

Google search with safe search turned off works without problem with old FF Pale Moon and and IE, but not with Firefox 61, Ice Dragon 60 and Opera. There is no problem with any other search engines on any browser, all working well with safe search off.Hence, I believe there is a (intentional) problem not letting Google safe search to be turned off with FF versions 60 and 61, and Opera.

Firefox is my main and default browser, and Google the main search, so I need them work with safe search off. What can I do to reverse this situation and make them Work as they always had. please?

All Replies (12)

more options

Hi, some important stuff, what security software are you using ? What have you tried to fix the problem ?

SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

more options

Stab in the dark, but could it be that you have inadvertently clicked 'Lock SafeSearch'  ?

See : https://www.google.com/preferences?hl=en

more options

Sorry, I replied before, but now I see that I surely have forgotten to click on the Post Reply button and I lost it. I will try to repeat what I lost. _________________________________

I have not changed the software for about two years, nothing new, except for the updates. For security I have Avast Premier.

I have tried so many things that i might have forgotten to mention some. One is that I had already tried Firefox in safe Mode without and it makes no difference.

I also have read some articles on the Google Search Help Forum, but couldn't find a hint.

As I said, the issue is only on most recent Firefox versions, and only with Google search. It does not happen on ancient version and does not happen with other search engines. I might be wrong, but this makes me believe that there is some interaction with ine another. The same also happens with Opera, but I don't really care because it is is just a secondary browser.

more options

Hi, I would say that it is your Avast Security making a issue with the page. Please disable it and then reload the Google page and try to turn it off.

There is security software like Avast/AVG, Kaspersky, BitDefender,ESET & sometimes Mcafee that intercept secure connections and send their own certificate. If you are running any of the above software please check their community forum for a work around to apply settings.

Please let us know if this solved your issue or if need further assistance.

more options

@ Pkshadow, you are right about the ant-viruses. They have become very obstructive, and today they are specially conceived for dumb people. I have received many viruses through the years, but I recognize them and don't need an antivirus for mail. We can loose a lot of data if they think they are protecting us, Or have unnecessary work recovering a file from the chest if we are lucky. That is why I already had some of Avast functions disabled. Now, following your instructions, I have disabled those concerning the Internet and the browsers or setting them to Ask:

  ▸Behaviour Shield
  ▸ Web Shield
  ▸ Ransomware Shield
  ▸ Real Site (off)
  ▸ Anti Spam (off)
  ▸ Browser Clean up (off)
  ▸ Passwords (off)

I am aware these are a bit too many, but in this try I believe too many is better than too less. Security Browser extension (off)

After configuring or disabling the Avast settings, I rebooted Firefox and reloaded the Google search page, but for may despair nothing changed, nothing at all.

Tomorrow, I will ask about this issue on Avast Forum because tonight is very late . Thank you

Modified by Straydog

more options

You have a ton of add-ons. I'd suggest running Firefox in Safe mode (Troubleshoot Firefox issues using Safe Mode) to see if any of them are causing issues.

Note, this is the Firefox support forum, we can't help with icedragon (people still use that?) or Opera.

I'd suggest uninstalling ALL anti-virus from your computer, and just using Microsoft Security Essentials and a monthly malwarebytes scan. Avast and all other anti-virus cause lots of issues, though it may not be the cause of issues here.

more options

@ Tyler Downer. Thank you for your reply.

I agree, most anti-viruses can interfere with the system without asking for permission and we have to search the settings to change some imposed configurations. They are not so safe as they claim, the Avast help forum was hacked a few years ago and the passwords stolen. Some sites impose settings for fake security. As an example, before, on this very site, if you chose to stay logged in, you turen off the computer or only the browser and when you came back you had what you typed after logging in. Now, with that choice removed, when you close either, you are logged out and when you come back all you wrote is lost for good. We can no longer choose to stay logged. If that ever make a security issue is the user's responsibility alone. He must respond for their choices and not just forbid a choice for millions.

Sorry, I have not asked for help with other browsers. I only mentioned them as examples or references.

I posted on Avast help forum as suggested above by Pkshadow. I believe I must wait for a reply and reproduce here before going ahead with uninstalling anything. Let's see the answer I'll get.

I have not seen a post with my issue either here on on the Avast forum. Only Google has plenty of complaints. They are answered with the links I posted above, and are closed before people can post back the results. It is clearly intentional. Google has always been very dishonest.

more options

For as strange as it may seem, the answer I got was link to a Wikipedia article which is list of search engines.

Taking you up at your word: A workaround https://en.wikipedia.org/wiki/List_of_search_engines Choose a search engine you like: (see attached)
  • Mulitple Search Engines.png (15.97 kB, 295x580 - viewed 2 times.)

I never abuse, askink for help on easy issues that I can solve myself. When I ask for help it is always for something difficult to solve, so I don't always get a solution. Now, it seems very difficult to get help on this issue.

more options

Yeah, I wouldn't suggest the anti-virus forums.

Please do the following:

Then, see if you still have an issue with Google being locked into safe search

more options

Also, do you have multiple browsers using the same profile? (example, are icedragon and Firefox using the same profile). If you are, then that is possibly what caused this issue.

more options

What is wrong with this site? My reply disappeared for the third time. I did not save a copy. Why should I if this never happened before? I do not come often, but it never happened even once for years and now it is like this. Something must be wrong here. I preview the reply, I post it and go away. When I come back hours later it is not there. Why?

more options

Hi, No idea. Make sure you hit Enter and you see it in the page posted.