X
Tap here to go to the mobile version of the site.

Support Forum

the black bars on the sides

Posted

Hello. I addressed this issue in support of Twitch, and they sent me to you. I have black bars on the sides of the stream when I look at Twitch. In the screenshot you see them. In full screen mode, or on other sites (YouTube), there are no such problems. I tried the techniques described here https://support.mozilla.org/en-US/questions/1095782, but nothing helped. http://prntscr.com/b9r7at

Hello. I addressed this issue in support of Twitch, and they sent me to you. I have black bars on the sides of the stream when I look at Twitch. In the screenshot you see them. In full screen mode, or on other sites (YouTube), there are no such problems. I tried the techniques described here https://support.mozilla.org/en-US/questions/1095782, but nothing helped. http://prntscr.com/b9r7at

Modified by Praime

Additional System Details

Installed Plug-ins

  • Garena Talk Plugin
  • Google Update
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0

Application

  • Firefox 46.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
  • Support URL: https://support.mozilla.org/1/firefox/46.0.1/WINNT/ru/

Extensions

  • Визуальные закладки 2.27.1 (vb@yandex.ru)
  • Элементы Яндекса 8.19.1 (yasearch@yandex.ru)
  • Adblock Plus 2.7.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Firefox Hello Beta 1.3.2 (loop@mozilla.org)
  • friGate - разблокировка сайтов 2.2.1.1-signed (e67f8350-7edf-11e3-baa7-0800200c9a66@fri-gate.org)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0 (firefox@getpocket.com)
  • Skype 8.3.0.9150 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A})
  • Splashtop Connect 1.1.6.3 ({91c612bf-2a7a-48b8-8c8c-6de28589b7a0}) (Inactive)
  • Splashtop Connect Companion 1.1.6.3 ({91c612bf-2a7a-48b8-8c8c-6de28589b7a1}) (Inactive)
  • Yoono 7.5.0 ({d9284e50-81fc-11da-a72b-0800200c9a66}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 660
  • adapterDescription2:
  • adapterDeviceID: 0x11c0
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 354e1458
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.17568
  • driverDate: 5-19-2016
  • driverDate2:
  • driverVersion: 10.18.13.6822
  • driverVersion2:
  • info: {u'AzureContentBackend': u'cairo', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webglRendererMessage: [u'']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers
See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Question owner

He performed all these tasks, but they did not help.

He performed all these tasks, but they did not help.

Question owner

The problem is not solved

The problem is not solved
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe websites. Are there any problems?

Then restart.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe websites. Are there any problems? Then restart.

Question owner

FredMcD said

Many site issues can be caused by corrupt cookies or cache.
  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.
Type about:preferences<Enter> in the address bar.
  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.
If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode; Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration. Poke around safe websites. Are there any problems? Then restart.

These solutions also did not help unfortunately :(

''FredMcD [[#answer-882447|said]]'' <blockquote> Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe websites. Are there any problems? Then restart. </blockquote> These solutions also did not help unfortunately :(
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.

Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance.''' Then select '''Default.''' Now restart Firefox.
jscher2000
  • Top 10 Contributor
8773 solutions 71727 answers

Could you give a link to the page you screenshotted? When I poke around on Twitch TV, there is a left sidebar (or left and right sidebar), so I don't think I'm in the right area, or I'm not clicking the correct display options.

Could you give a link to the page you screenshotted? When I poke around on Twitch TV, there is a left sidebar (or left and right sidebar), so I don't think I'm in the right area, or I'm not clicking the correct display options.

Question owner

FredMcD said

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A) On the left side of the page, select Appearance. Then select Default. Now restart Firefox.

I have all the time is the standard appearance

''FredMcD [[#answer-882483|said]]'' <blockquote> Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance.''' Then select '''Default.''' Now restart Firefox. </blockquote> I have all the time is the standard appearance

Question owner

jscher2000 said

Could you give a link to the page you screenshotted? When I poke around on Twitch TV, there is a left sidebar (or left and right sidebar), so I don't think I'm in the right area, or I'm not clicking the correct display options.

Sorry, I forgot that it was for the stream in the screenshot. But this problem on all channels Twitch. Like here https://www.twitch.tv/dotamajorru http://prntscr.com/bbu49a Without the left and right side bar And with them http://prntscr.com/bbu4zq

''jscher2000 [[#answer-882562|said]]'' <blockquote> Could you give a link to the page you screenshotted? When I poke around on Twitch TV, there is a left sidebar (or left and right sidebar), so I don't think I'm in the right area, or I'm not clicking the correct display options. </blockquote> Sorry, I forgot that it was for the stream in the screenshot. But this problem on all channels Twitch. Like here https://www.twitch.tv/dotamajorru http://prntscr.com/bbu49a Without the left and right side bar And with them http://prntscr.com/bbu4zq
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

Check your zoom controls.

<Control> + (plus) enlarge <Control> - (minus) reduce <Control> 0 (zero) restore

Check your zoom controls. <Control> '''+''' (plus) enlarge <Control> '''-''' (minus) reduce <Control> '''0''' (zero) restore

Question owner

FredMcD said

Check your zoom controls. <Control> + (plus) enlarge <Control> - (minus) reduce <Control> 0 (zero) restore


Did not help

''FredMcD [[#answer-883518|said]]'' <blockquote> Check your zoom controls. <Control> '''+''' (plus) enlarge <Control> '''-''' (minus) reduce <Control> '''0''' (zero) restore </blockquote> Did not help
jscher2000
  • Top 10 Contributor
8773 solutions 71727 answers

Okay, what's happening here is, when you are not in full screen mode, and you minimize one or both sidebars the black rectangle behind the video is widened to fill the space and becomes wider than 16:9. Flash does not distort the aspect ratio of the video to fit the box, instead it fits one dimension (height, usually, unless you make the browser window very narrow) and computes the width accordingly, which leaves black margins on both sides.

For what it's worth, I see the identical behavior in Google Chrome when I minimize one or both sidebars.

Okay, what's happening here is, when you are not in full screen mode, and you minimize one or both sidebars the black rectangle behind the video is widened to fill the space and becomes wider than 16:9. Flash does not distort the aspect ratio of the video to fit the box, instead it fits one dimension (height, usually, unless you make the browser window very narrow) and computes the width accordingly, which leaves black margins on both sides. For what it's worth, I see the identical behavior in Google Chrome when I minimize one or both sidebars.

Question owner

jscher2000 said

Okay, what's happening here is, when you are not in full screen mode, and you minimize one or both sidebars the black rectangle behind the video is widened to fill the space and becomes wider than 16:9. Flash does not distort the aspect ratio of the video to fit the box, instead it fits one dimension (height, usually, unless you make the browser window very narrow) and computes the width accordingly, which leaves black margins on both sides. For what it's worth, I see the identical behavior in Google Chrome when I minimize one or both sidebars.

That's right, I also appear in Google Chrome Do you have any idea what can you do?

''jscher2000 [[#answer-883588|said]]'' <blockquote> Okay, what's happening here is, when you are not in full screen mode, and you minimize one or both sidebars the black rectangle behind the video is widened to fill the space and becomes wider than 16:9. Flash does not distort the aspect ratio of the video to fit the box, instead it fits one dimension (height, usually, unless you make the browser window very narrow) and computes the width accordingly, which leaves black margins on both sides. For what it's worth, I see the identical behavior in Google Chrome when I minimize one or both sidebars. </blockquote> That's right, I also appear in Google Chrome Do you have any idea what can you do?
jscher2000
  • Top 10 Contributor
8773 solutions 71727 answers

I think using full screen is the best workaround. Otherwise, you would need to find a way to increase the height of the black box, which might not be easy.

I think using full screen is the best workaround. Otherwise, you would need to find a way to increase the height of the black box, which might not be easy.