X
Tap here to go to the mobile version of the site.

Support Forum

can't log in

Posted

Having trouble logging into my firefox account to ask a question. Since the change to Firefox 40, I can't load Farmville2 on Firefox. I can open my inbox and answer requests but I have to use chrome to play, but I would prefer to use Firefox.Also I was asked to take a Firefox survey but when I was done and hit submit...it wouldn't submit....another survey today asked if I was happy with Firefox, when I said no, it didn't even ask why (I was hoping to contact someone to fix the problems with zynga), just closed the survey.  ???? I have tried to find a contact us button, but just keep getting redirected to other places. I hope someone can help me with this problem

I just refreshed and nothing has changed so far.

Thanks Peggy

Having trouble logging into my firefox account to ask a question. Since the change to Firefox 40, I can't load Farmville2 on Firefox. I can open my inbox and answer requests but I have to use chrome to play, but I would prefer to use Firefox.Also I was asked to take a Firefox survey but when I was done and hit submit...it wouldn't submit....another survey today asked if I was happy with Firefox, when I said no, it didn't even ask why (I was hoping to contact someone to fix the problems with zynga), just closed the survey. ???? I have tried to find a contact us button, but just keep getting redirected to other places. I hope someone can help me with this problem I just refreshed and nothing has changed so far. Thanks Peggy

Chosen solution

Hi Kohei, that sounds like the problem.

So as a short-term workaround and test to confirm the diagnosis, it sounds like Peggy should try this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste ipc and pause while the list is filtered

(3) Double-click the dom.ipc.plugins.asyncInit preference to switch its value from true to false

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.51.2 for Mozilla browsers
  • Shockwave Flash 18.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.9.159

Application

  • Firefox 40.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.2/WINNT/en-US/

Extensions

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0f31
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 085e1025
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17999
  • driverDate: 11-18-2013
  • driverDate2:
  • driverVersion: 10.18.10.3355
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Hi Peggy, that sounds very frustrating.

On the Farmville issue, do you notice any icons toward the left end of the toolbar when trying to load the game? Normally, you would see the plugin notification icon near the address, which looks like a small, dark gray lego block. If you click that, it should indicate that Flash is allowed on Facebook (or Zynga's site, if you're over there).

If it's red, that indicates a Flash update is needed, which you can get here: https://www.adobe.com/products/flashplayer/distribution3.html (either the EXE or MSI file for plugin-based browers).

Are there any other icons, such as a shield? The shield icon indicates a problem with insecure content embedded in a secure page. This article has more information: Mixed content blocking in Firefox


Regarding the surveys, I'm not sure what the problem was there. Hopefully the Refresh will clear whatever that was.

Hi Peggy, that sounds very frustrating. On the Farmville issue, do you notice any icons toward the left end of the toolbar when trying to load the game? Normally, you would see the plugin notification icon near the address, which looks like a small, dark gray lego block. If you click that, it should indicate that Flash is allowed on Facebook (or Zynga's site, if you're over there). If it's red, that indicates a Flash update is needed, which you can get here: https://www.adobe.com/products/flashplayer/distribution3.html (either the EXE or MSI file for ''plugin-based browers''). Are there any other icons, such as a shield? The shield icon indicates a problem with insecure content embedded in a secure page. This article has more information: [[How does content that isn't secure affect my safety?]] ---- Regarding the surveys, I'm not sure what the problem was there. Hopefully the Refresh will clear whatever that was.

Question owner

Hi Jscher, Thanks for trying but it didn't help....I re-downloaded flash, etc. and tried again but the loading bar is still stuck. There is only the grey lego block icon....no shields.

The strange thing is that I can usually load the game with firefox once a day. but if it crashes or I sign out, it won't load again. Today...just can't load it on firefox at all...on zynga or facebook.

Sure wish this would get fixed soon. Firefox is slower loading as well...the chart shows it is taking 26 seconds now. I noticed that when I am typing, I am almost finished the sentence but the cursor is still on the first word(this was on facebook this morning) seems ok here.

Hi Jscher, Thanks for trying but it didn't help....I re-downloaded flash, etc. and tried again but the loading bar is still stuck. There is only the grey lego block icon....no shields. The strange thing is that I can usually load the game with firefox once a day. but if it crashes or I sign out, it won't load again. Today...just can't load it on firefox at all...on zynga or facebook. Sure wish this would get fixed soon. Firefox is slower loading as well...the chart shows it is taking 26 seconds now. I noticed that when I am typing, I am almost finished the sentence but the cursor is still on the first word(this was on facebook this morning) seems ok here.
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

It's good to hear that it can work at least one time, but I'm not sure what the problem is with later loads. Have you tried these "usual" things?

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

You also can clear Firefox's cache using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

Note: Flash games can use Flash local storage to save data, and this is separate from Firefox's cache. If you want to look into clearing it, Adobe has a control panel here: http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager07.html

(2) Remove your facebook.com and zynga.com cookies (save any pending work first). While viewing a page on either site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then change the box at the top from facebook.com to zynga.com, or the other way around, and clear cookies for the other site.

Then try reloading the game. Does that help?

It's good to hear that it can work at least one time, but I'm not sure what the problem is with later loads. Have you tried these "usual" things? When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache You also can clear Firefox's cache using: "3-bar" menu button (or Tools menu) > Options > Advanced On the Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes. '''''Note:''''' Flash games can use Flash local storage to save data, and this is separate from Firefox's cache. If you want to look into clearing it, Adobe has a control panel here: http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager07.html (2) Remove your facebook.com and zynga.com cookies (save any pending work first). While viewing a page on either site, try either: * right-click and choose View Page Info > Security > "View Cookies" * (menu bar) Tools > Page Info > Security > "View Cookies" * click the padlock or globe icon in the address bar > More Information > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then change the box at the top from facebook.com to zynga.com, or the other way around, and clear cookies for the other site. Then try reloading the game. Does that help?
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Regarding performance on pages that use Flash, some systems have a problem with the protected mode feature of the Flash player plugin. That feature does have security benefits, so if disabling it doesn't help after a few hours of testing, you probably want to re-enable it. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

Note: All tabs with Flash need to be closed for a few minutes to cancel any current use of protected mode, or you can exit and start Firefox up again.

Regarding performance on pages that use Flash, some systems have a problem with the protected mode feature of the Flash player plugin. That feature does have security benefits, so if disabling it doesn't help after a few hours of testing, you probably want to re-enable it. You can disable it using the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then ''uncheck'' the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps. Note: All tabs with Flash need to be closed for a few minutes to cancel any current use of protected mode, or you can exit and start Firefox up again.
Kohei 9 solutions 62 answers

Helpful Reply

There is a Flash issue in Firefox 40. The patch is coming.

There is a [https://developer.mozilla.org/en-US/Firefox/Releases/40/Site_Compatibility#Plug-ins Flash issue in Firefox 40]. The patch is coming.
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Chosen Solution

Hi Kohei, that sounds like the problem.

So as a short-term workaround and test to confirm the diagnosis, it sounds like Peggy should try this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste ipc and pause while the list is filtered

(3) Double-click the dom.ipc.plugins.asyncInit preference to switch its value from true to false

Hi Kohei, that sounds like the problem. So as a short-term workaround and test to confirm the diagnosis, it sounds like Peggy should try this: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''ipc''' and pause while the list is filtered (3) Double-click the '''dom.ipc.plugins.asyncInit''' preference to switch its value from true to false
KatieLu 1 solutions 6 answers

There is a similar problem in Farmville (1), whereby although the game appears to load, there are various functions such as opening craft shops that no longer work. I initially got round the problem by reverting to FF 39.0.3 and then I found the notes from Aaron Klutz about his changes to asynchronous initialization and realized that was the likely cause. I re-updated to FF 40.0.2 and then went into about:config and changed the value of "Dom.ipc.plugins.asyncInit" from True back to False (as it was prior to version 40 being released) and everything works. This solution is fine for the "computer savvy", but not something that the "average" Farmville player should have to do. I hope Mozilla and Zynga are working quickly to sort this out. I do not know if any other Flash games are affected, but I would suspect they might.

There is a similar problem in Farmville (1), whereby although the game appears to load, there are various functions such as opening craft shops that no longer work. I initially got round the problem by reverting to FF 39.0.3 and then I found the notes from Aaron Klutz about his changes to asynchronous initialization and realized that was the likely cause. I re-updated to FF 40.0.2 and then went into about:config and changed the value of "Dom.ipc.plugins.asyncInit" from True back to False (as it was prior to version 40 being released) and everything works. This solution is fine for the "computer savvy", but not something that the "average" Farmville player should have to do. I hope Mozilla and Zynga are working quickly to sort this out. I do not know if any other Flash games are affected, but I would suspect they might.
DraeSwede 0 solutions 1 answers

Well zynga has just written "Hey farmers! Having trouble using Firefox? Try using using the new Chrome browser instead." it is written at the top of the FV2 game.

I have the same issue not being able to use Firefox with zynga games.  It loads the game then stops and ithis issue has just been since I installed the new version. The answers for a solution here are a bit much for ALL the FV and FV2 gamers I know including me. 


I love Firefox and have always recommended it to everyone and now they are giving me a thumbs down. Please someone fix this issue ASAP thank you so very much

Well zynga has just written "Hey farmers! Having trouble using Firefox? Try using using the new Chrome browser instead." it is written at the top of the FV2 game. I have the same issue not being able to use Firefox with zynga games. It loads the game then stops and ithis issue has just been since I installed the new version. The answers for a solution here are a bit much for ALL the FV and FV2 gamers I know including me. I love Firefox and have always recommended it to everyone and now they are giving me a thumbs down. Please someone fix this issue ASAP thank you so very much

Modified by DraeSwede

Question owner

PeggyHobbs said

Having trouble logging into my firefox account to ask a question. Since the change to Firefox 40, I can't load Farmville2 on Firefox. I can open my inbox and answer requests but I have to use chrome to play, but I would prefer to use Firefox.Also I was asked to take a Firefox survey but when I was done and hit submit...it wouldn't submit....another survey today asked if I was happy with Firefox, when I said no, it didn't even ask why (I was hoping to contact someone to fix the problems with zynga), just closed the survey.  ???? I have tried to find a contact us button, but just keep getting redirected to other places. I hope someone can help me with this problem I just refreshed and nothing has changed so far. Thanks Peggy

PeggyHobbs said

Having trouble logging into my firefox account to ask a question. Since the change to Firefox 40, I can't load Farmville2 on Firefox. I can open my inbox and answer requests but I have to use chrome to play, but I would prefer to use Firefox.Also I was asked to take a Firefox survey but when I was done and hit submit...it wouldn't submit....another survey today asked if I was happy with Firefox, when I said no, it didn't even ask why (I was hoping to contact someone to fix the problems with zynga), just closed the survey.  ???? I have tried to find a contact us button, but just keep getting redirected to other places. I hope someone can help me with this problem I just refreshed and nothing has changed so far. Thanks Peggy
''PeggyHobbs [[#question-1077962|said]]'' <blockquote> Having trouble logging into my firefox account to ask a question. Since the change to Firefox 40, I can't load Farmville2 on Firefox. I can open my inbox and answer requests but I have to use chrome to play, but I would prefer to use Firefox.Also I was asked to take a Firefox survey but when I was done and hit submit...it wouldn't submit....another survey today asked if I was happy with Firefox, when I said no, it didn't even ask why (I was hoping to contact someone to fix the problems with zynga), just closed the survey. ???? I have tried to find a contact us button, but just keep getting redirected to other places. I hope someone can help me with this problem I just refreshed and nothing has changed so far. Thanks Peggy </blockquote> ''PeggyHobbs [[#question-1077962|said]]'' <blockquote> Having trouble logging into my firefox account to ask a question. Since the change to Firefox 40, I can't load Farmville2 on Firefox. I can open my inbox and answer requests but I have to use chrome to play, but I would prefer to use Firefox.Also I was asked to take a Firefox survey but when I was done and hit submit...it wouldn't submit....another survey today asked if I was happy with Firefox, when I said no, it didn't even ask why (I was hoping to contact someone to fix the problems with zynga), just closed the survey. ???? I have tried to find a contact us button, but just keep getting redirected to other places. I hope someone can help me with this problem I just refreshed and nothing has changed so far. Thanks Peggy </blockquote>

Question owner

Thanks everyone for your help. I just have one question...when the patch comes...do I have to go back to about.config and change it back to true, or will the patch correct the work around.

Have a great day.. And Thanks again.

Thanks everyone for your help. I just have one question...when the patch comes...do I have to go back to about.config and change it back to true, or will the patch correct the work around. Have a great day.. And Thanks again.
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Hi Peggy, assuming this is fixed in a future version of Firefox, I suspect that setting won't be forced back on automatically.

Hi Peggy, assuming this is fixed in a future version of Firefox, I suspect that setting won't be forced back on automatically.

Question owner

Well here I am again...upgraded to Firefox 41 and can't load zynga.com to play Farmville 2. It takes me to the login page..I sign in and nothing happens. I can load every other web site /page but not that one. I can play farmville 2 on facebook..it's really working better than ever there but I prefer to play on zynga. I have refreshed several times. All the plug-ins are up to date. I took quick time 7 off my computer as it seemed to be causing me an issue after updating it. I am running windows 8.1 I am also getting a lot of bars saying: Firefox prevented this page from automatically redirecting to another page. What is this. Maybe I'll run spybot and check to see if the first fix might work to solve the problem. Any help would be appreciated. Thanks Peggy

Well here I am again...upgraded to Firefox 41 and can't load zynga.com to play Farmville 2. It takes me to the login page..I sign in and nothing happens. I can load every other web site /page but not that one. I can play farmville 2 on facebook..it's really working better than ever there but I prefer to play on zynga. I have refreshed several times. All the plug-ins are up to date. I took quick time 7 off my computer as it seemed to be causing me an issue after updating it. I am running windows 8.1 I am also getting a lot of bars saying: Firefox prevented this page from automatically redirecting to another page. What is this. Maybe I'll run spybot and check to see if the first fix might work to solve the problem. Any help would be appreciated. Thanks Peggy

Question owner

tried the about:config...still set to false. so that isn't it.

tried the about:config...still set to false. so that isn't it.
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

If you search recent Farmville threads, there seem to be some problems. I haven't studied them in detail: https://support.mozilla.org/search/advanced?a=1&q=farmville&sortby=1&w=2

Regarding the redirect block, that setting is on the Advanced panel of the Preferences page:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the General mini-tab, in the Accessibility section, uncheck the box for "Warn me when websites try to redirect or reload the page"

If you search recent Farmville threads, there seem to be some problems. I haven't studied them in detail: https://support.mozilla.org/search/advanced?a=1&q=farmville&sortby=1&w=2 Regarding the redirect block, that setting is on the Advanced panel of the Preferences page: "3-bar" menu button (or Tools menu) > Options > Advanced On the General mini-tab, in the Accessibility section, ''uncheck'' the box for "Warn me when websites try to redirect or reload the page"