Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Pressing backspace and getting blank page.

more options

Not sure what's wrong, but lately when I go to my previous search in Google, by pressing backspace, I get a blank page about half of the time. The web address is right, but it won't display my search. Usually this occurs when I'm in a new tab. Note, this hasn't been an issue in other browsers I have used.

Thanks for your help!

Chosen solution

This could be a problem with the(disk) cache. You can check via the about:cache page if the caches are enabled and working. You can open about: pages via the location/address bar.


Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"
Read this answer in context 👍 0

All Replies (3)

more options

Hello, any luck if you delete the user.js file in your profile folder ?

The user.js file does not exist by default. If you create the file, forget it, if you have not create the file then delete the User.js file, to see if the problem goes away (some programs create and write in the file also).

Check also if you have the same behavior in firefox safe mode.

thank you

more options

Chosen Solution

This could be a problem with the(disk) cache. You can check via the about:cache page if the caches are enabled and working. You can open about: pages via the location/address bar.


Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"
more options

I tried both ideas and it turned out it was the cache. It was hanging at the limit of 349mb.

Thank you all!