X
Tap here to go to the mobile version of the site.

Support Forum

Flash Keeps Crashing Within Firefox

BF1
Posted

Suddenly I am finding that when playing Youtube videos within Firefox I get a message saying the Adobe flash plugin has crashed.

Everything was fine yesterday although I noticed that it is when I am playing lower resolution and poor quality videos on Youtube.

I have the latest version of Firefox on a Mac Retina and have disabled the hardware acceleration but still the problem occurs.

I have also rebooted my Mac several times as well as closed and opened Firefox each time I make a change. I have also uninstalled flash and reinstalled but to no avail.

As I said above this appears to crash when playing older lower quality videos. Newer, higher resolution videos seem OK.

I have tried playing the videos causing the issue in Safari and they play fine. It just seems to be Firefox.

Anyone else experienced this and can provide an answer to resolve?

Thanks for your help.

Suddenly I am finding that when playing Youtube videos within Firefox I get a message saying the Adobe flash plugin has crashed. Everything was fine yesterday although I noticed that it is when I am playing lower resolution and poor quality videos on Youtube. I have the latest version of Firefox on a Mac Retina and have disabled the hardware acceleration but still the problem occurs. I have also rebooted my Mac several times as well as closed and opened Firefox each time I make a change. I have also uninstalled flash and reinstalled but to no avail. As I said above this appears to crash when playing older lower quality videos. Newer, higher resolution videos seem OK. I have tried playing the videos causing the issue in Safari and they play fine. It just seems to be Firefox. Anyone else experienced this and can provide an answer to resolve? Thanks for your help.

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.10
  • A plugin to detect whether the Adobe Creative Cloud is installed on this machine.v_2_0_0_0
  • Provides information about the default web browser
  • Displays Java applet content, or a placeholder if Java is not installed.
  • CIG Download
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0

Application

  • Firefox 36.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:36.0) Gecko/20100101 Firefox/36.0
  • Support URL: https://support.mozilla.org/1/firefox/36.0.1/Darwin/en-GB/

Extensions

  • Bookmark Duplicate Cleaner 0.2 (bookmarkdup@localghost.net)
  • Bookmarks Checker - check for bad links 3.1.1 (firefoxbookmarkchecker@everhelper.me)
  • British English Dictionary 1.19.1 (en-GB@dictionaries.addons.mozilla.org)
  • FavIconReloader 0.8 (FavIconReloader@mozilla.org)
  • Flash Video Downloader - YouTube HD Download [4K] 7.2.0 (artur.dubovoy@gmail.com)
  • iTube Studio 5.3.3.0 ({B51267E0-2F92-11E1-B448-37B64724019B})
  • RoboForm 2.1.1 (rf-firefox-addon@siber.com)
  • Snagit Autoscroll Helper 1.9.6 (autoscrollhelper@techsmith.com)
  • Spell Checker 1.3.2 (gaurangnshah@gmail.com)
  • WOT 20131118 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})
  • YouTube Enhancer Plus 3.3.5 (firefoxaddon@youtubeenhancer.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x6938
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- AMD Radeon R9 M295X OpenGL Engine
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4224 solutions 58947 answers

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

Question owner

Thanks for your reply Fred.

I will look at the links provided later today. I am using a Mac and this is quite new and everything is updated.

The problems don't occur when I use Safari. However, my browser preference is Firefox and I would like it to continue to be.

I disabled hardware acceleration previously but to no avail.

What is puzzling is why it manifests itself with the older lower resolution Youtube videos and why it has suddenly occurred when previously all was OK.

I will update once I have followed the guidelines provided.

Thanks

Thanks for your reply Fred. I will look at the links provided later today. I am using a Mac and this is quite new and everything is updated. The problems don't occur when I use Safari. However, my browser preference is Firefox and I would like it to continue to be. I disabled hardware acceleration previously but to no avail. What is puzzling is why it manifests itself with the older lower resolution Youtube videos and why it has suddenly occurred when previously all was OK. I will update once I have followed the guidelines provided. Thanks

Question owner

I have followed the instructions provided and the problem still exists.

Everything on my Mac is up-to-date including Flash.

I find that I can watch some Youtube videos for a short while and then clicking on another will cause the crash.

It's only happening within Firefox. Very annoying that this has suddenly occurred without any obvious changes to the way I use my Mac or changes to the software within.

I have followed the instructions provided and the problem still exists. Everything on my Mac is up-to-date including Flash. I find that I can watch some Youtube videos for a short while and then clicking on another will cause the crash. It's only happening within Firefox. Very annoying that this has suddenly occurred without any obvious changes to the way I use my Mac or changes to the software within.
FredMcD
  • Top 10 Contributor
4224 solutions 58947 answers

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Question owner

FredMcD said

Many site issues can be caused by corrupt cookies or cache.
  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.
Type about:preferences<Enter> in the address bar.
  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.
If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode; Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration. Poke around safe web sites. Are there any problems? Then restart.

Hi Fred.

Again, thanks for your help. I have followed all suggestions but the problem still exists.

It seems that I can play 2 or 3 videos but when I select the next the crash occurs.

I select them quickly one after another. Now whether the browser doesn't like this I don't know but refreshing the page doesn't always clear the problem instead it will just immediately crash the flash.

This is the sequence of videos that I watched / selected when I noticed the crash:

https://www.youtube.com/watch?v=fyEThSM4JnI https://www.youtube.com/watch?v=5X1VIyZe3Ws https://www.youtube.com/watch?v=Cey35bBWXls

As I loaded these videos in order to get the urls the flash crashed on the 2nd and 3rd videos.

After following your instructions I restarted the browser several times along the process.

By the way, since making the changes Youtube videos are lagging and are out of sync.

Further update. I rebooted my Mac and the problems with lagging/sync/flash crashing still exist.

I played the videos that are lagging in Safari and they are fine. There's something definitely wrong with Firefox unfortunately.

''FredMcD [[#answer-707569|said]]'' <blockquote> Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart. </blockquote> Hi Fred. Again, thanks for your help. I have followed all suggestions but the problem still exists. It seems that I can play 2 or 3 videos but when I select the next the crash occurs. I select them quickly one after another. Now whether the browser doesn't like this I don't know but refreshing the page doesn't always clear the problem instead it will just immediately crash the flash. This is the sequence of videos that I watched / selected when I noticed the crash: https://www.youtube.com/watch?v=fyEThSM4JnI https://www.youtube.com/watch?v=5X1VIyZe3Ws https://www.youtube.com/watch?v=Cey35bBWXls As I loaded these videos in order to get the urls the flash crashed on the 2nd and 3rd videos. After following your instructions I restarted the browser several times along the process. By the way, since making the changes Youtube videos are lagging and are out of sync. Further update. I rebooted my Mac and the problems with lagging/sync/flash crashing still exist. I played the videos that are lagging in Safari and they are fine. There's something definitely wrong with Firefox unfortunately.

Modified by BF1

FredMcD
  • Top 10 Contributor
4224 solutions 58947 answers

How were the pages loaded? Did you open the pages from another window / tab? Did you close the clip window after it had played? Did you watch the full clip / part of it?

Install this, and repeat the above. Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it


Remove History For One Site Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

How were the pages loaded? Did you open the pages from another window / tab? Did you close the clip window after it had played? Did you watch the full clip / part of it? Install this, and repeat the above. '''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it ------------------------- '''[https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site]''' Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any passwords / settings.

Question owner

Since my last post I closed all open tabs within Firefox and uninstalled the browser.

I then reinstalled Firefox and loaded a video to see if the lagging / sync issue had resolved itself - it did'nt.

To answer your questions all pages were loaded one after the other in the same tab. I have only one Firefox window open.

I have installed Flash Block but now cannot see any Youtube videos even after doing the suggested click to enable.

This post suggests that Flash Block may not be compatible with the latest version of Firefox:


Not working in FireFox 36.0.4 Rated 1 out of 5 stars

by rcm on March 22, 2015 · permalink · translate

Dead as a door-nail it does not work in FireFox 36.0.4. I wish these add-on writers would keep up-to-date! Day after day one by one these add-ons are dropping like flies!" They want donations but don't keep-up why donate your money its wasted with each update by FireFox!!!!!!!!


Fred - Is it possible for me to go back to an earlier version of Firefox as it seems these issue have come about since either the latest update or the one previous.

Since my last post I closed all open tabs within Firefox and uninstalled the browser. I then reinstalled Firefox and loaded a video to see if the lagging / sync issue had resolved itself - it did'nt. To answer your questions all pages were loaded one after the other in the same tab. I have only one Firefox window open. I have installed Flash Block but now cannot see any Youtube videos even after doing the suggested click to enable. This post suggests that Flash Block may not be compatible with the latest version of Firefox: Not working in FireFox 36.0.4 Rated 1 out of 5 stars by rcm on March 22, 2015 · permalink · translate Dead as a door-nail it does not work in FireFox 36.0.4. I wish these add-on writers would keep up-to-date! Day after day one by one these add-ons are dropping like flies!" They want donations but don't keep-up why donate your money its wasted with each update by FireFox!!!!!!!! ----------------------------------- Fred - Is it possible for me to go back to an earlier version of Firefox as it seems these issue have come about since either the latest update or the one previous.
user293 39 solutions 279 answers

Youtube offers an alternative player that replaces flash player with newer technologies. As a workaround, I would suggest using that. Go to https://www.youtube.com/html5, and enable the player. It is supposedly still being tested, but I have never found any issues with it.

Youtube offers an alternative player that replaces flash player with newer technologies. As a workaround, I would suggest using that. Go to https://www.youtube.com/html5, and enable the player. It is supposedly still being tested, but I have never found any issues with it.

Question owner

user293 said

Youtube offers an alternative player that replaces flash player with newer technologies. As a workaround, I would suggest using that. Go to https://www.youtube.com/html5, and enable the player. It is supposedly still being tested, but I have never found any issues with it.

Thanks user293. This has resolved the lagging / sync issues and, so far, no crashes.

However, I do have to click twice to watch a video. There is an Play button in the middle of the Youtube screen which I have to click and then I have to click the play button on the bottom menu of the video window.

So although it is a longer process to watch the video the sync issues have been resolved and hopefully so have the crashes.

Ultimately I would like to return as before and utilise Flash without these workarounds as it was operating fine until something has upset the balance.

''user293 [[#answer-708264|said]]'' <blockquote> Youtube offers an alternative player that replaces flash player with newer technologies. As a workaround, I would suggest using that. Go to https://www.youtube.com/html5, and enable the player. It is supposedly still being tested, but I have never found any issues with it. </blockquote> Thanks user293. This has resolved the lagging / sync issues and, so far, no crashes. However, I do have to click twice to watch a video. There is an Play button in the middle of the Youtube screen which I have to click and then I have to click the play button on the bottom menu of the video window. So although it is a longer process to watch the video the sync issues have been resolved and hopefully so have the crashes. Ultimately I would like to return as before and utilise Flash without these workarounds as it was operating fine until something has upset the balance.

Modified by BF1

FredMcD
  • Top 10 Contributor
4224 solutions 58947 answers

FlashBlock can be disabled in the Add-ons Manager. Or by clicking om its icon. It can also be disabled on a per-site bases.

FlashBlock can be disabled in the Add-ons Manager. Or by clicking om its icon. It can also be disabled on a per-site bases.