Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

I do not have a spell check on firefox a 35.0 and can not downlowad a dictionary. I says firefox can not modify file to load

  • 3 replies
  • 1 has this problem
  • 5 views
  • Last reply by cor-el

more options

I do not have a spell check on firefox a 35.0 and can not downlowad a dictionary. I says firefox can not modify file to load

I also have a computer with the XP system on it.

All Replies (3)

more options

Have you blocked xpi files anywhere?

Do you have a lock file in your profile folder? Profiles - Where Firefox stores your bookmarks, passwords and other user data

more options

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

more options

Firefox no longer unpack an XPI file automatically if the unpack directive is absent.

This is necessary for a dictionary to work properly.

You can try to extract the dictionary files yourself manually to the dictionaries folder in the Firefox program folder. The dictionary XPI file is a ZIP archive.

See: