Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

adobe flash player unstable and disabled by Firefox

  • 4 replies
  • 59 have this problem
  • 8991 views
  • Last reply by philipp

more options

Adobe Flash plugin stopped working on YouTube and other news sites. Firefox claims Flashplayer is "unstable" and therefore disabled. It says I need to update, but the update crashes. Things were fine until Firefox screwed things up early this morning. How does one FIX FIREFOX?

Chosen solution

hello aregeejay, you don't have to fix firefox but update your flash plugin. adobe has just released a critical patch for a vulnerability in the plugin, which is reportedly already exploited in the wild. therefore firefox will block insecure versions from running by default on websites for your protection. https://helpx.adobe.com/security/products/flash-player/apsb14-27.html https://addons.mozilla.org/firefox/blocked/p794

please update to Adobe Flash Player version 16.0.0.235 as soon as possible, which you can download from http://www.adobe.com/products/flashplayer/distribution3.html (use the windows-exe for plugin-based browsers).

Read this answer in context 👍 7

All Replies (4)

more options

Chosen Solution

hello aregeejay, you don't have to fix firefox but update your flash plugin. adobe has just released a critical patch for a vulnerability in the plugin, which is reportedly already exploited in the wild. therefore firefox will block insecure versions from running by default on websites for your protection. https://helpx.adobe.com/security/products/flash-player/apsb14-27.html https://addons.mozilla.org/firefox/blocked/p794

please update to Adobe Flash Player version 16.0.0.235 as soon as possible, which you can download from http://www.adobe.com/products/flashplayer/distribution3.html (use the windows-exe for plugin-based browsers).

more options

That worked!! Thanks!!

more options

I was "forced" to update to Firefox 34.0.5 and I have Adobe Flash player 16.0.0.235

All i get is now that flash player crashed constantly! What kind of "upgrade" is this? More like a downgrade to incompatibility, creating artificial problems that did not exist before!

Very annoyed!

more options

@dorcom, please create a separate question about your issue: https://support.mozilla.org/en-US/questions/new