Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More keeps setting a cookie, eventhough disabled in browser

  • 10 replies
  • 7 have this problem
  • Last reply by Jennyfrog

more options

I've never seen this happen before, and I haven't found anything on the net about this either. It only happens with youtube as far as I can see, and only in the last few days, so on Firefox 31.0, nothing else has changed. Basically, I've always blocked cookies. About a month ago I set my privacy settings to enable Third-party cookies "from visited" - normally I just have it on "never". My settings are to "ask me everytime", so I get a lot of cookie requests when browsing and by default I block most of them. I only accept "for session", and thus in my Exception lists I have two types "Allow for session" and "Block". So far, so good, but in the last few weeks, as I've seen a few items as "Allow first party only", I also noticed that set cookies. And I have "" listed as "Block". To make sure, I entered it manually, again, and also "". I also set the third-party cookies back to "never" and deleted everything that was listed as "Allow first party only". But to no avail.

What's weirdest is that while the first time I spotted an "Allow" type entry in my Exceptions list for and deleted it, then refreshed the page, it asked to set a cookie and I blocked it - but never since then. I never get asked anymore. I have block entries in my Exceptions list. And still, after some time, I will find cookies from in my Cookies list. It isn't from every video, it seems to take some time.

I've even disabled temporarily and now need to enable each video specifically before it will play, but to no avail.

I use AdBlock Plus, NoScript, Ghostery and BetterPrivacy, and I do have the Privacy Badger for the last few months but it seems to have no effect. I don't think it's a clash between the add-ons. But I really am confused.

Anyone got any ideas? Does this come through as a Google cookie and therefore circumvent blocking? I block some Google cookies, but allow some for sessions, as I still have a gmail just now.

I know it's not the end of the world, but it's creepy :)


All Replies (10)

more options

Sorry! I ment of course, typo!! :*) I wish posts could be edited.

Modified by Jennyfrog

more options

Has no one had this problem? o_o I just saw that if I follow a youtube link from Facebook, then I get these cookies everytime. But I also saw that Facebook had set a cookie as "Allow" and that's not really possible, as I only ever "Allow for session". There isn't any cookies I ever set to "Allow" full stop.

So it seems Firefox is letting something set cookies without asking for approval, OR cookies are coming through behind others, OR something else which I clearly can't figure out, but I don't like this :/

Any ideas?

more options

You can let all cookies expire when Firefox is closed to make them act as session cookies.

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: Keep until: "I close Firefox"

Create a cookie 'allow' exception for cookies that you would like to keep across sessions.

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions
more options

Hi cor-el, thanks for your reply! Maybe I gave too much detail initially, but the steps you've described are known to me, and I go a lot further than that, but Firefox does NOT do what it is told to do.

Which is: block cookies from Firefox does: allow cookies from, despite haveing entries in the "Exceptions" tab, to block these.

This has only happened to me with Firefox 31.0, and I am really thinking it is a bug in Firefox. However, no one else seems to write about this issue - and I can't see why not. Nothing has changed on my system...

And the fact that cookies from both (should be blocked) and (should be Allow for Session only) appear in my Cookies list as "Allow" means they have somehow got into my browser / system outwith the controls I've asked Firefox to enforce. I.e. block cookies and limit to session only.

Any ideas? Thanks so much!

more options

Today I started Firefox and was suprised to find that it had lost all my stored exceptions - so I had to click to "Block" or "Allow for session" all these cookies from sites I've already visited many times and stored before.

That's very buggy behaviour, too o_o !

But I did add a lot today, and when I went to youtube, I did block the cookie request - and that has not stopped Firefox from letting through cookies from youtube again, several times today. They come in, again, as "Allow First Party Only" which is funny, as everything that comes through kosher, i.e. asks for whether I want the cookie and I then decide, will be either on "Allow for session" or "Block".

So yes. Firefox seems to have a pretty nasty bug here. But I can't understand why no one else has observed this o_o

Nothing's changed on my system. I really don't get it, but am getting really tired of it. If you can't trust Firefox in something like this, what else kind of %"&¤% is it letting through, despite being told not to :(

more options

Exceptions are stored as "Site Preferences", so if you lost the exceptions then you may have cleared the Site Preferences.

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception that you would like to keep.

more options

Hey cor-el,

Thank you, yep that makes perfect sense, I accidentally clicked on the Site Preferences, which is normally always left out. So that's great, that wasn't a bug! Although it means I did try my last resort (resetting it) already inadvertently. I didn't want to because it does take a bit of work with some persistent cookies :D

Anyway, the original problem with youtube is still present. It's INSANE :D I am on youtube just now, and I have an entry in my list "" set to Block, but I also manually added "" as Block yesterday. Well, today that item says Allow. I delete it, and add "" again with Block. Close the dialog box, and open it again, and again, it has the entry for set to Allow. It's like an insane game. I have tried to set it to "Allow" once, in case some weird button fail is going on, but nope, that one stays at Allow. And really, all other manually added exceptions are fine.

Two questions: 1) Is this because I recently installed Thunderbird? Thunderbird also may not accept these cookies, but do two profiles maybe break stuff? I have tighter controls on Thunderbird than on Firefox, and currently I don't run Thunderbird, to try and exclude it as an active error source, but I have done before. The error did start roughly around that time. Except for... I just remembered, I've always ended up with a "" cookie when I use my Gmail, although I have that listed nowhere, and never got asked for it. I just thought it surfed on through but ignored it. I do know Google own Youtube, and I used to get asked to accept an cookie when logging out of Gmail on a new system, but I wasn't this time after accidentally clearing the site preferences.

2) Does temporarily setting the browser to Keep history and in turn, accept all cookies (some sites are coded so %&#¤%& stupidly that you can't get their cookies and therefore can't log in any other way) break the cookie controls in Firefox? It was very temporarily, and nowhere near Youtube. I did get a cookie at the time though, and was nowhere near Google or Google affliated sites, so that was really really weird. Oh and I set everything back to how it was, checked all my Exceptions were still there, etc. Everything was back to normal before I went anywhere near Youtube.

Anyway, hope this wasn't TLDR. :)

Modified by Jennyfrog

more options

Hah, I just saw it change status before my eyes! I went into the "Exceptions list" and ordered it so came to the top, it said Block, and then changed to Allow.

That IS a bug, 100% - can this please be fixed? thanks!

more options

I found this thread while experiencing similar problems.

Maybe this is of some interest:

I suspect the addon PrivacyBadger is the main culprit Not only google and the like were made able to keep reinserting permissions and consequently also cookies in spite of my very very strong efforts to stop that, PB obviously also kept changing "do not tell sites about my tracking prefs" to "tell them i do not want to be tracked" over and over again.

Removing PrivacyBadger seems to solve the issue for me, but I'll be on watch. Will have to get by with Disconnect and Ghostery.

more options

Hey mocr, thank you so much for your reply! Both good to know that I'm not the only one, as it's a bit maddening and very illogical seeming, but of course I'm also sorry you had this problem, and others have or had it, too. Glad you solved it for you, and I removed PrivacyBadger now, I had it disabled for a while, but now it's gone - it did warn me it wouldn't work well with my current (high) settings, so I don't think it ever got going, I like the site it comes from but too many add-ons can conflict, I know.

So let's see if that helps, and I'll watch the thread you linked to, as well, and look into Disconnect. Thanks so much again!