Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

privacy.resistFingerprinting=false not being saved

  • 4 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 104 προβολές
  • Τελευταία απάντηση από webby2019

more options

One of my Windows 10 PCs running Firefox is not remembering my setting privacy.resistFingerprinting=false. After each restart if reverts to privacy.resistFingerprinting=true.

Has anyone experienced and solved this problem previously? Which config file is this setting stored in outside of FF?

Firefox is on latest release (v79) but this has been persistant across previous releases as well. Thanks

One of my Windows 10 PCs running Firefox is not remembering my setting privacy.resistFingerprinting='''false'''. After each restart if reverts to privacy.resistFingerprinting='''true'''. Has anyone experienced and solved this problem previously? Which config file is this setting stored in outside of FF? Firefox is on latest release (v79) but this has been persistant across previous releases as well. Thanks

Επιλεγμένη λύση

OK. I found the problem. I run an extension for Private Internet Access (PIA) and it also has a Fingerprint Protection setting which was overriding the FF setting.

Thanks very much for your help in solving this problem Co-rel :-)

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (4)

more options

You can check if you have a user.js file in the profile folder to initialize prefs# each time Firefox starts.
The user.js file will only be present if you or other software has created this file and normally won't be present.
Note that the user.js status also is listed on the "Help -> Troubleshooting Information" (about:support) page.

You can check its content with a text editor (right-click: "Open with"; do not double-click).
The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

See also:

more options

I've checked and I don't have a user.js file.

What I did though was create a user.js file and set privacy.resistFingerprinting=false within it. What now happens is that I can see that FF starts with privacy.resistFingerprinting=false but almost immediately is reset to true! (I have an about:config tab open at startup to see this change).

What could be resetting this on startup?

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Επιλεγμένη λύση

OK. I found the problem. I run an extension for Private Internet Access (PIA) and it also has a Fingerprint Protection setting which was overriding the FF setting.

Thanks very much for your help in solving this problem Co-rel :-)