Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox 43.0 slow at contacting websites

  • 1 απάντηση
  • 2 έχουν αυτό το πρόβλημα
  • 22 προβολές
  • Τελευταία απάντηση από guigs

more options

Hi everybody,

I am having a little problem with Firefox on my Ubuntu, and I was wondering if someone could help me. The problem is that my Firefox started to act very slow after the v43.0 update. I am using Ubuntu 14.04 LTS 64bit.

Every page that I try to open takes about 5-30 seconds to load, and sometimes it doesn't load at all (displays that connection was restarted, or blank tab). I tought it was problem with my OS, so I started up Windows Vista in virtualbox with Firefox v42 (it wasn't updated yet), and went to compare it. And really the Firefox 42 on my Vista in Virtualbox was A LOT faster when opening pages (almost instantly) than Firefox 43.0 on my host OS - Ubuntu.

Then I updated the Firefox on Vista virtualbox from 42 to the version 43.0.2., and it was OK, the speed was the same as before. So no problems on the Virtualbox with the 43. But on host OS, my Ubuntu 14.04, Firefox 43.0 is very slow when loading any page. I read something about nvidia network manager on Firefox reddit, but I am not sure if I do have that program on my Ubuntu. I have laptop with optimus technology and I am using only Intel GPU, so Nvidia should not be the problem, right?

I also checked for updates, to see is there Firefox v43.0.2. for Linux also, but no new updates were found. I am huge fan of Firefox, but this is annoying, browsing the web is simply imoposible. It's even worse when you know that everything it's working fine on Virtualbox, but not on host OS. I tried opening my test pages on Ubuntu browser (based on Chromium) and it worked ok, the load speed was almost the same as on virtualbox. So that leads me to the conclusion - is it something wrong with Ubuntu or Firefox, and can it be fixed?

Note: The problem is that Firefox is slow to "contact" the site. It's like it is testing does website even exists, or does the connection works or something like that. So the problem is in contacting the page, beacuse sometimes it showes nothing, just blank tab, or error message: "Connection was restarted".

I would really be greaful for any help. Thanks!

All Replies (1)

more options

I understand that the page to load time is slow in a virtual machine and on the main host OS. To conclude if its the network you can try another device on the same network or another browser.

To troubleshoot load times in Firefox you can test these to see if there is a difference: