Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Stuck on Never Remember History

  • 1 ŋuɖoɖo
  • 2 masɔmasɔ sia le wosi
  • 3 views
  • Nuɖoɖo mlɔetɔ cor-el

more options

Everytime I try and change "Never Remember History" to "Remember History" I get the message "Firefox must restart to disable this feature". I click OK, however, when Firefox restarts it is still on the Never Remember History setting. The same thing happens if I go to "Custom Settings for History" and try and untick the Always Use Private Browsing mode - when Firefox restarts it is still in Never Remember History setting.

This has been an ongoing problem for a couple of months, even before the recent update. I have tried resetting firefox but no luck.

Please can you advise how I can set Remember History as the default setting.

Many thanks oleary87

All Replies (1)

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

If you do not keep changes after a restart then see: