Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Recaptcha Not Working in Firefox Specifically.

  • 30 Antworten
  • 77 haben dieses Problem
  • 1 Aufruf
  • Letzte Antwort von cor-el

more options

Recaptcha isn't working in Firefox. It works in Chrome, Opera, and Edge with no issues, it will either just go to a check mark or open the window with the pictures to choose, on both regular pages and on the Google Recaptcha Demo site Google Recaptcha Demo site. But when I load a page that requires Recaptcha in Firefox, it just spins forever. It was working fine a few hours ago, and I didn't change any settings or anything in Firefox. I was filling out a job application and it worked fine, then I went to another job application and Recaptcha won't work at all, even on the Recaptcha Demo site.

I'm on version 125.0.3 (64-bit), on Windows 10. Not using a VPN or anything like that, just a standard Ethernet connection, with whatever Charter gives me.

Steps I've tried, none of which have helped:

1. Cleared Cookies. 2. Restart Browser. 3. Restart Computer. 4. Restart Modem and Router. 5. Opening Firefox in troubleshooting mode. 6. Ensured Firefox was up to date. 7. Reinstalling Firefox. 8. Turned Connection Settings to no proxy. 9. Turned off Enhanced Tracking Protection. (It's set on standard otherwise, and I didn't change it) 10. Release/Renew IP via Command Prompt.

I'm genuinely at a loss of what to do, after a couple of hours of searching around for solutions. I don't get how it just stopped working in the span of like ten minutes when I didn't change any settings or anything. Firefox is my main browser and it would be a tremendous pain to have to use another browser for any pages that require Recaptcha.

Any assistance or advice to solve this problem would be greatly appreciated!

Recaptcha isn't working in Firefox. It works in Chrome, Opera, and Edge with no issues, it will either just go to a check mark or open the window with the pictures to choose, on both regular pages and on the [https://google.com/recaptcha/api2/demo Google Recaptcha Demo site] Google Recaptcha Demo site. But when I load a page that requires Recaptcha in Firefox, it just spins forever. It was working fine a few hours ago, and I didn't change any settings or anything in Firefox. I was filling out a job application and it worked fine, then I went to another job application and Recaptcha won't work at all, even on the Recaptcha Demo site. I'm on version 125.0.3 (64-bit), on Windows 10. Not using a VPN or anything like that, just a standard Ethernet connection, with whatever Charter gives me. Steps I've tried, none of which have helped: 1. Cleared Cookies. 2. Restart Browser. 3. Restart Computer. 4. Restart Modem and Router. 5. Opening Firefox in troubleshooting mode. 6. Ensured Firefox was up to date. 7. Reinstalling Firefox. 8. Turned Connection Settings to no proxy. 9. Turned off Enhanced Tracking Protection. (It's set on standard otherwise, and I didn't change it) 10. Release/Renew IP via Command Prompt. I'm genuinely at a loss of what to do, after a couple of hours of searching around for solutions. I don't get how it just stopped working in the span of like ten minutes when I didn't change any settings or anything. Firefox is my main browser and it would be a tremendous pain to have to use another browser for any pages that require Recaptcha. Any assistance or advice to solve this problem would be greatly appreciated!

Ausgewählte Lösung

From this closed bug it looks that Google has fixed this issue, so you can test this by disabling the extension.

Diese Antwort im Kontext lesen 👍 3

Alle Antworten (20)

more options

Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection".

Does it still happen with default settings in a new browser profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

Hilfreich?

more options

What about all the users who use firefox with default security settings? It turns out that captcha does not work by default for everyone starting from the new version? I'm interested as a website developer

Hilfreich?

more options

The page at https://google.com/recaptcha/api2/demo tortured me with grainy images for over a minute in Firefox and Edge but finished in less than 10 seconds in Chrome.

I'm in California, in case that matters. The Network Monitor (Ctrl+Shift+E) shows that the page is using

https://www.gstatic. com/recaptcha/releases/V6_85qpc2Xf2sbe3xTnRte7m/recaptcha__en.js

(the list appears after a reload).

Hilfreich?

more options

I have the same exact problem. Since yesterday, when I click on the recaptcha, it just keeps circling. The page just works fine with other browsers. Tried everything (including cleaning the registry keys, preferences, tracking, etc.,) and frustrated that I had to spend hours to fix this and still not working. I don't understand why the developers change things and give problems for users like me. After using firefox for over a decade, I am ready to ditch and never use this software again.

Hilfreich?

more options

I have the same exact issue-just started happening yesterday! looks like it's widespread problem. Is mozilla going to address this??

Hilfreich?

more options

zeroknight said

Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection". Does it still happen with default settings in a new browser profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

Tried both "Off" and "Max Protection" didn't work, and tried with both a new profile, and a bare, fresh install of Firefox to no avail.

Based on this Reddit thread and other comments left on this page, I think this a somewhat widespread issue with Firefox specifically and not something on my end.

Hilfreich?

more options

I can replicate the problem on these pages (without filling the form, just clicking the checkbox):

Contrary to some speculation, disabling Tracking Protection does not resolve the script error that seems to be occurring when checking the box.

I can't explain why some users are able to work around this with a VPN, unless it indicates a delay in propagation of script changes across the CDN used for reCAPTCHA. When checking for scripts in the disk cache (about:cache), I found three versions. If I load them in a tab and check Page Info (Ctrl+i) they have these dates/times in Pacific time:

https://www.gstatic .com/recaptcha/releases/WQcDpAcHn0sjM6ZiVkU8JwNH/recaptcha__en.js - Modified: Sunday, April 28, 2024, 9:01:38 PM https://www.gstatic .com/recaptcha/releases/V6_85qpc2Xf2sbe3xTnRte7m/recaptcha__en.js - Modified: Monday, April 22, 2024, 2:03:35 PM https://www.gstatic .com/recaptcha/releases/QoukH5jSO3sKFzVEA7Vc8VgC/recaptcha__en.js - Modified: Sunday, April 14, 2024, 7:01:04 PM

The problem may be in that latest script update, or a coincidence of updates by Google and Mozilla causing a new incompatibility.

I also notice that the script sends Google the script error message, so assuming someone is watching, they must be aware of this by now with all our testing:

https://www.google .com/recaptcha/api2/jserrorlogging?script=https%3A%2F%2Fwww.gstatic .com%2Frecaptcha%2Freleases%2FWQcDpAcHn0sjM6ZiVkU8JwNH%2Frecaptcha__en.js&error=oB%20is%20not%20a%20function&line=461

Hilfreich?

more options

Edit: An add-on may be easier, for example:


A comment in Bugzilla by Alice0775 White indicates that this problem does NOT occur if you have Firefox report to websites that it is Chrome rather than Firefox. You can do this by creating a preference in about:config, or there may be an add-on to do it more surgically (i.e., only lie to the relevant servers). This makes it sound more like a script error on Google's part.

If this is something anyone wants to test, here's how you do it. Unfortunately, this could break your experience on sites that have browser-specific code that actually would be to your benefit.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste general.useragent.override and pause while the list is filtered

Normally, Firefox will display a bar with Boolean Number String and a + button. In that case, proceed to Step 3. If instead you see that there is already a saved preference with this name, double-click it to open an editing area and skip to Step 4.

(3) Click String, then click the + button to create the new preference.

(4) Paste the following Chrome 124 user agent string into the editing area, then press Enter/Return or click the blue check mark button to save the change:

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/124.0.0.0 Safari/537.36

Edit: Or you can inject AppleWebKit into a normal Firefox user agent string:

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:125.0) AppleWebKit Gecko/20100101 Firefox/125.0

I don't know whether that would break fewer sites than masquerading 100% as Chrome.

Geändert am von jscher2000 - Support Volunteer

Hilfreich?

more options

A Chrome user agent can cause other breakage though, preferably there would be a Firefox user agent string that is unaffected.

Hilfreich?

more options

Temporary fix but great work around for now- download the following extension: User-Agent Switcher by Erin Schlarb Set the default to windows/chrome 123 Recaptcha all work normally now. Looks like firefox is getting blocked somehow.

Hilfreich?

more options

Same issue works with Google but I had some suspicious intrusion with Google Chrome. Not working with Firefox since today.

Hilfreich?

more options

The bug reference and discussion in Bugzilla is https://bugzilla.mozilla.org/show_bug.cgi?id=1894590. As workaround, for those familiar with about:config who don't want to download an extension just to fake the user agent info, there's a suggestion to add a preference named general.useragent.override with value "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/124.0.0.0 Safari/537.36" (which is latest Google Chrome agent info). I've confirmed this as a working workaround for me, which will basically make your Firefox identify as Google Chrome while visiting websites.

Hilfreich?

more options

Hi MRotta, your post is currently in the link spam moderation queue for review. I don't know why links to Bugzilla are considered potential link spam. ?? Hopefully a moderator will release it soon.

Hilfreich?

more options

reCAPTCHA works for me on Linux with the current release with all websites posted in various threads about this issue including Google recaptcha/api2/demo. It also works with a MAC user agent, so only a Windows Firefox user agent seems to be affected.

  • Mozilla/5.0 (X11; Linux x86_64; rv:125.0) Gecko/20100101 Firefox/125.0
  • Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:125.0) Gecko/20100101 Firefox/125.0

Hilfreich?

more options

Downgrading to 123.0 did not work. The user agent extension did work. This is another Mozilla mess.

Hilfreich?

more options

Workaround Until this is Fixed. By the way, this is a Google issue not really a Firefox issue.

1. In the address bar, type: about:config 2. Search for: general.useragent.override 3. Select "String" and then the + button 4. Copy and Paste this into the field: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:125.0) AppleWebKit Gecko/20100101 Firefox/125.0 5. Click the Checkmark Blue button. You're done. 6. Now Bookmark this setting so you can delete it when this issue is fixed. Don't forget

Hilfreich?

more options

It ONLY affects Firefox. That makes it a Mozilla issue, by definition.

Hilfreich?

more options

Федор said

What about all the users who use firefox with default security settings? It turns out that captcha does not work by default for everyone starting from the new version? I'm interested as a website developer

It does work fine for Firefox users on Linux and macOS. It appears only Windows users with Firefox useragents showing as Windows appears to be affected. This is something Google needs to fix.

Hilfreich?

more options

sjduskin said

It ONLY affects Firefox. That makes it a Mozilla issue, by definition.

This is a issue Google needs to fix. Firefox users with Linux and macOS useragents appear to not be affected, however it impacts Firefox users with Windows uersagents for some reason.

Just because it appears to affect Firefox users does not automatically mean it is a bug in Firefox or a issue that Mozilla needs to fix.

Hilfreich?

more options

sjduskin, you're incorrect. reCAPTCHA is owned by Google. Google owns & dominates everything. And when Google breaks something, they convince everyone to rush in here & start blaming Mozilla.

You even proved we weren't responsible when you downgraded Firefox from version 125 to 123 and STILL saw the problem. We can't break recaptchas in a version released back in February.

To reinforce the point James made above: We don't control Google's code, software or services. And I guarantee you this won't be the first or the last time Google breaks something in Firefox. Google has been breaking Youtube for Firefox users in various ways for 10+ years. Even just recently NordVPN has broken auto updates in Firefox. So Firefox users are constantly under attack from 3rd party software & services outside of Mozilla's control. Just breaking stuff for us randomly but not Chrome or Edge, Vivaldi, Opera & Brave because they're all browsers based on Chrome. So buckle up, because this kind of stuff always happens, it's just the company's name who is responsible that changes.

This is unfortunately the consequences of letting a company become so big & powerful that it owns all major services needed to have a smooth & pain free internet experience.

TL;DR - What we know:

  • Google's Recaptcha spins endlessly for Windows Firefox users because of a broken script Google owns
  • Mac & Linux Firefox users seem to be unaffected by this (Thank god! Firefox catches a small break)
  • Changing the Firefox useragent to look like you're using a Mac or Linux version of Firefox, Safari or any Chrome browser (Edge, Opera, Vivaldi, Opera) seems to fix the broken recaptchas
  • Useragent workaround can be found here: https://support.mozilla.org/en-US/questions/1446332#answer-1650870
  • Or by installing one of these addons: User-Agent Switcher or UA Switcher, to change the useragent with only a few clicks.

I hope Google fixes this ASAP.

Hilfreich?

  1. 1
  2. 2
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.