X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Which security settings cause my add-on extensions to disappear?

Veröffentlicht

I have installed these add-ons. Ad blocker, password manager, and privacy browser.

After changing the settings in Firefox, my ad blocker and password manager disappeared from the menu bar. I see the add-ons in the extension list. Uninstalling, re-instaling the extensions do not bring the extension icons back. I tried to do a "re-install" using the Firefox "re-install" button, but my extensions did not show up again.

I had to completely uninstall Firefox (which does not remove Firefox settings from the computer ---- WHY?!) delete the registry entry, re-install Firefox and re-instsall the add-on extension to get them to show up again.

But when I go back into settings, make changes, the add-on extensions disappear again.

Which settings cause this?

I have installed these add-ons. Ad blocker, password manager, and privacy browser. After changing the settings in Firefox, my ad blocker and password manager disappeared from the menu bar. I see the add-ons in the extension list. Uninstalling, re-instaling the extensions do not bring the extension icons back. I tried to do a "re-install" using the Firefox "re-install" button, but my extensions did not show up again. I had to completely uninstall Firefox (which does not remove Firefox settings from the computer ---- WHY?!) delete the registry entry, re-install Firefox and re-instsall the add-on extension to get them to show up again. But when I go back into settings, make changes, the add-on extensions disappear again. Which settings cause this?
Zitieren

Mehr Details zum System

Installierte Plugins

ad blocker, lastpass, search engine

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Weitere Informationen

Hilfreiche Antwort

Ok. I think I have discovered the problem.

Under Privacy & Security: When selecting: "Never remember history" my extensions disappeared.

When I selected "Remember all History" my extensions re-appeared.

Should Firefox work this way? I don't want any browser to remember my history browing history.

Ok. I think I have discovered the problem. Under Privacy & Security: When selecting: "Never remember history" my extensions disappeared. When I selected "Remember all History" my extensions re-appeared. Should Firefox work this way? I don't want any browser to remember my history browing history.
Hat Ihnen das weitergeholfen? 1
Zitieren
jscher2000
  • Top 10 Contributor
8783 Lösungen 71825 Antworten
Veröffentlicht

"Never remember history" triggers automatic private browsing mode.

Are your extensions enabled for private windows? You can check on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then on the right side, if an extension does not have a white-on-purple "mask" icon next to the title, click the title and use the setting section of the page to change "Run in Private Windows" to "Allow". Use the Back button to return to the list and repeat as needed.

Does that fix it?

"Never remember history" triggers automatic private browsing mode. Are your extensions enabled for private windows? You can check on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then on the right side, if an extension does not have a white-on-purple "mask" icon next to the title, click the title and use the setting section of the page to change "Run in Private Windows" to "Allow". Use the Back button to return to the list and repeat as needed. Does that fix it?
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.