Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How to add custom search engine?

  • 13 Antworten
  • 6 haben dieses Problem
  • 9370 Aufrufe
  • Letzte Antwort von erotavlas

more options

Hi, Firefox is great browser especially for those that care about freedom and privacy. I would like to know why it is not possible to specify custom search engine as you were able to do in the past version of Firefox. I would like to use google search engine together with https://search.disconnect.me/ that offers the possibility of anonymous searches. I know that exists a plug-in https://disconnect.me/search, but is not very comfortable with respect to standard search bar. Thank you

I read the proposed solution here https://support.mozilla.org/en-US/kb/use-search-bar-firefox-and-manage-search-engines#w_add-a-search-engine but in Firefox 36 does not work

Ausgewählte Lösung

That TypeError message probably explains why you couldn't add the search engine from the Mycroft page originally.

When I search that exact error in Google, only this turned up, from July 2013:

As long as the "Unity Desktop Integration 2.4.6" plugin is enabled I could not add search providers to Firefox. https://bugs.launchpad.net/ubuntu/+source/unity-firefox-extension/+bug/1202383

Note: that add-on is not a Plugin, it is an Extension, and can found on the Add-ons page with other extensions.

Diese Antwort im Kontext lesen 👍 2

Alle Antworten (13)

more options

hello, you could try the open search plugins from: http://mycroftproject.com/search-engines.html?name=disconnect

more options

philipp said

hello, you could try the open search plugins from: http://mycroftproject.com/search-engines.html?name=disconnect

I tried but it does not work.

more options

Maybe use the built-in DuckDuckGo search engine because both use Google and both offer anonymous searching.

more options

Startpage.com uses Google data. There is an "Add to Firefox" link below the search box to install their search plugin.

https://startpage.com/

more options

cor-el said

Maybe use the built-in DuckDuckGo search engine because both use Google and both offer anonymous searching.

Does DuckDuckGo use Google? This is not true https://en.wikipedia.org/wiki/DuckDuckGo So there is no possibility to add custom search engine?

more options

I have been able to add search engines from the Mycroftproject site.

Search engine plugins also can be hand-edited if you know the destination URL of the result page.

more options

jscher2000 said

I have been able to add search engines from the Mycroftproject site. Search engine plugins also can be hand-edited if you know the destination URL of the result page.

Yes, I tried but it says "your browser does not support OpenSearch plugin". I'm using Firefox 36.0.4 on Ubuntu 64 bit.

more options

erotavlas said

Yes, I tried but it says "your browser does not support OpenSearch plugin". I'm using Firefox 36.0.4 on Ubuntu 64 bit.

There's no reason for search plugins not to work on your Firefox. I can't understand why you get that message. I have to log off now, but there is a way to extract the parameters from the page and build links directly to the files (examples in this post: https://support.mozilla.org/questions/1049643#answer-697498).

more options

Following up on my last suggestion, you could try this:

(1) Select and copy the script starting with "window" (it's one long line; ignore the fact that the forum has created a link in there):

Disconnect Private Search en-WW (search.disconnect.me) by Disconnect, Inc.:

window.external.AddSearchProvider("http://mycroftproject.com/installos.php/65076/disconnect-search.xml");

(2) On the search plugin list page (http://mycroftproject.com/search-engines.html?name=disconnect), open the web console by pressing Ctrl+Shift+k (or select Web Console from the Developer menu). A new section should open at the bottom of the tab.

(3) Click in the blank line at the bottom, just to the right of the caret (>>). Paste the script and press Enter to run it. Firefox should display a confirmation pop-up dialog.

(4) If you want the new plugin to be your default search engine, check the box for that.

(5) Click Add. The search engine should appear at the end of the list.

Any luck?

When I test that, the search defaults to Google. Not sure whether that is automatic or just sticks with the last one you used.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

jscher2000 said

Following up on my last suggestion, you could try this: (1) Select and copy the script starting with "window" (it's one long line; ignore the fact that the forum has created a link in there): Disconnect Private Search en-WW (search.disconnect.me) by Disconnect, Inc.: window.external.AddSearchProvider("http://mycroftproject.com/installos.php/65076/disconnect-search.xml"); (2) On the search plugin list page (http://mycroftproject.com/search-engines.html?name=disconnect), open the web console by pressing Ctrl+Shift+k (or select Web Console from the Developer menu). A new section should open at the bottom of the tab. (3) Click in the blank line at the bottom, just to the right of the caret (>>). Paste the script and press Enter to run it. Firefox should display a confirmation pop-up dialog. (4) If you want the new plugin to be your default search engine, check the box for that. (5) Click Add. The search engine should appear at the end of the list. Any luck? When I test that, the search defaults to Google. Not sure whether that is automatic or just sticks with the last one you used.

Hi, thank you for your detailed answer, but I still have problem. I followed your instruction and I pasted the line inside the console. I get this message TypeError: window.external.AddSearchProvider is not a function I think at this point, it is better to type search.disconnect.me. Thank

more options

Ausgewählte Lösung

That TypeError message probably explains why you couldn't add the search engine from the Mycroft page originally.

When I search that exact error in Google, only this turned up, from July 2013:

As long as the "Unity Desktop Integration 2.4.6" plugin is enabled I could not add search providers to Firefox. https://bugs.launchpad.net/ubuntu/+source/unity-firefox-extension/+bug/1202383

Note: that add-on is not a Plugin, it is an Extension, and can found on the Add-ons page with other extensions.

more options

jscher2000 said

That TypeError message probably explains why you couldn't add the search engine from the Mycroft page originally. When I search that exact error in Google, only this turned up, from July 2013: As long as the "Unity Desktop Integration 2.4.6" plugin is enabled I could not add search providers to Firefox. https://bugs.launchpad.net/ubuntu/+source/unity-firefox-extension/+bug/1202383 Note: that add-on is not a Plugin, it is an Extension, and can found on the Add-ons page with other extensions.

Yes this is the source of the problem. I forgot to disable these plugins related to unity integration since I do not use unity. Now, every solutions that you reported before works well. Thank you very much.