Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

CANNOT upd to latest Flash,Java,etc on WinXP; want to set XP versions to "Always Activate" vs constant "Ask To Activat" nags! (=Q1035710)

  • 4 Antworten
  • 3 haben dieses Problem
  • 2 Aufrufe
  • Letzte Antwort von James

more options

When running Firefox on Windows XP, it is NOT POSSIBLE to update to the latest ("safe") versions of Flash, Java, etc...they no longer support XP. So the latest XP compatible plugins are marked "...vulnerable and should be updated". And in this case, the activation dropdown only allows options "Ask To Activate" and "Never Activate" but NOT "Always Activate". As a result, there's a constant nag on every webpage using any of these plugins. It would really be much more user friendly (read "much less annoying") if there were an "Always Activate even tho I KNOW IT IS OUT OF DATE" option. This problem obviously applies whenever the "latest" add-on cannot be installed on the running OS, not just Windows XP, and not just any specific version of Firefox. See Mozilla Support question 1035710 ("I want to set the Java Plugin to Always Activate in Firefox for Ubuntu...") where it's the same problem with Ubuntu vs Java. An acceptable compromise would be the ability to manually set "Always Activate" via about:config...this capability may be there already but I haven't found any documentation to that effect.

Geändert am von lbruns

Alle Antworten (4)

more options

hello, flash and java 7 still support windows xp, so please just download their latest security updates and you should be fine anyway:

https://www.adobe.com/products/flashplayer/distribution3.html https://www.java.com/en/download/manual_java7.jsp

more options

Thanks for your prompt reply...found and installed the updates OK!

Previously, my experience with flash as supplied at http://get.adobe.com/flashplayer/ had been unsuccessful...the download (w/o extras) from there (install_flashplayer16x32_mssd_aaa_aih.exe) has failed to install (just hangs) if and only if I was installing v16 on Windows XP ever since v16 appeared...hence my assumptions about XP compatibility. The v16 .exe & .msi files your links pointed to, however, installed properly, both the "active-X" and "plugin" versions...I had been unable to locate direct pointers to them. Ditto the JRE-7u71, again had looked but couldn't find the proper link.

That said, these are patches to the symptoms but they do not fix the problem. There will inevitably be a situation where the latest version of whatever plugin is not compatible with the host OS (again, support question 1035710). So some other workaround to the constant "Ask To Activate" nagging must be available!

Geändert am von lbruns

more options

there would be a workaround, but it's not a good one as long there are still updates available...

http://kb.mozillazine.org/Extensions.blocklist.enabled

more options

If you cannot use Flash 16.0 then try the Flash 13.0 ESR version as 13.0.0.259 is safe and not on blocklist like 13.0.0.258 and earlier is.

The Extended Support Release Flash 13.0.0.259 is near bottom of page. https://www.adobe.com/products/flashplayer/distribution3.html

https://addons.mozilla.org/en-us/firefox/blocked/p794 https://addons.mozilla.org/en-us/firefox/blocked/p798

Geändert am von James