Fehlerbehebung bei Erweiterungen, Themes und Hardware-Beschleunigung

Einige Probleme, die Nutzer bei der Verwendung von Firefox feststellen, können durch Erweiterungen oder Themes hervorgerufen werden. Dieser Artikel beschreibt, wie Sie herausfinden können, welche Erweiterung oder welches Theme daran schuld ist und wie Sie Firefox wieder dazu bringen, normal zu funktionieren.

Hinweis: Das Zurücksetzen von Firefox in seinen Ausgangszustand kann viele Probleme beheben, wobei Sie wichtige Daten vorher sichern können. Ziehen Sie diese Art der Problembehebung in Erwägung, bevor Sie eine langwierige Suche nach der Ursache und der Lösung Ihres Problems beginnen.

Firefox im Abgesicherten Modus starten

Wenn Sie im Abgesicherten Modus von Firefox starten, werden alle Erweiterungen vorübergehend deaktiviert, die Hardwarebeschleunigung abgeschaltet und das Standard-Theme verwendet. Wenn Sie im Abgesicherten Modus von Firefox starten, werden alle Erweiterungen vorübergehend deaktiviert und das Standard-Theme verwendet. Das hilft Ihnen dabei herauszufinden, ob eine Erweiterung oder ein Theme Ihr Problem verursacht.

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Mit deaktivierten Add-ons neu starten.... Firefox wird neu starten und das Dialogfenster für den Abgesicherten Modus zeigen.

    Abgesicherter Modus - WinXP - Fx23 Abgesicherter Modus - Win7 - Fx23 AbgesicherterModus_Fx4_linux AbgesicherterModus_Fx4_mac

    Hinweis: Sie können Firefox ebenso im Abgesicherten Modus starten, wenn Sie die Umschalttaste gedrückt halten, während Sie Firefox starten.

    Umschalt-Taste + Doppelklick - Win7 - Fx23
    die Wahltaste mac-wahltaste gedrückt halten, während Sie Firefox starten.
    Firefox beenden, das Terminal aufrufen und folgendes ausführen: firefox -safe-mode
    Eventuell müssen Sie das Installationsverzeichnis von Firefox angeben (z.B. /usr/lib/firefox-4 -safe-mode).
    So öffnen Sie das Terminal (das auch Shell oder Konsole genannt wird):
    • (Unity wie bei Ubuntu) Öffnen Sie den Schnellstart (Dash-Startseite). Klicken Sie dazu entweder auf das Ubuntu-Symbol im Unity-Startmenü oder betätigen Sie einfach die Taste Windows/Super. Tippen Sie das Wort „terminal“ ein und klicken Sie dann auf das erscheinende Symbol mit dem schwarzen Bildschirm darunter.
    • (GNOME wie bei Fedora, Linux Mint) Öffnen Sie das Menü Anwendungen, wählen Sie Zubehör und dann Terminal.
    • (KDE wie bei Kubuntu, openSUSE, Knoppix) Öffnen Sie den Anwendungen-Starter links unten am Bildschirmrand. Geben Sie im Feld Suchen den Befehl Terminal ein und drücken Sie danach die Eingabetaste.
    Klicken Sie in der Titelleiste auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Mit deaktivierten Add-ons neu starten. Firefox startet dann neu im Abgesicherten Modus.
    Hinweis: Sie können Firefox auch im Abgesicherten Modus starten, indem Sie Firefox zuvor beenden und die Umschalttaste die Wahltaste mac-wahltaste gedrückt halten, während Sie Firefox starten.
    Sie können Firefox ebenso im Abgesicherten Modus starten, wenn Sie Firefox beenden, das Terminal aufrufen und folgendes ausführen: firefox -safe-mode
    Eventuell müssen Sie das Installationsverzeichnis von Firefox angeben (z. B. /usr/lib/firefox).
    So öffnen Sie das Terminal (das auch Shell oder Konsole genannt wird):
    • (Unity wie bei Ubuntu) Öffnen Sie den Schnellstart (Dash-Startseite). Klicken Sie dazu entweder auf das Ubuntu-Symbol im Unity-Startmenü oder betätigen Sie einfach die Taste Windows/Super. Tippen Sie das Wort „terminal“ ein und klicken Sie dann auf das erscheinende Symbol mit dem schwarzen Bildschirm darunter.
    • (GNOME wie bei Fedora, Linux Mint) Öffnen Sie das Menü Anwendungen, wählen Sie Zubehör und dann Terminal.
    • (KDE wie bei Kubuntu, openSUSE, Knoppix) Öffnen Sie den Anwendungen-Starter links unten am Bildschirmrand. Geben Sie im Feld Suchen den Befehl Terminal ein und drücken Sie danach die Eingabetaste.
  2. Wenn das Dialog-Fenster „Abgesicherter Modus“ erscheint, klicken Sie auf die Schaltfläche Im abgesicherten Modus weiterarbeitenIm abgesicherten Modus starten.

Überprüfen Sie, ob Ihr Problem weiterhin besteht, nachdem Firefox im Abgesicherten Modus gestartet wurde.

Das Problem tritt auch im Abgesicherten Modus auf

Wenn das Problem auch im Abgesicherten Modus auftritt, wird es nicht durch eine Erweiterung, ein Theme oder die Hardwarebeschleunigung hervorgerufen.Wenn das Problem auch im Abgesicherten Modus auftritt, wird es nicht durch eine Erweiterung oder ein Theme hervorgerufen. Es könnte ein Plugin oder eine Änderung in den Firefox-Einstellungen verantwortlich sein, da diese im Abgesicherten Modus nicht deaktiviert werden.

Das Problem tritt im Abgesicherten Modus nicht auf

Wenn das Problem im Abgesicherten Modus nicht auftritt, wird es höchstwahrscheinlich durch eine Erweiterung, ein Theme oder die Hardwarebeschleunigung hervorgerufen.Wenn das Problem im Abgesicherten Modus nicht auftritt, wird es höchstwahrscheinlich durch eine Erweiterung oder ein Theme hervorgerufen. Fahren Sie mit den unten aufgeführten Schritten in diesem Artikel fort um festzustellen, was Ihr Problem verursacht.

Hardwarebeschleunigung abschalten

Bei manchen Grafikkarten und manchen Einstellungen kommt es vor, dass die Benutzung der Hardwarebeschleunigung dazu führt, dass Firefox abstürzt oder Text und Objekte mancher Webseiten fehlerhaft angezeigt werden. Sie können versuchen, die Hardwarebeschleunigung abzuschalten um festzustellen, ob dies Ihr Problem behebt:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie Einstellungen.Klicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie Einstellungen.Klicken Sie in der Menüleiste auf das das Menü Firefox und wählen Sie Einstellungen....Klicken Sie oben im Firefox-Fenster auf das Menü Bearbeiten (oder auf die Schaltfläche Firefox, wenn die Menüleiste ausgeblendet ist) und wählen Sie Einstellungen....

    Einstellungen - Fx20 - Win7


    EinstellungenFx4Win7.png


    Einstellungen - Fx20 - WinXP


    Einstellungen_Fx4_Linux


    010897fd58f6e294a60e43bbcf0ffe51-1281982768-69-1.png

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Einstellungen.

  2. Wählen Sie im Panel den Eintrag Erweitert und dann den Reiter Allgemein.
  3. Entfernen Sie den Haken am Eintrag Hardware-Beschleunigung verwenden, wenn verfügbar.

    HardwarebeschleunigungDeaktivieren_Fx4_Win



    HardwarebeschleunigungDeaktivieren_Fx4_Mac



    HardwarebeschleunigungDeaktivieren_Fx4_Linux

  4. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  5. Starten Sie Firefox wie gewohnt.

Wenn das Problem nicht mehr besteht, wurde es vermutlich durch die Hardwarebeschleunigung verursacht. Sie können versuchen, ein Update für Ihren Grafik-Treiber durchzuführen. Wenn das Problem dadurch nicht behoben wird, lassen Sie die Hardwarebeschleunigung deaktiviert. Andernfalls wird Ihr Problem vermutlich durch Erweiterungen oder Themes verursacht. Fahren Sie mit den unten aufgeführten Schritten in diesem Artikel fort um festzustellen, ob eine Erweiterung oder ein Theme Ihr Problem verursacht.

Zum Standard-Theme wechseln

Wenn Sie ein anderes Theme als das Standard-Theme von Firefox verwenden:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche FirefoxKlicken Sie in der Menüleiste auf ExtrasKlicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie dann Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    FehlerbehebungPluginsWinXP_01 FehlerbehebungPluginsWin_01 FehlerbehebungPluginsMac_01 Fehlerbehebung Plugins Linux 01
    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    Windows: Australis - Add-ons öffnen Linux: Australis - Add-ons öffnen


  2. Gehen Sie im Tab der Add-ons-Verwaltung zum Abschnitt Erscheinungsbild.Gehen Sie im Tab der Add-ons-Verwaltung zum Abschnitt Erscheinungsbild.
  3. Markieren Sie das Standard-Theme und klicken auf die Schaltfläche Theme benutzen, um dieses Theme zu aktivieren.
  4. Klicken Sie auf Firefox neu starten.

Überprüfen Sie nach dem Neustart von Firefox, ob Ihr Problem weiterhin besteht.

  • Wenn das Problem nun nicht mehr auftritt, war das vorher genutzte Theme die Ursache des Fehlers.
  • Wenn das Problem weiterhin besteht, fahren Sie mit den folgenden Schritten in diesem Artikel fort.

Alle Erweiterungen deaktivieren

Um herauszufinden, ob eine fehlerhafte Erweiterung Ihr Problem verursacht, können Sie all Ihre installierten Erweiterungen deaktivieren:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche FirefoxKlicken Sie in der Menüleiste auf ExtrasKlicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie dann Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    FehlerbehebungPluginsWinXP_01 FehlerbehebungPluginsWin_01 FehlerbehebungPluginsMac_01 Fehlerbehebung Plugins Linux 01
    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    Windows: Australis - Add-ons öffnen Linux: Australis - Add-ons öffnen


  2. Gehen Sie im Tab der Add-ons-Verwaltung zum Abschnitt Erweiterungen.Gehen Sie im Tab der Add-ons-Verwaltung zum Abschnitt Erweiterungen.
  3. Klicken Sie auf den Namen einer Erweiterung in der Liste.
  4. Klicken Sie auf Deaktivieren, um die gewählte Erweiterung zu deaktivieren.
  5. Wiederholen Sie das bei jeder Erweiterung in der Liste.
  6. Klicken Sie auf Firefox neu starten.

Überprüfen Sie nach dem Neustart von Firefox, ob Ihr Problem weiterhin besteht.

  • Wenn das Problem weiterhin besteht, obwohl Sie alle Erweiterungen deaktiviert haben, liegt es höchstwahrscheinlich an einer kaputten Datei namens localstore.rdf in Ihrem Profilordner. Sie können Symbolleisten und Einstellungen zurücksetzen, um Ihr Problem zu beheben.
  • Wenn das Problem nun nicht mehr auftritt, ist eine Ihrer Erweiterungen die Ursache des Fehlers. Um herauszufinden, welche Erweiterung dafür verantwortlich ist, fahren Sie folgendermaßen fort:

Die fehlerhafte Erweiterung finden

Um herauszufinden, welche Ihrer deaktivierten Erweiterung das Problem verursacht, können Sie jede Erweiterung einzeln wieder aktivieren.

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche FirefoxKlicken Sie in der Menüleiste auf ExtrasKlicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie dann Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    FehlerbehebungPluginsWinXP_01 FehlerbehebungPluginsWin_01 FehlerbehebungPluginsMac_01 Fehlerbehebung Plugins Linux 01
    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    Windows: Australis - Add-ons öffnen Linux: Australis - Add-ons öffnen


  2. Gehen Sie im Tab der Add-ons-Verwaltung zum Abschnitt Erweiterungen.Gehen Sie im Tab der Add-ons-Verwaltung zum Abschnitt Erweiterungen.
  3. Klicken Sie auf den Namen einer Erweiterung in der Liste.
  4. Klicken Sie auf Aktivieren, um die gewählte Erweiterung zu aktivieren.
  5. Klicken Sie auf Firefox neu starten.

Überprüfen Sie nach dem Neustart von Firefox, ob Ihr Problem wieder auftritt. Wenn das Problem zurückgekehrt ist, ist jene Erweiterung die Ursache, die Sie zuletzt aktiviert haben.

Hinweis: Wenn Sie eine große Anzahl von Erweiterungen installiert haben, kann es schneller gehen, mehr als eine Erweiterung auf einmal wieder zu aktivieren. Die Methode, die am wenigsten Neustarts erfordert, lautet: Aktivieren Sie die Hälfte aller Erweiterungen in der Liste, starten Sie dann Firefox neu und überprüfen Sie, ob Ihr Problem auftritt. Wenn das der Fall ist, dann wissen Sie, dass sich die fehlerhafte Erweiterung unter denen befindet, die Sie soeben aktiviert haben. Wenn das Problem nicht auftritt, dann wissen Sie, dass sich die fehlerhafte Erweiterung bei den noch deaktivierten Erweiterungen befindet. Wiederholen Sie diesen Prozess und aktivieren bzw. deaktivieren Sie die Hälfte der noch nicht überprüften Erweiterungen, bis Sie die fehlerhafte Erweiterung gefunden haben.

Nachdem Sie die Erweiterung gefunden haben, die Ihr Problem verursacht, deaktivieren oder deinstallieren Sie diese und aktivieren Sie die anderen Erweiterungen im Add-ons-Fenster wieder.

Themes aktualisieren

Wenn ein installiertes Theme Ihr Problem verursacht, hilft möglicherweise ein verfügbares Update, um das Problem zu beseitigen:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche FirefoxKlicken Sie in der Menüleiste auf ExtrasKlicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie dann Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    FehlerbehebungPluginsWinXP_01 FehlerbehebungPluginsWin_01 FehlerbehebungPluginsMac_01 Fehlerbehebung Plugins Linux 01
    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    Windows: Australis - Add-ons öffnen Linux: Australis - Add-ons öffnen


  2. Gehen Sie im Tab der Add-ons-Verwaltung zum Abschnitt Erscheinungsbild.Gehen Sie im Tab der Add-ons-Verwaltung zum Abschnitt Erscheinungsbild.
  3. Um nach Updates für Ihre installierten Themes zu suchen, klicken Sie auf Aktualisieren.
  4. Wenn Updates gefunden werden, installieren Sie diese mit einem Klick auf Installieren.
  5. Wenn die Installation beendet ist, klicken Sie auf Firefox neu starten.

Nach dem Neustart von Firefox wurden Ihre Themes aktualisiert. Falls das Theme aktualisiert worden ist, das Ihr Problem verursacht hat, aktivieren Sie es wieder und überprüfen Sie erneut, ob Ihr Problem wieder auftritt.

Erweiterungen aktualisieren

Wenn eine installierte Erweiterung Ihr Problem verursacht, hilft möglicherweise ein verfügbares Update, um das Problem zu beseitigen:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche FirefoxKlicken Sie in der Menüleiste auf ExtrasKlicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie dann Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    FehlerbehebungPluginsWinXP_01 FehlerbehebungPluginsWin_01 FehlerbehebungPluginsMac_01 Fehlerbehebung Plugins Linux 01
    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    Windows: Australis - Add-ons öffnen Linux: Australis - Add-ons öffnen


  2. Gehen Sie im Tab der Add-ons-Verwaltung zum Abschnitt Erweiterungen.Gehen Sie im Tab der Add-ons-Verwaltung zum Abschnitt Erweiterungen.
  3. Um nach Updates für Ihre installierten Erweiterungen zu suchen, klicken Sie auf Aktualisieren.
  4. Wenn Updates gefunden werden, installieren Sie diese mit einem Klick auf Installieren.
  5. Wenn die Installation beendet ist, klicken Sie auf Firefox neu starten.

Nach dem Neustart von Firefox wurden Ihre Erweiterungen aktualisiert. Falls jene Erweiterung aktualisiert worden ist, die Ihr Problem verursacht hat, aktivieren Sie sie wieder und überprüfen Sie erneut, ob Ihr Problem wieder auftritt.

Erweiterungen-Einstellungen überprüfen

Einige Probleme werden dadurch hervorgerufen, dass Einstellungen von einer Erweiterung jene von Firefox überschreiben (z.B. bei Problemen mit Symbolleisten). Deshalb überprüfen Sie bitte die Einstellungen von Erweiterungen, um zu sehen, ob die eine darunter ist, die Ihr Problem verursacht:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche FirefoxKlicken Sie in der Menüleiste auf ExtrasKlicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie dann Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    FehlerbehebungPluginsWinXP_01 FehlerbehebungPluginsWin_01 FehlerbehebungPluginsMac_01 Fehlerbehebung Plugins Linux 01
    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    Windows: Australis - Add-ons öffnen Linux: Australis - Add-ons öffnen


  2. Gehen Sie im Tab der Add-ons-Verwaltung zum Abschnitt Erweiterungen.Gehen Sie im Tab der Add-ons-Verwaltung zum Abschnitt Erweiterungen.
  3. Klicken Sie bei der Erweiterung, die das Problem verursacht, auf die Schaltfläche Einstellungen.
  4. Klicken Sie durch die Einstellungen, um zu sehen, ob die eine darunter ist, die möglicherweise Ihr Problem beseitigt.



Teile diesen Artikel: http://mzl.la/MAyOQc

War der Artikel hilfreich? Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: ThomasLendo, Wawuschel, boersenfeger, fireflow321. Auch Sie können helfen – erfahren Sie, wie.