Viele Fenster oder Tabs öffnen sich nach dem Herunterladen von Dateien

Firefox öffnet wiederholt neue Tabs oder Fenster, nachdem Sie auf einen Hyperlink geklickt haben. Dies zwingt Sie dazu, Firefox zu beenden. Die gleichen Tabs oder Fenster öffnen sich beim nächsten Start von Firefox, wenn Sie die vorherige Sitzung wiederherstellen lassen.

Dies passiert meistens, wenn Sie Firefox als immer zu benutzendes Programm für Aktionen wie z. B. das Öffnen einer Grafik-Datei oder als Anwendung zum Senden von E-Mails gewählt haben.

Hinweis:

Das Zurücksetzen von Firefox in seinen Ausgangszustand kann viele Probleme beheben, wobei Sie wichtige Daten vorher sichern können. Ziehen Sie diese Art der Problembehebung in Erwägung, bevor Sie eine langwierige Suche nach der Ursache und der Lösung Ihres Problems beginnen.

Das Restaurieren von Firefox kann viele Probleme beheben, wobei wichtige Daten vorher gesichert werden. Ziehen Sie diese Art der Problembehebung in Erwägung, bevor Sie eine langwierige Suche nach der Ursache und der Lösung Ihres Problems beginnen.

Eine neue Firefox-Sitzung starten

Wenn Firefox wiederholt viele Fenster und Tabs öffnet, müssen Sie ihn möglicherweise schließen. Firefox enthält eine Sitzungswiederherstellungs-Funktion, die nach einem Absturz bzw. einem unerwarteten Schließen von Firefox, alle Tabs und Fenster wiederherstellen kann.

Beim nächsten Starten von Firefox öffnen sich die vielen Tabs und Fenster vielleicht wieder, was Sie erneut zum Schließen von Firefox zwingt. Wenn sich beim Neustarten von Firefox die Sitzungswiederherstellung öffnet (d. h. die Seite „Entschuldigung, das hätte nicht passieren dürfen.“), klicken Sie auf Neue Sitzung starten.

Sobald Sie eine neue Firefox-Sitzung gestartet haben, sollten Sie den untenstehenden Anleitungen folgen, damit das Problem nicht wieder auftritt.

Aktion für einen Dateityp ändern

Möglicherweise können Sie das Problem beheben, wenn Sie den Dateityp ausfindig machen, der das Verhalten auslöst. Dann können Sie mit den folgenden Schritten die auszuführende Aktion ändern:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie Einstellungen.Klicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie Einstellungen.Klicken Sie in der Menüleiste auf das das Menü Firefox und wählen Sie Einstellungen....Klicken Sie oben im Firefox-Fenster auf das Menü Bearbeiten (oder auf die Schaltfläche Firefox, wenn die Menüleiste ausgeblendet ist) und wählen Sie Einstellungen....

    Einstellungen - Fx20 - Win7


    EinstellungenFx4Win7.png


    Einstellungen - Fx20 - WinXP


    Einstellungen_Fx4_Linux


    010897fd58f6e294a60e43bbcf0ffe51-1281982768-69-1.png

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Einstellungen.

    Einstellungen öffnen - Fx29 - Win7



    Einstellungen öffnen - Fx29 - Win8



    Einstellungen öffnen - Fx37 - Win8.1



    Einstellungen öffnen - Fx29 - Linux



    Einstellugen öffnen - Fx34 - MacOS

  2. Wählen Sie den Abschnitt Anwendungen.
  3. Wenn Sie wissen, bei welchem Dateityp das Problem auftritt, markieren Sie diesen. Andernfalls tippen Sie in die Suchleiste verwenden. In der Liste erscheinen nun alle Inhalte, die z. B. mit Firefox geöffnet werden.

    ed0244a0fac9ffb9b697febbe04e8de3-1271188453-536-1.png



    ed0244a0fac9ffb9b697febbe04e8de3-1271189703-608-1.png



    ed0244a0fac9ffb9b697febbe04e8de3-1280426803-918-1.png

  4. Für jeden problematischen Dateityp wählen Sie nun eine andere Anwendung in der Aktionsspalte aus. Wenn Sie nicht sicher sind, welche Anwendung dafür zuständig ist, wählen Sie Jedes Mal nachfragen.
  5. Klicken Sie auf OK, um das Einstellungen-Fenster zu schließenKlicken Sie auf Schließen, um das Einstellungen-Fenster zu schließenSchließen Sie das Einstellungen-FensterSchließen Sie den Einstellungen-Tab (about:preferences). Alle Änderungen, die Sie vorgenommen haben, werden dabei automatisch gespeichert. .

Allgemeine Informationen über Datei- oder Inhaltstypen erhalten Sie im Artikel Einstellen, was Firefox tun soll, wenn eine Datei angeklickt oder heruntergeladen wird.

Aktionen für alle Dateitypen zurücksetzen

Wenn die vorherigen Schritte das Problem nicht beseitigen oder Sie die auslösende Aktion in der Liste nicht finden können, müssen Sie die Einstellungen für alle Dateitypen durch manuelles Löschen zurücksetzen.

Dies setzt alle Einstellungen – nicht nur die ein Problem auslösenden – für Dateitypen-Aktionen zurück. Danach müssen Sie Ihre gewünschten Einstellungen erneut festlegen.
  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet. Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder mit ihm zu arbeiten, folgen Sie der Anleitung Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    Profilordner öffnen - Fx29 - Win8 Profilordner öffnen - Fx29 - Linux Profilordner öffnen - Fx35 - Mac

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Schließen Sie Firefox:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie den Eintrag Beenden. Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie BeendenBeenden Firefox 29 Schließen .

  4. Löschen Sie die Datei mimeTypes.rdf.
  5. Starten Sie Firefox.

Auf Schadprogramme prüfen

Wenn das Problem nicht behoben werden kann, sollten Sie in Erwägung ziehen, dass Ihr System möglicherweise von Schadprogrammen befallen ist. Lesen Sie dazu den Artikel Von Malware verursachte Firefox-Probleme beheben für weitere Anweisungen.

 


Diesen Artikel teilen: http://mzl.la/1xKrFbP

War der Artikel hilfreich? Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: Wawuschel, pollti. Auch Sie können helfen – erfahren Sie, wie.