Die Sicherheitskomponenten der Anwendung konnten nicht initialisiert werden

Dieser Artikel befasst sich mit den Ursachen der Meldung „Die Sicherheitskomponenten der Anwendung konnten nicht initialisiert werden. Der wahrscheinlichste Grund dafür sind Probleme mit Dateien im Profilverzeichnis der Anwendung. Bitte überprüfen Sie, ob das Verzeichnis keine Lese- oder Schreibbeschränkungen hat und Ihre Festplatte nicht voll oder fast voll ist. Es wird empfohlen, dass Sie die Anwendung jetzt beenden und das Problem beheben. Wenn Sie diese Sitzung weiter verwenden, könnten Sie unkorrektes Verhalten der Anwendung beim Zugriff auf Sicherheitsfunktionen feststellen.“.

420addfc0b553d29e930f016402df008-1286110880-462-1.png ErrorSicherheitskomponentenMac.png ErrorSicherheitskomponentenLinux.png

Informationen zu anderen Meldungen, die Sie beim Aufrufen von Webseiten erhalten, finden Sie im Artikel Webseiten laden nicht – Fehlersuche und Fehlermeldungen beheben.

Festplattenplatz

Prüfen Sie, ob Sie noch genug freien Speicherplatz auf Ihrer Festplatte haben.

  • (Windows Vista/7)
    1. Klicken Sie doppelt mit der Maus auf Computer auf Ihrem Desktop oder öffnen Sie es über die Windows-Start-Schaltfläche am linken unteren Bildschirmrand.
    2. Klicken Sie mit der rechten Maustaste auf das Laufwerk C:.
    3. Wählen Sie Eigenschaften. Das Eigenschaften-Dialogfenster öffnet sich.
    4. Gehen Sie zum Reiter Allgemein.
  • (Windows XP)
    1. Klicken Sie doppelt mit der Maus auf Arbeitsplatz auf Ihrem Desktop oder öffnen Sie es über die Windows-Start-Schaltfläche am linken unteren Bildschirmrand.
    2. Klicken Sie mit der rechten Maustaste auf das Laufwerk C:.
    3. Wählen Sie Eigenschaften. Das Eigenschaften-Dialogfenster öffnet sich.
    4. Gehen Sie zum Reiter Allgemein.
  1. Gehen Sie zu Ihrem Schreibtisch.
    • Drücken Sie F11.
  2. Wählen Sie Macintosh HD aus.
  3. Drücken Sie die Befehlstaste+I, um das Informationsfenster von Macintosh HD anzuzeigen.
  • (GNOME wie bei Ubuntu, Fedora)
    1. Klicken Sie auf das Menü Orte und wählen Sie Rechner (oder Computer).
    2. Klicken Sie mit der rechten Maustaste auf Dateisystem.
    3. Wählen Sie Eigenschaften. Das Eigenschaften-Dialogfenster öffnet sich.
    4. Gehen Sie zum Reiter Grundlegend.
  • (KDE wie bei Kubuntu, openSUSE, Knoppix)
    1. Klicken Sie auf den K-Anwendungs-Starter am linken unteren Bildschirmrand.
    2. Klicken Sie auf Programme, dann auf System und dann auf Dateimanager (Dolphin).
    3. Klicken Sie mit der rechten Maustaste auf irgend einen Ordner.
    4. Wählen Sie Eigenschaften. Das Eigenschaften-Dialogfenster öffnet sich.
    5. Gehen Sie zum Reiter Allgemein.

Wenn weniger als 1 MB freier Speicherplatz angezeigt werden, müssen Sie mehr Platz schaffen.

Dateiberechtigungen

Prüfen Sie die Dateiberechtigungen im Profilordner Ihres Firefox. Die Datei cert8.db darf nicht schreibgeschützt sein.

  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  4. Klicken Sie mit der rechten Maustaste auf die Datei cert8.db.
  5. Wählen Sie Eigenschaften. Ein Dialogfenster wird sich öffnen.
  6. Gehen Sie zum Reiter Allgemein.
  7. Stellen Sie sicher, dass bei Attribute kein Häkchen vor Schreibgeschützt gesetzt ist.

    420addfc0b553d29e930f016402df008-1278446452-520-1.png
  8. Klicken Sie auf OK.
  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  4. Klicken Sie mit der rechten Maustaste auf die Datei cert8.db.
  5. Drücken Sie die Befehlstaste+I, um das Informationsfenster der Datei cert8.db zu öffnen.
  6. Erweitern Sie den Abschnitt Zugriff & Berechtigungen.
  7. Stellen Sie sicher, dass Ihr Mac-Nutzerkonto Schreib- und Leserechte besitzt.
  8. Schließen Sie das Informationsfenster der Datei cert8.db wieder.
  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  4. Klicken Sie mit der rechten Maustaste auf die Datei cert8.db.
  5. Wählen Sie Eigenschaften, um das Eigenschaften-Fenster zu öffnen.
    • (GNOME) Gehen Sie im Eigenschaften-Fenster zum Reiter Zugriffsrechte. Stellen Sie sicher, dass Ihr Benutzerkonto Schreibrechte für diese Datei besitzt.
    • (KDE) Gehen Sie im Eigenschaften-Fenster zum Reiter Berechtigungen. Stellen Sie sicher, dass Ihr Benutzerkonto Schreibrechte für diese Datei besitzt.
  6. Klicken Sie auf Schließen.

Starten Sie Firefox neu. Das Problem könnte damit behoben sein.

Beschädigte Datei

Die Datei cert8.db in Ihrem Profilordner von Firefox könnte beschädigt worden sein. Löschen Sie diese Datei, während Firefox geschlossen ist.

  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  4. Klicken Sie auf die Datei cert8.db.
  5. Drücken Sie auf die Befehlstaste+Entfernen.
  6. Starten Sie Firefox neu.
Die Datei cert8.db wird neu erstellt, wenn Sie Firefox neu starten. Das ist normal.

Neue Profile

Ihre Firefox-Einstellungen können durch Änderungen an Ihrem Betriebssystem oder durch zu wenig Festplattenplatz beschädigt worden sein. Erstellen Sie ein neues Profil über den Profil-Manager. Falls das Problem im neuen Profil nicht mehr auftritt, können Sie Ihre Einstellungen in das neue Profil übertragen. Wenn das Problem weiterhin auftritt, können Sie zu Ihrem ursprünglichen Profil zurückkehren.




Basiert auf Informationen des Artikels Could not initialize the browser security component (mozillaZine KB)

War der Artikel hilfreich? Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: ThomasLendo, Wawuschel. Auch Sie können helfen – erfahren Sie, wie.