Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox doesn't recognize my Firefox browser

  • 8 svar
  • 3 har dette problem
  • 18 visninger
  • Seneste svar af will547_us

more options

I ONLY use Firefox 25. I'm trying to add a search engine(duck duck go) to my tool bar. When I click manage search engines and try to "Add To Fiorefox" I'm told I must use Firefox as a browser. I ONLY use Firefox 25???

Alle svar (8)

more options

That is hard to understand. There are some external security products that can change or your browser identification (user agent). If you view a site that shows what you sent, do you see anything unusual? For example:


On the DDG home page, at the bottom, there is a link to Add to Browser that pops up some choices. Do any of those work?

more options

Per More System Details - you have the DuckDuckGo Plus 0.3.8 extension installed.

https://addons.mozilla.org/en-US/firefox/addon/duckduckgo-for-firefox/ says it adds a DDG search engine. Maybe that "must use Firefox as a browser" message is triggered because you already have that search plugin?

more options

Why isn't it or how can I get DDG back in the search window drop down? It was there along with Google, Yahoo, etc. It is no longer.

I did find a keyboard shortcut to use DDG but I'm still curious as to why it was removed from the search engine list???

more options

No they did not. Even more curious is why DDG shows in my Firefox add-ons but it is no longer in the search window drop down menu?

more options

That would be a question for DuckDuckGo support.

I don't use that add-on, I use DDG search plugin alone. I have no use for the other features provided by that add-on.

more options

This issue can be caused by an extension that isn't working properly.

Make sure that you do not block JavaScript.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

Ændret af cor-el den

more options

I feel we can probably put this question to rest although I feel it is unresolved. I now have a DDG icon at the upper right corner of the tool bar, I guess that will suffice. I have a laptop with the same OS and version of Firefox with DDG still listed in the search window drop down??

I tried the restart in safe mode and I noticed nothing different.

Thanks for your help!

more options

If you click on your second suggested link and look at the first image you will see where I want to return. If you read this instruction you will wonder as i do where DDG went?

"About this Add-on DuckDuckGo is a search engine that does not track you. We believe that better search and real privacy are not mutually exclusive.

This add-on will:

1. Add DuckDuckGo as your default search engine in the search bar."

When I click add this to Firefox I'm told I must be using Firefox, tres bizzare, no?