Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not playing youtube videos in normal mode

  • 2 svar
  • 1 har dette problem
  • 2 visninger
  • Seneste svar af BrockyTaz

more options

I am running Firefox v 120.0 (64bit) on Windows 10 Pro version 22H2 OS build 19045.3570 and today Firefox has stopped playing the video track on youtube videos or any video that is embedded in a page. Audio works but the screen just shows a blank field of green. The progress bar will show frames from the video. IF I run Firefox in trouble shooting mode the videos play as normal with video and audio tracks.

I have already refreshed fire fox and uninstalled and reinstalled it but the video track is still a blank field of green in both full screen and small screen modes.

Anyone have any ideas on what configuration setting may be causing this? Thanks in advance, Brocky

I am running Firefox v 120.0 (64bit) on Windows 10 Pro version 22H2 OS build 19045.3570 and today Firefox has stopped playing the video track on youtube videos or any video that is embedded in a page. Audio works but the screen just shows a blank field of green. The progress bar will show frames from the video. IF I run Firefox in trouble shooting mode the videos play as normal with video and audio tracks. I have already refreshed fire fox and uninstalled and reinstalled it but the video track is still a blank field of green in both full screen and small screen modes. Anyone have any ideas on what configuration setting may be causing this? Thanks in advance, Brocky
Vedhæftede skærmbilleder

Valgt løsning

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin), always make sure such extensions do not block content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings), click the padlock icon (Clear cookies and site data) for the domain in the selected tab.

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages like blocked content.

Læs dette svar i sammenhæng 👍 1

Alle svar (2)

more options

Valgt løsning

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin), always make sure such extensions do not block content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings), click the padlock icon (Clear cookies and site data) for the domain in the selected tab.

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages like blocked content.

more options

Hello cor-el, It was the hardware acceleration option. This was happening on my very elderly Dell studio laptop. As soon as I read the words "hardware acceleration" I remembered I had this issue several years back when Firefox updated to the next version and enabled the use hardware acceleration option. I checked and it was enabled. I disabled the switch and videos are playing again. Yayyy!

Thanks for the assist and have a great day. Brocky