Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

On latest update my firefox tabs show at the bottom of my browser

  • 3 svar
  • 1 har dette problem
  • 22 visninger
  • Seneste svar af cor-el

more options

Hi all,

On your latest install Firefox 108.0.1 my tabs have moved to the bottom of my browser near my taksbar in window 10. The tabs are not working correctly. Please fix. Thank you.

P.S. it working in firefox safe mode. The tabs show a the top of screen and you can add multiple tabs.

Richard M. Ambrosino

Hi all, On your latest install Firefox 108.0.1 my tabs have moved to the bottom of my browser near my taksbar in window 10. The tabs are not working correctly. Please fix. Thank you. P.S. it working in firefox safe mode. The tabs show a the top of screen and you can add multiple tabs. Richard M. Ambrosino
Vedhæftede skærmbilleder

Alle svar (3)

more options

This is possibly a problem with your userChrome.css file in case you use this file to style the user interface as we have seen more reports about userChrome.css getting broken in Firefox 108. You need to check whether there is an update available from its creator.

more options

Hi all,

My userChrom.css file contained the following code:

@import url(addressbar.css) screen;

/* Colored folders for bookmark sidebar, toolbar, menu button */
  /* Standard folder */
#bookmarks-view treechildren::-moz-tree-image(container),
#PlacesToolbarItems toolbarbutton[container="true"] .toolbarbutton-icon,
#PlacesToolbarItems menu[container="true"] .menu-iconic-left,
#BMB_bookmarksPopup menu[container="true"] .menu-iconic-icon {
  fill: #e8bb00 !important; /* slightly muted gold */
}
  /* Live Bookmark (RSS Feed) */
#bookmarks-view treechildren::-moz-tree-image(container, livemark),
#PlacesToolbarItems toolbarbutton[container="true"][livemark="true"] .toolbarbutton-icon,
#PlacesToolbarItems menu[container="true"][livemark="true"] .menu-iconic-left,
#BMB_bookmarksPopup menu[container="true"][livemark="true"] .menu-iconic-icon {
  fill: orange !important;
}
  /* Smart bookmark folder */
#bookmarks-view treechildren::-moz-tree-image(container, query),
#PlacesToolbarItems toolbarbutton[container="true"][query="true"] .toolbarbutton-icon,
#PlacesToolbarItems menu[container="true"][query="true"] .menu-iconic-left,
#BMB_bookmarksPopup menu[container="true"][query="true"] .menu-iconic-icon {
  fill: #69c !important; /* similar to blue smart folder color */
}
  /* These "containers" are SVG in the sidebar, not yet on the menu */
#bookmarks-view treechildren::-moz-tree-image(container, OrganizerQuery_BookmarksMenu) {
  fill: olive !important;
}
#bookmarks-view treechildren::-moz-tree-image(container, OrganizerQuery_BookmarksToolbar) {
  fill: olive !important;
}
#bookmarks-view treechildren::-moz-tree-image(container, OrganizerQuery_UnfiledBookmarks) {
  fill: olive !important;
}

/* Tab bar below Navigation & Bookmarks Toolbars 
   For best results, show Title Bar or Menu Bar */
#nav-bar { /* main toolbar */
  -moz-box-ordinal-group: 1 !important;
  border-top-width: 0 !important; 
}
#PersonalToolbar { /* bookmarks toolbar */
  -moz-box-ordinal-group: 2 !important;
}
#TabsToolbar { /* tab bar */
  -moz-box-ordinal-group: 3 !important;
}


/* Hide blue stripe on active tab */
.tab-line[selected="true"] {
  opacity: 0 !important;
}


*********************************
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* TABS on bottom */
#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {-moz-box-ordinal-group:10}
#TabsToolbar {-moz-box-ordinal-group:1000!important}

#TabsToolbar {
 height: var(--tab-min-height) !important;
 position: absolute !important;
 bottom: 0 !important;
 width: 100vw !important;
}

#tabbrowser-tabs,
.tab-stack,
.tab-content {
  height: var(--tab-min-height) !important;
}

*|*:root:not([chromehidden*="toolbar"]) #navigator-toolbox {
  padding-bottom: var(--tab-min-height) !important;
  position: relative !important; /*required in 89+*/
}

/* do not use in Firefox 108+, needed in 102 ESR */
/*
#tabbrowser-tabs {
  width: 100vw !important;
}*/

***********************************************************

So what I did was I commented out a section of code:

/* TABS on bottom */ /*#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {-moz-box-ordinal-group:10}

  1. TabsToolbar {-moz-box-ordinal-group:1000!important}*/
*****************************************************************

I then closed out of firefox and then restarted. It seems to have worked!!! If their is a better solution let me know. I will attach a screen shot. Thank you.

Rick Ambrosino

Ændret af cor-el den

more options

I've updated the Tabs below the Navigation Toolbar CSS code in your above reply and it now should work in Firefox 198 and later.

Note that you only need one @namespace line in userChrome.css. @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once at the start and below possible @import lines */