On Monday September 25th from 10PM EDT - 12AM EDT (2AM UTC - 4AM UTC on September 26th), we will be performing system maintenance on the Firefox Accounts databases for two hours. During the maintenance window, there will be brief periods of a few minutes where users will not be able to login to their accounts. Please try again at a later time.

Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Need to make Firefox stop automatically downloading PDF files. None of the suggested fixes work.

  • 5 svar
  • 4 har dette problem
  • 54 visninger
  • Seneste svar af James

more options

I need to know how to stop firefox from automatically downloading every PDF file I look at. I’ve tried all of the suggested fixes on Mozilla and various other sites to no avail. None of them work. I’ve tried the following:

Going into settings, downloads, and checking “Always ask you where to save files.” Didn’t work.

Going into settings, applications, and under PDF, choosing “always ask.” Didn’t work.

Going into settings, applications, and under PDF, choosing “open in firefox.” Didn’t work.

Going into about:config and changing browser.download.alwaysOpenPanel from true to false. Didn’t work

None of these fixes stopped firefox from automatically downloading pdf files. I can’t just click on a pdf file to look at it without firefox downloading it.

I’m at wit’s end. My recylcle bin is full of unwanted pdf files.

Please give me a solution that actually works. My version is 105.0.3.

I need to know how to stop firefox from automatically downloading every PDF file I look at. I’ve tried all of the suggested fixes on Mozilla and various other sites to no avail. None of them work. I’ve tried the following: Going into settings, downloads, and checking “Always ask you where to save files.” Didn’t work. Going into settings, applications, and under PDF, choosing “always ask.” Didn’t work. Going into settings, applications, and under PDF, choosing “open in firefox.” Didn’t work. Going into about:config and changing browser.download.alwaysOpenPanel from true to false. Didn’t work None of these fixes stopped firefox from automatically downloading pdf files. I can’t just click on a pdf file to look at it without firefox downloading it. I’m at wit’s end. My recylcle bin is full of unwanted pdf files. Please give me a solution that actually works. My version is 105.0.3.

Alle svar (5)

more options

A file has to be downloaded by a browser for you to open it. Before the recent change, opened files were saved to the system's temp folder. There is now a preference in about:config to do that again. browser.download.start_downloads_in_tmp_dir Change the value to true.

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

more options

What's the other about:config that affects this? Now instead of my downloads folder filling up with worthless pdf files, my temp folder is filling up with them instead.

more options

I omitted to post a link to the comment in the relevant bug report. Your temp folder should be cleared by your OS at some point.

https://bugzilla.mozilla.org/show_bug.cgi?id=1738574#c133

more options

I finally solved this problem by removing the Avast! antivirus from my computer. It had taken over part of Firefox and was forcing the download of PDF documents instead of letting me choose whether to just open them or to download them. Case closed.

more options

The outdated information you may have seen posted by Dropa mentioning the browser.download.improvements_to_download_panel Preference will NOT work as it was for Fx 98.0 to 101.0. The Preference for Fx 102.0 to current is browser.download.start_downloads_in_tmp_dir

Please be careful with all about:config changes. Please read Firefox advanced customization and configuration options and Configuration Editor for Firefox to learn more.

Also the first reply posted by Terry had the correct Preference.

Ændret af James den