Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Search (not in address bar)

  • 7 svar
  • 1 har dette problem
  • 38 visninger
  • Seneste svar af csurvine

more options

I intentionally set my browser so that I can search from the search box in the center of this page. However, when I start typing in that box I get all kinds of stuff from the address bar blocking the box and what I'm typing. I don't want to search from the address bar, I want to use that search box. How do I get this feature back?

Before, all I had to do was uncheck the box in the second screen shot but that no longer seems to work. What's the new trick or why have the search box if you can't search from it?

Also, after a search, my links always opened in a new tab. That no longer seems to be working that way. I prefer my links open in a new tab in case I want to look at other results while keeping that tab available.

Vedhæftede skærmbilleder

Valgt løsning

What happens is that as soon as you type the first character in the search box, the cursor jumps up to the address bar. The address bar gives you matches from your history, bookmarks, and open tabs even if you turned off search engine suggestions (the ones fetched from Google).

There is a preference to switch it back, but it does take a bit of work to find it because of the unusual name:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true (move cursor to address bar) to false (keep cursor in search box)

Success?

More info on about:config: Configuration Editor for Firefox.

Læs dette svar i sammenhæng 👍 2

Alle svar (7)

more options

Valgt løsning

What happens is that as soon as you type the first character in the search box, the cursor jumps up to the address bar. The address bar gives you matches from your history, bookmarks, and open tabs even if you turned off search engine suggestions (the ones fetched from Google).

There is a preference to switch it back, but it does take a bit of work to find it because of the unusual name:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true (move cursor to address bar) to false (keep cursor in search box)

Success?

More info on about:config: Configuration Editor for Firefox.

Nyttig?

more options

I don't know if this worked because I got frustrated and went back to a previous version. I will update and try again this weekend.

Curious, what's the option for that says, "show search suggestions in address bar results" if it no longer stops or makes that happen? Why have an option that seems to do nothing? I appreciate the "about:config" solution, but will I have to do this after each update?

Also, after a search, the links I click have always opened in another tab and not in the tab I used to search. Anyway to get that back? That's a very important option for me, I do a lot of research and may use several links from my search results that I keep in separate tabs.

Nyttig?

more options

"Search suggestions" refers to asking your default search engine to return maybe half a dozen phrases based on the text you have typed in the search box so far. In my view, it's useful when you are searching for something in the new and you are in a hurry or aren't confident about the spelling of a word/name. Otherwise, I don't think they are useful.

"Search suggestions" doesn't cover matches from bookmarks, history, and open tabs, which have their own individual checkboxes on the privacy settings panel.

Regarding opening search results page links in a new tab, this is a search engine setting. For example, on Google, look for the "Where results open" section on this page:

https://www.google.com/preferences

Although Google and other sites refer to a new window, by default, Firefox diverts new windows to a new tab instead.

Nyttig?

more options

Cool, I didn't realize that. In the past (until a recent version) it let me search in the box instead of the address bar. Whenever the courser jumped to the address bar I just unchecked that box and it stopped???

As for the search, see attached, I have google set to open in new window and this has always been the case for the last at least 10 years I remember. It also works when I downgraded the browser back to a previous version. However, this wasn't working with the updated browser which is one of the reasons I went back to a previous version???

Can you see if yours is working right? It sure wasn't working that way for me but then again, I used a lot of drugs in the past...

Nyttig?

more options

The "new window" option works for me if I turn it on (in Firefox 89).

Did your results layout change? Some users occasionally get more of a mobile-style layout and that one might not implement all of the same behaviors as the desktop layout. This typically is caused by a Google user interface experiment, and you typically can escape by clearing your cache and Google cookies.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache (just "web cache", not all of the site data)

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first).

While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try searching again from the original search box (not in the same page). Does that help?

Nyttig?

more options

Note: after clearing cookies, you'll need to tweak those preferences again.

Nyttig?

more options

I stand corrected with the open links in new tabs, I signon in our churches account to set up the service for each week. It was the churches account that didn't have that setting set. All is well in Soapm land...

Thanks for all the help...

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.