Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Maps goes black (again)

  • 3 svar
  • 1 har dette problem
  • 1523 visninger
  • Seneste svar af madclarky

more options

Since a few days, when I visit Google Maps, after completely loading the page (roads and buildings shown for a brief moment) the map becomes wholly black with just captions still readable.

Doing the following didn't fix: Restart Firefox. Update Nvidia Drivers (updated yesterday to 466.11, didn't resolve). Disable every add-on and setting default theme. Disable Hardware Acceleration from settings.

THIS temporarily fixed: Entering Firefox Troubleshoot mode.

So I assume the problem is in advanced settings. There are TONS of settings there. Any ideas? I 'd rather not go through a Firefox Refresh losing all site permissions/fine tuning for cookie settings/blocked content for every site made in years. I'm on Firefox 88, Windows 10 64bit ver. 2004, GeForce 950M, Core i7-4720HQ, 16GB RAM.


I put "again" in the title since another question about this is marked as solved for Firefox 68/69. Needless to say, I tried everything from that discussion (such as switching gfx.webrender.all), to no avail for the present issue.

Since a few days, when I visit Google Maps, after completely loading the page (roads and buildings shown for a brief moment) the map becomes wholly black with just captions still readable. Doing the following didn't fix: Restart Firefox. Update Nvidia Drivers (updated yesterday to 466.11, didn't resolve). Disable every add-on and setting default theme. Disable Hardware Acceleration from settings. THIS temporarily fixed: Entering Firefox Troubleshoot mode. So I assume the problem is in advanced settings. There are TONS of settings there. Any ideas? I 'd rather not go through a Firefox Refresh losing all site permissions/fine tuning for cookie settings/blocked content for every site made in years. I'm on Firefox 88, Windows 10 64bit ver. 2004, GeForce 950M, Core i7-4720HQ, 16GB RAM. I put "again" in the title since another [https://support.mozilla.org/en-US/questions/1263534 question] about this is marked as solved for Firefox 68/69. Needless to say, I tried everything from that discussion (such as switching gfx.webrender.all), to no avail for the present issue.
Vedhæftede skærmbilleder

Valgt løsning

Well, I apparently solved the problem. it was caused by wrong settings in the about:config page. I post here the solution in case it may help others with similar issue.

For reasons I don't remember, I forced the following options to TRUE: webgl.all-angle-options webgl.enable-privileged-extensions webgl.force-enabled

by reverting them to FALSE, Maps started working correctly again. it solved also some issues with other webgl based apps and browser games that weren't working anymore (not all webgl pages had stopped working because of those settings though, which is why I didn't point out the solution very soon)

Læs dette svar i sammenhæng 👍 0

Alle svar (3)

more options

You can check the Web Console for possible (WebGL) error messages.

more options

These are the WebGL lines shown on my console everytime I refresh Maps page. The blackening always occurs after the fourth line, after which all next lines appear alltogether. Errors selected but it catches just warnings. I'm sorry, I'm not competent enough to understand anything from this output. Am I missing something?


WebGL warning: texSubImage: Texture has not been initialized prior to a partial upload, forcing the browser to clear it. This may be slow. WebGL warning: texSubImage: Tex image TEXTURE_2D level 0 is incurring lazy initialization. WebGL warning: texSubImage: Texture has not been initialized prior to a partial upload, forcing the browser to clear it. This may be slow. WebGL warning: texSubImage: Tex image TEXTURE_2D level 0 is incurring lazy initialization. WebGL warning: texSubImage: Texture has not been initialized prior to a partial upload, forcing the browser to clear it. This may be slow. WebGL warning: texSubImage: Tex image TEXTURE_2D level 0 is incurring lazy initialization. WebGL warning: texSubImage: Texture has not been initialized prior to a partial upload, forcing the browser to clear it. This may be slow. WebGL warning: texSubImage: Tex image TEXTURE_2D level 0 is incurring lazy initialization. WebGL warning: texSubImage: Texture has not been initialized prior to a partial upload, forcing the browser to clear it. This may be slow. WebGL warning: texSubImage: Tex image TEXTURE_2D level 0 is incurring lazy initialization. WebGL warning: texSubImage: Texture has not been initialized prior to a partial upload, forcing the browser to clear it. This may be slow. WebGL warning: texSubImage: Tex image TEXTURE_2D level 0 is incurring lazy initialization. WebGL warning: linkProgram: Must have an compiled fragment shader attached. WebGL warning: useProgram: Program must be linked successfully. 19 After reporting 32, no further warnings will be reported for this WebGL context.


EDIT: these are the errors reported by not filtering with "WebGL". Sorry for Italian language :)

Previsto “none”, URL o una funzione filtro, invece è stato rilevato “progid”. Errore durante l’interpretazione di “filter”. Dichiarazione tralasciata. @45.1837495,13.4559925,6z:471:19684 Elementi che corrispondono al selettore: .gb_4 Previsto “none”, URL o una funzione filtro, invece è stato rilevato “progid”. Errore durante l’interpretazione di “filter”. Dichiarazione tralasciata. @45.1837495,13.4559925,6z:471:20126 Elementi che corrispondono al selettore: .gb_4:active Previsto “none”, URL o una funzione filtro, invece è stato rilevato “progid”. Errore durante l’interpretazione di “filter”. Dichiarazione tralasciata. @45.1837495,13.4559925,6z:471:44686 Elementi che corrispondono al selettore: .gb_Ed Previsto “none”, URL o una funzione filtro, invece è stato rilevato “progid”. Errore durante l’interpretazione di “filter”. Dichiarazione tralasciata. @45.1837495,13.4559925,6z:471:45178 Elementi che corrispondono al selettore: .gb_Ed:hover Previsto “none”, URL o una funzione filtro, invece è stato rilevato “progid”. Errore durante l’interpretazione di “filter”. Dichiarazione tralasciata. @45.1837495,13.4559925,6z:471:53773 Elementi che corrispondono al selettore: #gbqfb Previsto “none”, URL o una funzione filtro, invece è stato rilevato “progid”. Errore durante l’interpretazione di “filter”. Dichiarazione tralasciata. @45.1837495,13.4559925,6z:471:54486 Elementi che corrispondono al selettore: #gbqfb:active:active Previsto “none”, URL o una funzione filtro, invece è stato rilevato “progid”. Errore durante l’interpretazione di “filter”. Dichiarazione tralasciata. @45.1837495,13.4559925,6z:471:56868 Elementi che corrispondono al selettore: .gbqfba:hover Previsto “none”, URL o una funzione filtro, invece è stato rilevato “progid”. Errore durante l’interpretazione di “filter”. Dichiarazione tralasciata. @45.1837495,13.4559925,6z:471:57404 Elementi che corrispondono al selettore: .gbqfba Errore durante l’interpretazione di “-moz-box-flex”. Dichiarazione tralasciata. @45.1837495,13.4559925,6z:471:61299 Errore durante l’interpretazione di “-webkit-perspective”. Dichiarazione tralasciata. @45.1837495,13.4559925,6z:1:758 Elementi che corrispondono al selettore: .tile-image-3d Errore durante l’interpretazione di “perspective”. Dichiarazione tralasciata. @45.1837495,13.4559925,6z:1:810 Elementi che corrispondono al selettore: .tile-image-3d Errore durante l’interpretazione di “-moz-perspective”. Dichiarazione tralasciata. @45.1837495,13.4559925,6z:1:859 Elementi che corrispondono al selettore: .tile-image-3d Errore durante l’interpretazione di “left”. Dichiarazione tralasciata. @45.1837495,13.4559925,6z

Ændret af madclarky den

more options

Valgt løsning

Well, I apparently solved the problem. it was caused by wrong settings in the about:config page. I post here the solution in case it may help others with similar issue.

For reasons I don't remember, I forced the following options to TRUE: webgl.all-angle-options webgl.enable-privileged-extensions webgl.force-enabled

by reverting them to FALSE, Maps started working correctly again. it solved also some issues with other webgl based apps and browser games that weren't working anymore (not all webgl pages had stopped working because of those settings though, which is why I didn't point out the solution very soon)