Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Open links in tabs instead of new windows

more options

All of a sudden, my Firefox browser started Opening links in new windows instead of new tabs. In tools>options>tabs: Open links in tabs instead of new windows is check marked. it still opens in new window

All of a sudden, my Firefox browser started Opening links in new windows instead of new tabs. In tools>options>tabs: Open links in tabs instead of new windows is check marked. it still opens in new window

Alle svar (12)

more options

Hi, that setting covers a certain scenario where the links in the page are targeted to open in a new window instead of in the same tab. There are settings to address some other scenarios, too, so let me give you a tour of the back end:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste neww and pause while the list is filtered

Normally you'll see four rows starting with browser.link.open_newwindow:

(3) Review/Edit the preference values as follows (double-click the current value to open an editing field, and then when you're done, press Enter or click the blue checkmark to save the change):

(A) browser.link.open_newwindow - for links in Firefox tabs

This is the one that has a checkbox on the Preferences page and determines whether targeted links are allowed to open in a new window or are diverted to a new tab instead; there's no effect on untargeted links:

  • 3 = divert new window to a new tab (default) <= Make sure this is still set
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

By default, if a page sets width, height, or toolbars for a popup, Firefox will open it in a "dialog-style" window. To force those into a tab as well, you can change this preference to 0:

  • 0 = apply the setting under (A) to ALL new windows <= set this to tame scripted windows
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

This preference governs those external links that open in Firefox (not directly relevant to your question):

  • -1 = apply the setting under (A) to external links (default) <= Usually best, or try setting to 3
  • 3 = open external links in a new tab in the last active window
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

To return to normal if things go haywire, there's an arrow-like reset button at the right end of each of those rows if it has a non-default value.

Working any better?

more options

Thanks but, it not work. See Uploaded images. What did I do wrong

more options

That looks fine.

Have you tried doing a regular shutdown and restart of Firefox since this problem started?

Do you use any add-ons related to containers or container tabs?

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

I shut down and did a restart. Problem is still there. It still opens links in a new window instead of a new tab.

As for containers, I don't use containers or add-ons that I know off. I looked up containers and elected to try to edit an existing container. To do so I found an instruction, "To edit an existing container, click the Firefox multi-account containers icon, then click Edit. The Firefox multi-account containers icon illustration that was given and shown in Uploaded image below was not their. Can assume that, because the icon is not there, I have no containers, so that is not the problem?

more options

Boot the computer in Windows Safe Mode with network support to see if that has effect.


You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

I refreshed Firefox and the tried to open a link. The link did not open in a new window so, that part of the problem is fixed but now, instead of a new tab, it replaced the current tab with the new link. So, now the problem is that it is not opening in a new tab and keeping the current tab in tact. Tools > options > Tabs > only Open links in tabs instead of new windows > Check Marked.

About:config neww is marked as what was recommended and shown in Browse add images.

I attempted to open Firefox in safe mode at https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode > How to start Firefox in Safe Mode. The link did not work. The nonworking link is also shown in Browse add images.

more options

mark_church said

I refreshed Firefox and the tried to open a link. The link did not open in a new window so, that part of the problem is fixed but now, instead of a new tab, it replaced the current tab with the new link. So, now the problem is that it is not opening in a new tab and keeping the current tab in tact. Tools > options > Tabs > only Open links in tabs instead of new windows > Check Marked.

Are you using any container extensions, such as Facebook Container? When you click a link to a site that needs to open in a different container from the page containing the link, and it is not directed to a new window or tab, then Firefox will close the current tab while opening the container tab. Test whether you can restore the closed tab using either:

  • right-click a tab > Undo Close Tab
  • Ctrl+Shift+t

Is that what seems to be happening?

more options

The search speedtest produced a current tab of many speed test links. Choosing Speedtest by Ookla (https://www.speedtest.net/) replaced the current tab with Speedtest by Ookla.

Hitting the back arrow brought the current tab of many speed test links back to current tab

Pressing Ctrl+Shift+t duplicated the Speedtest by Ookla in a new tab without changing the current tab back to a tab of many speed test links. In other words two identical tabs of Speedtest by Ookla

right-click a tab > Undo Close Tab proposal did not bring the current tab of many speed test links back to current tab. it duplicated the Speedtest by Ookla tab. So now three tabs of Speedtest by Ookla. no current tab of many speed test links. many speed test links.

more options

I figured out how to get into Firefox safe mode. I cleared cookies, history etc. I restart my computer. It did not fix the issue. It does not open in a new window any more. That is a big improvement but it still opens in the same tab. My computer was slowing by having too many windows open and I was slowing in productivity by having to keep track of them. At least now that is not happening. The last suggestion in trouble shooting was to uninstall and reinstall Firefox. I did that and it still does not open in a new tab. It opens in the same tab. I guess this is the best we can do.

more options

The setting in "Options/Preferences -> General -> Tabs" applies only to links that specify a target window and allows to divert a new window to a new tab. Links that do not specify a target window will open in the same tab unless you force opening in a new tab by holding the Ctrl key or by middle-clicking with the mouse wheel, so what you experience might be quite normal.

more options

mark_church said

The search speedtest produced a current tab of many speed test links. Choosing Speedtest by Ookla (https://www.speedtest.net/) replaced the current tab with Speedtest by Ookla. Hitting the back arrow brought the current tab of many speed test links back to current tab

That sounds normal.

Pressing Ctrl+Shift+t duplicated the Speedtest by Ookla in a new tab without changing the current tab back to a tab of many speed test links. In other words two identical tabs of Speedtest by Ookla right-click a tab > Undo Close Tab proposal did not bring the current tab of many speed test links back to current tab. it duplicated the Speedtest by Ookla tab. So now three tabs of Speedtest by Ookla. no current tab of many speed test links. many speed test links.

Since your "good" tab didn't close, I don't know what these two tabs were. ??